]> git.pld-linux.org Git - packages/nfs-utils.git/commitdiff
- updated to 2.4.3 auto/th/nfs-utils-2.4.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 16 May 2020 08:25:44 +0000 (10:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 16 May 2020 08:25:44 +0000 (10:25 +0200)
- removed obsolete types patch
- added sh patch (kill bashism)

nfs-utils-sh.patch [new file with mode: 0644]
nfs-utils-types.patch [deleted file]
nfs-utils.spec

diff --git a/nfs-utils-sh.patch b/nfs-utils-sh.patch
new file mode 100644 (file)
index 0000000..4d5da19
--- /dev/null
@@ -0,0 +1,11 @@
+--- nfs-utils-2.4.3/configure.ac.orig  2020-02-09 20:41:19.000000000 +0100
++++ nfs-utils-2.4.3/configure.ac       2020-05-16 10:00:17.813179249 +0200
+@@ -622,7 +622,7 @@
+   AC_MSG_CHECKING([whether CC supports $1])
+   AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+     [AC_MSG_RESULT([yes])]
+-    [$2+=$1],
++    [$2="$$2 $1"],
+     [AC_MSG_RESULT([no])]
+   )
+   CFLAGS="$my_save_cflags"
diff --git a/nfs-utils-types.patch b/nfs-utils-types.patch
deleted file mode 100644 (file)
index ce39b8a..0000000
+++ /dev/null
@@ -1,105 +0,0 @@
---- nfs-utils-2.4.2/utils/nfsdcld/nfsdcld.c.orig       2019-11-29 16:50:34.858389742 +0100
-+++ nfs-utils-2.4.2/utils/nfsdcld/nfsdcld.c    2019-11-29 16:50:38.298371106 +0100
-@@ -378,7 +378,7 @@
-       bsize = cld_message_size(cmsg);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize)
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-       /* reopen pipe, just to be sure */
-@@ -409,7 +409,7 @@
-       xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
-@@ -459,7 +459,7 @@
-       xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
-@@ -498,7 +498,7 @@
-                       cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
-@@ -548,7 +548,7 @@
-                       cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
-@@ -607,7 +607,7 @@
-       xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
-@@ -667,7 +667,7 @@
-       xlog(D_GENERAL, "Doing downcall with status %d", cmsg->cm_status);
-       wsize = atomicio((void *)write, clnt->cl_fd, cmsg, bsize);
-       if (wsize != bsize) {
--              xlog(L_ERROR, "%s: problem writing to cld pipe (%ld): %m",
-+              xlog(L_ERROR, "%s: problem writing to cld pipe (%zd): %m",
-                        __func__, wsize);
-               ret = cld_pipe_open(clnt);
-               if (ret) {
---- nfs-utils-2.4.2/utils/nfsdcld/sqlite.c.orig        2019-11-13 18:09:41.000000000 +0100
-+++ nfs-utils-2.4.2/utils/nfsdcld/sqlite.c     2019-11-29 16:52:19.827821073 +0100
-@@ -512,7 +512,7 @@
-       current_epoch = tcur;
-       recovery_epoch = trec;
-       ret = 0;
--      xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
-+      xlog(D_GENERAL, "%s: current_epoch=%"PRIu64" recovery_epoch=%"PRIu64,
-               __func__, current_epoch, recovery_epoch);
- out:
-       sqlite3_finalize(stmt);
-@@ -1223,7 +1223,7 @@
-       current_epoch = tcur;
-       recovery_epoch = trec;
--      xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
-+      xlog(D_GENERAL, "%s: current_epoch=%"PRIu64" recovery_epoch=%"PRIu64,
-               __func__, current_epoch, recovery_epoch);
- out:
-@@ -1282,7 +1282,7 @@
-       }
-       recovery_epoch = 0;
--      xlog(D_GENERAL, "%s: current_epoch=%lu recovery_epoch=%lu",
-+      xlog(D_GENERAL, "%s: current_epoch=%"PRIu64" recovery_epoch=%"PRIu64,
-               __func__, current_epoch, recovery_epoch);
- out:
---- nfs-utils-2.4.2/utils/nfsdcltrack/nfsdcltrack.c.orig       2019-12-01 08:16:29.090420366 +0100
-+++ nfs-utils-2.4.2/utils/nfsdcltrack/nfsdcltrack.c    2019-12-01 08:16:36.084104443 +0100
-@@ -525,7 +525,7 @@
-       if (*tail)
-               return -EINVAL;
--      xlog(D_GENERAL, "%s: grace done. gracetime=%ld", __func__, gracetime);
-+      xlog(D_GENERAL, "%s: grace done. gracetime=%lld", __func__, (long long)gracetime);
-       ret = sqlite_remove_unreclaimed(gracetime);
index df916620ed0fdfc63aaba7757fde1ae4a1382716..5de3aa6044384b6baf88aed2d034ee38428de298 100644 (file)
@@ -10,12 +10,12 @@ Summary(pt_BR.UTF-8):       Os utilitários para o cliente e servidor NFS do Linux
 Summary(ru.UTF-8):     Утилиты для NFS и демоны поддержки для NFS-сервера ядра
 Summary(uk.UTF-8):     Утиліти для NFS та демони підтримки для NFS-сервера ядра
 Name:          nfs-utils
-Version:       2.4.2
-Release:       4
+Version:       2.4.3
+Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       https://www.kernel.org/pub/linux/utils/nfs-utils/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: d427c6b3014e9a04e8498f0598b1c1b9
+# Source0-md5: 06020c76f531ed97f3145514901e0e7c
 #Source1:      ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/nfs.doc.tar.gz
 Source1:       nfs.doc.tar.gz
 # Source1-md5: ae7db9c61c5ad04f83bb99e5caed73da
@@ -49,7 +49,7 @@ Patch3:               %{name}-union-mount.patch
 Patch4:                %{name}-heimdal.patch
 Patch5:                %{name}-x32.patch
 Patch6:                libnfsidmap-pluginpath.patch
-Patch7:                %{name}-types.patch
+Patch7:                %{name}-sh.patch
 URL:           http://linux-nfs.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -65,7 +65,10 @@ BuildRequires:       libwrap-devel
 BuildRequires: openldap-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.623
 BuildRequires: sqlite3-devel >= 3.3
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 %if %{with tirpc}
 BuildRequires: libtirpc-devel >= 1:0.1.10-4
 %else
@@ -76,7 +79,6 @@ BuildRequires:        krb5-devel >= 1.6
 %else
 BuildRequires: heimdal-devel >= 1.0
 %endif
-BuildRequires: rpmbuild(macros) >= 1.623
 # lucid context fields mismatch with current version of spkm3.h
 BuildConflicts:        gss_mech_spkm3-devel
 Requires(post):        fileutils
@@ -325,7 +327,7 @@ install %{SOURCE104} $RPM_BUILD_ROOT%{systemdunitdir}/nfsd-exportfs.service
 install %{SOURCE105} $RPM_BUILD_ROOT%{systemdunitdir}/gssd.service
 # TODO: upstream installs nfs-idmapd.service
 install %{SOURCE106} $RPM_BUILD_ROOT%{systemdunitdir}/idmapd.service
-# TODO: upstream installs rpc-statd.service + nfs-statd-notify.service
+# TODO: upstream installs rpc-statd.service + rpc-statd-notify.service
 install %{SOURCE107} $RPM_BUILD_ROOT%{systemdunitdir}/nfslock.service
 # TODO: upstream installs nfs-mountd.service
 install %{SOURCE108} $RPM_BUILD_ROOT%{systemdunitdir}/nfsd-mountd.service
@@ -478,12 +480,12 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README html
-%attr(755,root,root) /sbin/nfsdcld
 %attr(755,root,root) /sbin/nfsdcltrack
 %attr(755,root,root) /sbin/rpcdebug
 %attr(755,root,root) /sbin/fsck.nfs
 %attr(755,root,root) %{_sbindir}/clddb-tool
 %attr(755,root,root) %{_sbindir}/exportfs
+%attr(755,root,root) %{_sbindir}/nfsdcld
 %attr(755,root,root) %{_sbindir}/rpc.mountd
 %attr(755,root,root) %{_sbindir}/rpc.nfsd
 %attr(755,root,root) %{_sbindir}/rpc.svcgssd
@@ -521,6 +523,7 @@ fi
 %{systemdunitdir}/nfsd.service
 %{systemdunitdir}/nfsd-exportfs.service
 %{systemdunitdir}/nfsd-mountd.service
+%{systemdunitdir}/nfsdcld.service
 %{systemdunitdir}/svcgssd.service
 %{systemdunitdir}/proc-fs-nfsd.mount
 %attr(755,root,root) %{_datadir}/nfs-utils/nfsd.postconfig
This page took 0.212775 seconds and 4 git commands to generate.