]> git.pld-linux.org Git - packages/mutt.git/commitdiff
- updated to 1.12.0
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 25 Jun 2019 12:05:01 +0000 (14:05 +0200)
committerAdam Gołębiowski <adamg@pld-linux.org>
Tue, 25 Jun 2019 12:05:01 +0000 (14:05 +0200)
mutt-crypt-autoselectkey.patch
mutt-keep_to.patch
mutt-vvv.quote.patch
mutt-xface.patch
mutt.spec

index 1431c77020f167985cf15d92407da119ff9ae292..fa550d9699e4336cab341554547991bd025f2520 100644 (file)
@@ -63,9 +63,9 @@
 +  }
  
 @@ -599,5 +621,3 @@ static pgp_key_t pgp_select_key (pgp_key
-       
--      if (option (OPTPGPCHECKTRUST) &&
--        (!pgp_id_is_valid (KeyTable[menu->current])
--         || !pgp_id_is_strong (KeyTable[menu->current])))
+
+-        if (option (OPTPGPCHECKTRUST) &&
+-            (!pgp_id_is_valid (KeyTable[menu->current])
+-             || !pgp_id_is_strong (KeyTable[menu->current])))
 +      if (!pgp_trusted_id(KeyTable[menu->current]))
-       {
+         {
index 70567b1c4eeb65e2f8d613622dfabaca3362b546..f99fd29bb31f8bbf2b4cd89ea69309000447ed4b 100644 (file)
@@ -5,19 +5,15 @@ author: Jan Palus
 diff -urN mutt-1.5.23.orig/send.c mutt-1.5.23/send.c
 --- mutt-1.5.23.orig/send.c    2014-10-12 16:55:39.680846728 +0200
 +++ mutt-1.5.23/send.c 2014-10-12 16:55:52.104179682 +0200
-@@ -557,7 +557,11 @@
-     if ((flags & SENDGROUPREPLY) && (!in->mail_followup_to || hmfupto != M_YES))
+@@ -672,7 +672,7 @@
+         (!in->mail_followup_to || hmfupto != MUTT_YES))
      {
-       /* if(!mutt_addr_is_user(in->to)) */
--      rfc822_append (&out->cc, in->to, 1);
-+      if (option (OPTKEEPTO)) {
-+        rfc822_append (&out->to, in->to, 1);
-+      } else {
-+        rfc822_append (&out->cc, in->to, 1);
-+      }
-       rfc822_append (&out->cc, in->cc, 1);
-     }
-   }
+       /* if (!mutt_addr_is_user(in->to)) */
+-      if (flags & SENDGROUPREPLY)
++      if ( (flags & SENDGROUPREPLY) || ! option(OPTKEEPTO) )
+         rfc822_append (&out->cc, in->to, 1);
+       else
+         rfc822_append (&out->to, in->to, 1);
 diff -ur mutt-1.5.23.orig/init.h mutt-1.5.23/init.h
 --- mutt-1.5.23.orig/init.h    2014-10-12 17:17:05.716118306 +0200
 +++ mutt-1.5.23/init.h 2014-10-12 17:24:08.119438749 +0200
index 647062e88583792a87bc15e8c9938e7760c72c28..cd641a16919ad650ada91eaef77d52a9e4bfa10c 100644 (file)
@@ -34,7 +34,7 @@ diff -udprP mutt-1.5.19.orig/handler.c mutt-1.5.19/handler.c
 @@ -1617,7 +1621,7 @@ int mutt_body_handler (BODY *b, STATE *s
         */
        if ((WithCrypto & APPLICATION_PGP) && mutt_is_application_pgp (b))
-       handler = crypt_pgp_application_pgp_handler;
+       encrypted_handler = handler = crypt_pgp_application_pgp_handler;
 -      else if (option(OPTREFLOWTEXT) && ascii_strcasecmp ("flowed", mutt_get_parameter ("format", b->parameter)) == 0)
 +      else if (option(OPTREFLOWTEXT) && ascii_strcasecmp ("flowed", mutt_get_parameter ("format", b->parameter)) == 0 && !s->prefix)
        handler = rfc3676_handler;
index 32558956f2c8a938c356dd9c623e737aa899a694..230aced5461ff6cad86883b03ce55f004002e646 100644 (file)
@@ -120,9 +120,9 @@ diff -urp ../MUTT/mutt/init.c mutt/init.c
  
  void toggle_quadoption (int opt)
 @@ -2356,3 +2358,130 @@ int mutt_get_hook_type (const char *name
    return 1;
  }
 +void mutt_start_slrnface(void)
 +{
 +  char *fifo;
@@ -275,9 +275,9 @@ diff -urp ../MUTT/mutt/main.c mutt/main.c
  
 +    mutt_start_slrnface();
 +
-     if((Context = mx_open_mailbox (folder, ((flags & MUTT_RO) || option (OPTREADONLY)) ? MUTT_READONLY : 0, NULL))
-        || !explicit_folder)
-     {
+     Context = mx_open_mailbox (mutt_b2s (folder),
+                                ((flags & MUTT_RO) || option (OPTREADONLY)) ? MUTT_READONLY : 0,
+                                NULL);
 @@ -913,6 +915,8 @@ int main (int argc, char **argv)
      }
  
@@ -407,61 +407,39 @@ diff -urp ../MUTT/mutt/pager.c mutt/pager.c
          pager_menu->redraw = REDRAW_FULL;
          InHelp = 0;
        }
-@@ -2383,58 +2448,70 @@ CHECK_IMAP_ACL(IMAP_ACL_WRITE);
+@@ -2649,7 +2649,9 @@
        case OP_MAIL:
        CHECK_MODE(IsHeader (extra) && !IsAttach (extra));
-         CHECK_ATTACH;      
-+      mutt_suppress_xface ();
+         CHECK_ATTACH;
++      mutt_suppress_xface();
        ci_send_message (0, NULL, NULL, extra->ctx, NULL);
-+      mutt_show_xface ();
++      mutt_show_xface();
        pager_menu->redraw = REDRAW_FULL;
        break;
  
-       case OP_REPLY:
+@@ -2662,6 +2664,7 @@
        CHECK_MODE(IsHeader (extra) || IsMsgAttach (extra));
-         CHECK_ATTACH;      
+         CHECK_ATTACH;
 +      mutt_suppress_xface();
-         if (IsMsgAttach (extra)) 
-         mutt_attach_reply (extra->fp, extra->hdr, extra->actx,
-                            extra->bdy, SENDREPLY);
+         replyflags = SENDREPLY |
+         (ch == OP_GROUP_REPLY ? SENDGROUPREPLY : 0) |
+@@ -2673,6 +2676,7 @@
+                            extra->bdy, replyflags);
        else
-         ci_send_message (SENDREPLY, NULL, NULL, extra->ctx, extra->hdr);
-+      mutt_show_xface ();
+         ci_send_message (replyflags, NULL, NULL, extra->ctx, extra->hdr);
++      mutt_show_xface();
        pager_menu->redraw = REDRAW_FULL;
        break;
+       }
+@@ -2680,19 +2684,23 @@
        case OP_RECALL_MESSAGE:
        CHECK_MODE(IsHeader (extra) && !IsAttach(extra));
          CHECK_ATTACH;
 +      mutt_suppress_xface();
        ci_send_message (SENDPOSTPONED, NULL, NULL, extra->ctx, extra->hdr);
-+      mutt_show_xface ();
-       pager_menu->redraw = REDRAW_FULL;
-       break;
-       case OP_GROUP_REPLY:
-       CHECK_MODE(IsHeader (extra) || IsMsgAttach (extra));
-         CHECK_ATTACH;
-+      mutt_suppress_xface();
-         if (IsMsgAttach (extra))
-         mutt_attach_reply (extra->fp, extra->hdr, extra->actx,
-                            extra->bdy, SENDREPLY|SENDGROUPREPLY);
-         else
-         ci_send_message (SENDREPLY | SENDGROUPREPLY, NULL, NULL, extra->ctx, extra->hdr);
-+      mutt_suppress_xface ();
-       pager_menu->redraw = REDRAW_FULL;
-       break;
-       case OP_LIST_REPLY:
-       CHECK_MODE(IsHeader (extra) || IsMsgAttach (extra));
-         CHECK_ATTACH;        
-+      mutt_suppress_xface();
-         if (IsMsgAttach (extra))
-         mutt_attach_reply (extra->fp, extra->hdr, extra->actx,
-                            extra->bdy, SENDREPLY|SENDLISTREPLY);
-         else
-         ci_send_message (SENDREPLY | SENDLISTREPLY, NULL, NULL, extra->ctx, extra->hdr);
-+      mutt_show_xface ();
++      mutt_show_xface();
        pager_menu->redraw = REDRAW_FULL;
        break;
  
@@ -474,10 +452,11 @@ diff -urp ../MUTT/mutt/pager.c mutt/pager.c
                               extra->bdy);
          else
          ci_send_message (SENDFORWARD, NULL, NULL, extra->ctx, extra->hdr);
-+      mutt_show_xface ();
        pager_menu->redraw = REDRAW_FULL;
++      mutt_show_xface();
        break;
  
+       case OP_DECRYPT_SAVE:
 @@ -2485,7 +2562,9 @@ CHECK_IMAP_ACL(IMAP_ACL_WRITE);
        break;
  
@@ -527,17 +506,17 @@ diff -urp ../MUTT/mutt/parse.c mutt/parse.c
  {
    LIST *t, *lst = NULL;
 @@ -1231,6 +1252,11 @@ int mutt_parse_rfc822_line (ENVELOPE *e,
-       e->x_label = safe_strdup(p);
-       matched = 1;
-     }
+         e->x_label = safe_strdup(p);
+         matched = 1;
+       }
 +    else if (ascii_strcasecmp (line+1, "-face") == 0)
 +    {
 +      e->x_face = mutt_add_x_face (e->x_face, p);
 +      matched = 1;
 +    }
-     
      default:
-     break;
+       break;
 diff -urp ../MUTT/mutt/sendlib.c mutt/sendlib.c
 --- ../MUTT/mutt/sendlib.c     2004-07-21 13:33:02.000000000 +0200
 +++ mutt/sendlib.c     2004-07-21 13:37:16.000000000 +0200
@@ -554,6 +533,6 @@ diff -urp ../MUTT/mutt/sendlib.c mutt/sendlib.c
 +      fprintf (fp, "X-Face: %s\n", face->data);
 +  }
 +
-   if (mode == 0 && !privacy && option (OPTXMAILER) && !has_agent)
+   if (mode == MUTT_WRITE_HEADER_NORMAL && !privacy &&
+       option (OPTXMAILER) && !has_agent)
    {
-     /* Add a vanity header */
index b510029c0c753067c590cc0be4b13b25dddfc4f1..bc65b74065e2f13cfafe009768265c233c949f8a 100644 (file)
--- a/mutt.spec
+++ b/mutt.spec
@@ -30,14 +30,14 @@ Summary(ru.UTF-8):  Почтовая клиентская программа Mutt
 Summary(tr.UTF-8):     Mutt elektronik posta programı
 Summary(uk.UTF-8):     Поштова клієнтська програма Mutt
 Name:          mutt
-Version:       1.11.4
+Version:       1.12.0
 Release:       1
 Epoch:         6
 License:       GPL v2+
 Group:         Applications/Mail
 # temporarily dead? (Jun 2014)
 Source0:       ftp://ftp.mutt.org/pub/mutt/%{name}-%{version}.tar.gz
-# Source0-md5: e6b3e8e437b554beafdce0baa34d9adc
+# Source0-md5: 2a6491745de2f76631aa06a6f2b46a7b
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 Source3:       %{name}.1.pl
This page took 0.046279 seconds and 4 git commands to generate.