]> git.pld-linux.org Git - packages/mutt.git/blob - mutt.spec
f142da4ae28d6a1bd1d4607c843ce05e4f3d8f74
[packages/mutt.git] / mutt.spec
1 #
2 # TODO:
3 # - gss/heimdal
4 # - finish -folder_columns.patch
5 # - update/drop -home_etc.patch
6 # - update/drop -imap_recent.patch
7 #
8 # Conditional build:
9 %bcond_with     slang           # use slang library instead of ncurses
10 %bcond_with     nntp            # use VVV's NNTP patch
11 %bcond_with     folder_column   # build with folder_column patch
12 %bcond_with     imap_recent     # show IMAP RECENT messages as new (instead of UNSEEN)
13 %bcond_without  sasl            # don't use sasl
14 %bcond_with     home_etc        # use home_etc
15 %bcond_with     gdbm            # use GDBM instead of BerkeleyDB
16 %bcond_with     qdbm            # use QDBM instead of BerkeleyDB
17 %bcond_with     tokyocabinet    # use TokyoCabinet instead of BerkeleyDB
18 #
19 %if %{without gdbm} && %{without qdbm} && %{without tokyocabinet}
20 %define with_bdb        1
21 %endif
22 Summary:        The Mutt Mail User Agent
23 Summary(de.UTF-8):      Der Mutt Mail-User-Agent
24 Summary(es.UTF-8):      Mutt, cliente de correo electrónico
25 Summary(fr.UTF-8):      Agent courrier Mutt
26 Summary(ko.UTF-8):      텍스트 기반의 MUA
27 Summary(pl.UTF-8):      Program pocztowy Mutt
28 Summary(pt_BR.UTF-8):   Mutt, cliente de correio eletrônico
29 Summary(ru.UTF-8):      Почтовая клиентская программа Mutt
30 Summary(tr.UTF-8):      Mutt elektronik posta programı
31 Summary(uk.UTF-8):      Поштова клієнтська програма Mutt
32 Name:           mutt
33 Version:        1.12.1
34 Release:        1
35 Epoch:          6
36 License:        GPL v2+
37 Group:          Applications/Mail
38 # temporarily dead? (Jun 2014)
39 Source0:        ftp://ftp.mutt.org/pub/mutt/%{name}-%{version}.tar.gz
40 # Source0-md5:  f77586a895f12d19de9c5250a4dfd034
41 Source1:        %{name}.desktop
42 Source2:        %{name}.png
43 Source3:        %{name}.1.pl
44 Patch0:         %{name}-pl.po-update.patch
45 Patch1:         %{name}-bj.status-time.patch
46 # http://mutt.org.ua/download/
47 Patch2:         %{name}-vvv.quote.patch
48 Patch3:         %{name}-null_name.patch
49 Patch4:         %{name}-cd.signatures_menu.patch
50 # http://www.mutt.ca/patches/ (dw.crypt-autoselectkey)
51 Patch5:         %{name}-crypt-autoselectkey.patch
52 Patch6:         %{name}-manual.patch
53 Patch7:         %{name}-xface.patch
54 Patch8:         %{name}-Muttrc_mbox_path.patch
55 Patch9:         %{name}-po.patch
56 Patch10:        %{name}-Muttrc.head.patch
57 Patch11:        %{name}-smime.rc.patch
58 Patch12:        %{name}-db.patch
59 Patch13:        format-security.patch
60 Patch14:        %{name}-keep_to.patch
61 Patch15:        %{name}-vvv.initials.patch
62 # applied during %%install
63 Patch50:        %{name}-Muttrc.patch
64 # bcond-related patches
65 Patch101:       %{name}-home_etc.patch
66 # http://mutt.org.ua/download/
67 Patch102:       %{name}-vvv.nntp.patch
68 Patch103:       %{name}-folder_columns.patch
69 Patch104:       %{name}-imap_recent.patch
70 URL:            http://www.mutt.org/
71 BuildRequires:  autoconf >= 2.54
72 BuildRequires:  automake >= 1.6
73 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.1.0}
74 %{?with_bdb:BuildRequires:      db-devel >= 4.0}
75 BuildRequires:  docbook-dtd42-xml
76 BuildRequires:  docbook-style-xsl
77 %{?with_gdbm:BuildRequires:     gdbm-devel}
78 BuildRequires:  gettext-tools
79 BuildRequires:  gpgme-devel >= 1:1.4.0
80 %{?with_home_etc:BuildRequires: home-etc-devel >= 1.0.8}
81 BuildRequires:  libgpg-error-devel >= 1.33
82 BuildRequires:  libidn-devel
83 BuildRequires:  libxslt-progs
84 BuildRequires:  lynx
85 %{!?with_slang:BuildRequires:   ncurses-devel >= 5.0}
86 BuildRequires:  openssl-devel >= 0.9.7d
87 %{?with_qdbm:BuildRequires:     qdbm-devel}
88 %{?with_slang:BuildRequires:    slang-devel}
89 %{?with_tokyocabinet:BuildRequires:     tokyocabinet-devel}
90 Requires:       gpgme >= 1:1.4.0
91 %{?with_home_etc:Requires:      home-etc-lib >= 1.0.8}
92 Requires:       iconv
93 Requires:       libgpg-error >= 1.33
94 Suggests:       mailcap
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         specflags_ia32  -fomit-frame-pointer
98
99 %description
100 Mutt is a small but very poweful full-screen Unix mail client.
101 Features include MIME support, color, POP3 support, message threading,
102 bindable keys, and threaded sorting mode.
103
104 %description -l de.UTF-8
105 Mutt ist ein kleiner aber leistungsfähiger Vollbild-Mail-Client für
106 Unix mit MIME-Unterstützung, Farbe, POP3-Unterstützung,
107 Nachrichten-Threading, zuweisbaren Tasten und Sortieren nach Threads.
108
109 %description -l es.UTF-8
110 Mutt es un pequeño, pero muy potente cliente de correo en pantalla
111 llena. Incluye soporte a tipos MINE, color, POP3; encadenamiento de
112 mensajes, teclas configurables y clasificaciones por encadenamiento.
113
114 %description -l fr.UTF-8
115 mutt est un client courrier Unix plein écran, petit mais très
116 puissant. Il dispose de la gestion MIME, des couleurs, de la gestion
117 POP, des fils de discussion, des touches liées et d'un mode de tri sur
118 les fils.
119
120 %description -l ko.UTF-8
121 Mutt는 작지만 매우 강력한 텍스트 기반의 메일 클라이언트이다. Mutt는 많은 설정이 가능하다. 그리고, 키바인딩, 키보드
122 메크로, 메일 스레딩과 같은 진보된 형태와 정규표현식 검색, 메일에서 선택된 그룹의 내용에서 강력하게 일정한 패턴을 찾아내는
123 것을 지원함으로써 메일의 파워 유저에게 가장 적합하다.
124
125 %description -l pl.UTF-8
126 Mutt jest niewielkim programem pocztowym dla terminali tekstowych,
127 posiadającym duże możliwości. Obsługuje MIME, POP3, cztery formaty
128 skrzynek pocztowych, kolory, wątki, ocenę ważności listów (scoring)
129 oraz skompresowane foldery.
130
131 %description -l pt_BR.UTF-8
132 O Mutt é um pequeno mas muito poderoso cliente de correio em tela
133 cheia. Inclui suporte a tipos MIME, cor, POP3, encadeamento de
134 mensagens, teclas configuráveis e classificação por encadeamento.
135
136 %description -l ru.UTF-8
137 Mutt - это небольшой, но мощный полноэкранный почтовый клиент.
138 Включает поддержку MIME, цвет, поддержку POP3 и IMAP, группировку
139 сообщений по цепочкам, переопределяемые клавиши, поддержку pgp/gpg и
140 сортировку сообщений в цепочках. Включает также (пока что
141 экспериментальную) поддержку NNTP.
142
143 %description -l tr.UTF-8
144 Mutt, küçük ama çok güçlü bir tam-ekran Unix mektup istemcisidir. MIME
145 desteği, renk ve POP3 desteği içerir.
146
147 %description -l uk.UTF-8
148 Mutt - це невеликий, але потужний повноекранний поштовий клієнт.
149 Містить підтримку MIME, колір, підтримку POP3 та IMAP, групування
150 повідомлень по ланцюжкам, перевизначення клавіш, підтримку pgp/gpg та
151 сортування повідомлень у ланцюжках. Містить також (поки що
152 експериментальну) підтримку NNTP.
153
154 %prep
155 %setup -q
156 # pl.poupdate
157 #%patch0 -p1
158 %patch1 -p1
159 %patch2 -p1
160 %patch3 -p1
161 %patch4 -p1
162 %patch5 -p1
163 %patch6 -p1
164 %patch7 -p1
165 %patch8 -p1
166 %patch9 -p1
167 %patch10 -p1
168 %patch11 -p1
169 %patch12 -p1
170 %patch13 -p1
171 %patch14 -p1
172 %patch15 -p1
173
174 %{?with_home_etc:%patch101 -p1}
175 %{?with_nntp:%patch102 -p1}
176 # breaks display if arrow_cursor is set
177 %{?with_folder_column:%patch103 -p1}
178 %{?with_imap_recent:%patch1043 -p1}
179
180 # force regeneration (manual.sgml is modified by some patches)
181 %{__rm} doc/{manual*.html,manual.txt}
182
183 %build
184 %{__aclocal} -I m4
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188 %configure \
189         mutt_cv_groupwrite=yes \
190         mutt_cv_worldwrite=no \
191         %{!?debug:--disable-debug} %{?debug:--enable-debug} \
192         --disable-warnings \
193         --enable-compressed \
194         --enable-external-dotlock \
195         --enable-gpgme \
196         --enable-hcache \
197         --enable-imap \
198         --enable-mailtool \
199         %{?with_nntp:--enable-nntp} \
200         --enable-pop \
201         --enable-sidebar \
202         --enable-smtp \
203         %{?with_bdb:--with-bdb=/usr} \
204         %{!?with_slang:--with-curses} \
205         --with-docdir=%{_docdir}/%{name} \
206         %{?with_gdbm:--with-gdbm} \
207         %{?with_home_etc:--with-home-etc} \
208         --with-mailpath=/var/mail \
209         --with-mixmaster \
210         %{?with_qdbm:--with-qdbm} \
211         --with-regex \
212         %{?with_sasl:--with-sasl} \
213         %{?with_slang:--with-slang} \
214         --with-ssl \
215         %{?with_tokyocabinet:--with-tokyocabinet}
216
217 %{__make} -j1 -C doc
218 %{__make}
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1} \
223         $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
224
225 %{__make} install \
226         DESTDIR=$RPM_BUILD_ROOT \
227         DOTLOCK_GROUP=
228
229 %{__patch} -p2 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH50}
230
231 install contrib/gpg.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
232 install contrib/smime.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
233 install contrib/colors.linux $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d/colors.rc
234
235 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
236 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
237 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
238
239 cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/mutt_source-muttrc.d
240 #!/bin/sh -e
241 for rc in %{_sysconfdir}/Muttrc.d/*.rc; do
242         [ ! -r "$rc" ] || echo "source \"$rc\""
243 done
244 EOF
245
246 # keep manual.txt.gz, the rest is installed as %doc
247 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
248
249 # conflict with qmail
250 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
251 # belongs to mailcap
252 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
253
254 %find_lang %{name}
255
256 %clean
257 rm -rf $RPM_BUILD_ROOT
258
259 %post   -p /sbin/postshell
260 -/usr/sbin/fix-info-dir -c %{_infodir}
261
262 %postun -p /sbin/postshell
263 -/usr/sbin/fix-info-dir -c %{_infodir}
264
265 %files -f %{name}.lang
266 %defattr(644,root,root,755)
267 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL
268 %dir %{_sysconfdir}/Muttrc.d
269 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc
270 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc.d/*.rc
271 %attr(755,root,root) %{_bindir}/mutt
272 %attr(755,root,root) %{_bindir}/mutt_pgpring
273 %attr(755,root,root) %{_bindir}/mutt_source-muttrc.d
274 %attr(755,root,root) %{_bindir}/flea
275 %attr(755,root,root) %{_bindir}/muttbug
276 %attr(755,root,root) %{_bindir}/pgp*
277 %attr(755,root,root) %{_bindir}/smime_keys
278 %attr(2755,root,mail) %{_bindir}/mutt_dotlock
279
280 %{_docdir}/%{name}
281 %{_desktopdir}/mutt.desktop
282 %{_pixmapsdir}/mutt.png
283 #%{_mandir}/man1/flea.1*
284 %{_mandir}/man1/mutt*.1*
285 %{_mandir}/man1/pgp*.1*
286 %{_mandir}/man1/smime_keys.1*
287 %{_mandir}/man5/mmdf.5*
288 %{_mandir}/man5/muttrc.5*
289 %lang(pl) %{_mandir}/pl/man1/*
290 %{_infodir}/mutt.info*
This page took 0.105549 seconds and 3 git commands to generate.