]> git.pld-linux.org Git - packages/mutt.git/blob - mutt.spec
- todo about patches that need to be updated, renumbered patch list
[packages/mutt.git] / mutt.spec
1 #
2 # TODO:
3 # - gss/heimdal
4 # - finish -folder_columns.patch
5 # - update/drop -home_etc.patch
6 # - update/drop -nntp.patch
7 # - update/drop -imap_recent.patch
8 # - update -pl.po-update.patch
9 #
10 # Conditional build:
11 %bcond_with     slang           # use slang library instead of ncurses
12 %bcond_with     nntp            # use VVV's NNTP patch
13 %bcond_with     folder_column   # build with folder_column patch
14 %bcond_with     imap_recent     # show IMAP RECENT messages as new (instead of UNSEEN)
15 %bcond_without  sasl            # don't use sasl
16 %bcond_with     home_etc        # use home_etc
17 %bcond_with     gdbm            # use GDBM instead of BerkeleyDB
18 %bcond_with     qdbm            # use QDBM instead of BerkeleyDB
19 %bcond_with     tokyocabinet    # use TokyoCabinet instead of BerkeleyDB
20 #
21 %if %{without gdbm} && %{without qdbm} && %{without tokyocabinet}
22 %define with_bdb        1
23 %endif
24 Summary:        The Mutt Mail User Agent
25 Summary(de.UTF-8):      Der Mutt Mail-User-Agent
26 Summary(es.UTF-8):      Mutt, cliente de correo electrónico
27 Summary(fr.UTF-8):      Agent courrier Mutt
28 Summary(ko.UTF-8):      텍스트 기반의 MUA
29 Summary(pl.UTF-8):      Program pocztowy Mutt
30 Summary(pt_BR.UTF-8):   Mutt, cliente de correio eletrônico
31 Summary(ru.UTF-8):      Почтовая клиентская программа Mutt
32 Summary(tr.UTF-8):      Mutt elektronik posta programı
33 Summary(uk.UTF-8):      Поштова клієнтська програма Mutt
34 Name:           mutt
35 Version:        1.11.0
36 Release:        0.0.1
37 Epoch:          6
38 License:        GPL v2+
39 Group:          Applications/Mail
40 # temporarily dead? (Jun 2014)
41 Source0:        ftp://ftp.mutt.org/pub/mutt/%{name}-%{version}.tar.gz
42 # Source0-md5:  b58fdddf76a880c6314c9d4df2c32efb
43 Source1:        %{name}.desktop
44 Source2:        %{name}.png
45 Source3:        %{name}.1.pl
46 Patch0:         %{name}-pl.po-update.patch
47 Patch1:         %{name}-bj.status-time.patch
48 # http://mutt.org.ua/download/
49 Patch2:         %{name}-vvv.quote.patch
50 Patch3:         %{name}-null_name.patch
51 Patch4:         %{name}-cd.signatures_menu.patch
52 # http://www.mutt.ca/patches/ (dw.crypt-autoselectkey)
53 Patch5:         %{name}-crypt-autoselectkey.patch
54 Patch6:         %{name}-manual.patch
55 Patch7:         %{name}-xface.patch
56 Patch8:         %{name}-Muttrc_mbox_path.patch
57 Patch9:         %{name}-po.patch
58 Patch10:        %{name}-Muttrc.head.patch
59 Patch11:        %{name}-smime.rc.patch
60 Patch12:        %{name}-db.patch
61 Patch13:        format-security.patch
62 Patch14:        %{name}-keep_to.patch
63 # applied during %%install
64 Patch50:        %{name}-Muttrc.patch
65 # bcond-related patches
66 Patch101:       %{name}-home_etc.patch
67 # http://mutt.org.ua/download/
68 Patch102:       %{name}-vvv.nntp.patch
69 Patch103:       %{name}-folder_columns.patch
70 Patch104:       %{name}-imap_recent.patch
71 URL:            http://www.mutt.org/
72 BuildRequires:  autoconf >= 2.54
73 BuildRequires:  automake >= 1.6
74 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.1.0}
75 %{?with_bdb:BuildRequires:      db-devel >= 4.0}
76 BuildRequires:  docbook-dtd42-xml
77 BuildRequires:  docbook-style-xsl
78 %{?with_gdbm:BuildRequires:     gdbm-devel}
79 BuildRequires:  gettext-tools
80 BuildRequires:  gpgme-devel >= 1:1.1.1
81 %{?with_home_etc:BuildRequires: home-etc-devel >= 1.0.8}
82 BuildRequires:  libidn-devel
83 BuildRequires:  libxslt-progs
84 BuildRequires:  lynx
85 %{!?with_slang:BuildRequires:   ncurses-devel >= 5.0}
86 BuildRequires:  openssl-devel >= 0.9.7d
87 %{?with_qdbm:BuildRequires:     qdbm-devel}
88 %{?with_slang:BuildRequires:    slang-devel}
89 %{?with_tokyocabinet:BuildRequires:     tokyocabinet-devel}
90 %{?with_home_etc:Requires:      home-etc-lib >= 1.0.8}
91 Requires:       iconv
92 Suggests:       mailcap
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         specflags_ia32  -fomit-frame-pointer
96
97 %description
98 Mutt is a small but very poweful full-screen Unix mail client.
99 Features include MIME support, color, POP3 support, message threading,
100 bindable keys, and threaded sorting mode.
101
102 %description -l de.UTF-8
103 Mutt ist ein kleiner aber leistungsfähiger Vollbild-Mail-Client für
104 Unix mit MIME-Unterstützung, Farbe, POP3-Unterstützung,
105 Nachrichten-Threading, zuweisbaren Tasten und Sortieren nach Threads.
106
107 %description -l es.UTF-8
108 Mutt es un pequeño, pero muy potente cliente de correo en pantalla
109 llena. Incluye soporte a tipos MINE, color, POP3; encadenamiento de
110 mensajes, teclas configurables y clasificaciones por encadenamiento.
111
112 %description -l fr.UTF-8
113 mutt est un client courrier Unix plein écran, petit mais très
114 puissant. Il dispose de la gestion MIME, des couleurs, de la gestion
115 POP, des fils de discussion, des touches liées et d'un mode de tri sur
116 les fils.
117
118 %description -l ko.UTF-8
119 Mutt는 작지만 매우 강력한 텍스트 기반의 메일 클라이언트이다. Mutt는 많은 설정이 가능하다. 그리고, 키바인딩, 키보드
120 메크로, 메일 스레딩과 같은 진보된 형태와 정규표현식 검색, 메일에서 선택된 그룹의 내용에서 강력하게 일정한 패턴을 찾아내는
121 것을 지원함으로써 메일의 파워 유저에게 가장 적합하다.
122
123 %description -l pl.UTF-8
124 Mutt jest niewielkim programem pocztowym dla terminali tekstowych,
125 posiadającym duże możliwości. Obsługuje MIME, POP3, cztery formaty
126 skrzynek pocztowych, kolory, wątki, ocenę ważności listów (scoring)
127 oraz skompresowane foldery.
128
129 %description -l pt_BR.UTF-8
130 O Mutt é um pequeno mas muito poderoso cliente de correio em tela
131 cheia. Inclui suporte a tipos MIME, cor, POP3, encadeamento de
132 mensagens, teclas configuráveis e classificação por encadeamento.
133
134 %description -l ru.UTF-8
135 Mutt - это небольшой, но мощный полноэкранный почтовый клиент.
136 Включает поддержку MIME, цвет, поддержку POP3 и IMAP, группировку
137 сообщений по цепочкам, переопределяемые клавиши, поддержку pgp/gpg и
138 сортировку сообщений в цепочках. Включает также (пока что
139 экспериментальную) поддержку NNTP.
140
141 %description -l tr.UTF-8
142 Mutt, küçük ama çok güçlü bir tam-ekran Unix mektup istemcisidir. MIME
143 desteği, renk ve POP3 desteği içerir.
144
145 %description -l uk.UTF-8
146 Mutt - це невеликий, але потужний повноекранний поштовий клієнт.
147 Містить підтримку MIME, колір, підтримку POP3 та IMAP, групування
148 повідомлень по ланцюжкам, перевизначення клавіш, підтримку pgp/gpg та
149 сортування повідомлень у ланцюжках. Містить також (поки що
150 експериментальну) підтримку NNTP.
151
152 %prep
153 %setup -q
154 # pl.poupdate
155 #%patch0 -p1
156 %patch1 -p1
157 %patch2 -p1
158 %patch3 -p1
159 %patch4 -p1
160 %patch5 -p1
161 %patch6 -p1
162 %patch7 -p1
163 %patch8 -p1
164 %patch9 -p1
165 %patch10 -p1
166 %patch11 -p1
167 %patch12 -p1
168 %patch13 -p1
169 %patch14 -p1
170
171 %{?with_home_etc:%patch101 -p1}
172 %{?with_nntp:%patch102 -p1}
173 # breaks display if arrow_cursor is set
174 %{?with_folder_column:%patch103 -p1}
175 %{?with_imap_recent:%patch1043 -p1}
176
177 # force regeneration (manual.sgml is modified by some patches)
178 %{__rm} doc/{manual*.html,manual.txt}
179
180 %build
181 %{__aclocal} -I m4
182 %{__autoconf}
183 %{__autoheader}
184 %{__automake}
185 %configure \
186         mutt_cv_groupwrite=yes \
187         mutt_cv_worldwrite=no \
188         %{!?debug:--disable-debug} %{?debug:--enable-debug} \
189         --disable-warnings \
190         --enable-compressed \
191         --enable-external-dotlock \
192         --enable-gpgme \
193         --enable-hcache \
194         --enable-imap \
195         --enable-mailtool \
196         %{?with_nntp:--enable-nntp} \
197         --enable-pop \
198         --enable-smtp \
199         %{?with_bdb:--with-bdb=/usr} \
200         %{!?with_slang:--with-curses} \
201         --with-docdir=%{_docdir}/%{name} \
202         %{?with_gdbm:--with-gdbm} \
203         %{?with_home_etc:--with-home-etc} \
204         --with-mailpath=/var/mail \
205         --with-mixmaster \
206         %{?with_qdbm:--with-qdbm} \
207         --with-regex \
208         %{?with_sasl:--with-sasl} \
209         %{?with_slang:--with-slang} \
210         --with-ssl \
211         %{?with_tokyocabinet:--with-tokyocabinet}
212
213 %{__make} -j1 -C doc
214 %{__make}
215
216 %install
217 rm -rf $RPM_BUILD_ROOT
218 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1} \
219         $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
220
221 %{__make} install \
222         DESTDIR=$RPM_BUILD_ROOT \
223         DOTLOCK_GROUP=
224
225 %{__patch} -p2 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH50}
226
227 install contrib/gpg.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
228 install contrib/smime.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
229 install contrib/colors.linux $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d/colors.rc
230
231 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
232 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
233 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
234
235 cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/mutt_source-muttrc.d
236 #!/bin/sh -e
237 for rc in %{_sysconfdir}/Muttrc.d/*.rc; do
238         [ ! -r "$rc" ] || echo "source \"$rc\""
239 done
240 EOF
241
242 # keep manual.txt.gz, the rest is installed as %doc
243 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
244
245 # conflict with qmail
246 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
247 # belongs to mailcap
248 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
249
250 %find_lang %{name}
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %post   -p /sbin/postshell
256 -/usr/sbin/fix-info-dir -c %{_infodir}
257
258 %postun -p /sbin/postshell
259 -/usr/sbin/fix-info-dir -c %{_infodir}
260
261 %files -f %{name}.lang
262 %defattr(644,root,root,755)
263 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL
264 %dir %{_sysconfdir}/Muttrc.d
265 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc
266 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc.d/*.rc
267 %attr(755,root,root) %{_bindir}/mutt
268 %attr(755,root,root) %{_bindir}/mutt_pgpring
269 %attr(755,root,root) %{_bindir}/mutt_source-muttrc.d
270 %attr(755,root,root) %{_bindir}/flea
271 %attr(755,root,root) %{_bindir}/muttbug
272 %attr(755,root,root) %{_bindir}/pgp*
273 %attr(755,root,root) %{_bindir}/smime_keys
274 %attr(2755,root,mail) %{_bindir}/mutt_dotlock
275
276 %{_docdir}/%{name}
277 %{_desktopdir}/mutt.desktop
278 %{_pixmapsdir}/mutt.png
279 #%{_mandir}/man1/flea.1*
280 %{_mandir}/man1/mutt*.1*
281 %{_mandir}/man1/pgp*.1*
282 %{_mandir}/man1/smime_keys.1*
283 %{_mandir}/man5/mmdf.5*
284 %{_mandir}/man5/muttrc.5*
285 %lang(pl) %{_mandir}/pl/man1/*
286 %{_infodir}/mutt.info*
This page took 0.042673 seconds and 3 git commands to generate.