]> git.pld-linux.org Git - packages/mutt.git/blob - mutt.spec
367e3944b560fcdb907b39982c94b44aed9981bd
[packages/mutt.git] / mutt.spec
1 #
2 # TODO:
3 # - gss/heimdal
4 # - finish -folder_columns.patch
5 # - update/drop -home_etc.patch
6 # - update/drop -imap_recent.patch
7 #
8 # Conditional build:
9 %bcond_with     slang           # use slang library instead of ncurses
10 %bcond_with     nntp            # use VVV's NNTP patch
11 %bcond_with     folder_column   # build with folder_column patch
12 %bcond_with     imap_recent     # show IMAP RECENT messages as new (instead of UNSEEN)
13 %bcond_without  sasl            # don't use sasl
14 %bcond_with     home_etc        # use home_etc
15 %bcond_with     gdbm            # use GDBM instead of BerkeleyDB
16 %bcond_with     qdbm            # use QDBM instead of BerkeleyDB
17 %bcond_with     tokyocabinet    # use TokyoCabinet instead of BerkeleyDB
18 #
19 %if %{without gdbm} && %{without qdbm} && %{without tokyocabinet}
20 %define with_bdb        1
21 %endif
22 Summary:        The Mutt Mail User Agent
23 Summary(de.UTF-8):      Der Mutt Mail-User-Agent
24 Summary(es.UTF-8):      Mutt, cliente de correo electrónico
25 Summary(fr.UTF-8):      Agent courrier Mutt
26 Summary(ko.UTF-8):      텍스트 기반의 MUA
27 Summary(pl.UTF-8):      Program pocztowy Mutt
28 Summary(pt_BR.UTF-8):   Mutt, cliente de correio eletrônico
29 Summary(ru.UTF-8):      Почтовая клиентская программа Mutt
30 Summary(tr.UTF-8):      Mutt elektronik posta programı
31 Summary(uk.UTF-8):      Поштова клієнтська програма Mutt
32 Name:           mutt
33 Version:        2.0.6
34 Release:        1
35 Epoch:          6
36 License:        GPL v2+
37 Group:          Applications/Mail
38 Source0:        ftp://ftp.mutt.org/pub/mutt/%{name}-%{version}.tar.gz
39 # Source0-md5:  585072c134ac5cd9e264187685dcd4ae
40 Source1:        %{name}.desktop
41 Source2:        %{name}.png
42 Source3:        %{name}.1.pl
43 Patch0:         %{name}-pl.po-update.patch
44 Patch1:         %{name}-bj.status-time.patch
45 # http://mutt.org.ua/download/
46 Patch2:         %{name}-vvv.quote.patch
47 Patch3:         %{name}-null_name.patch
48 Patch4:         %{name}-cd.signatures_menu.patch
49 # http://www.mutt.ca/patches/ (dw.crypt-autoselectkey)
50 Patch5:         %{name}-crypt-autoselectkey.patch
51 Patch6:         %{name}-manual.patch
52 Patch7:         %{name}-Muttrc_mbox_path.patch
53 Patch8:         %{name}-po.patch
54 Patch9: %{name}-Muttrc.head.patch
55 Patch10:        %{name}-smime.rc.patch
56 Patch11:        %{name}-db.patch
57 Patch12:        format-security.patch
58 Patch13:        %{name}-keep_to.patch
59 Patch14:        %{name}-vvv.initials.patch
60 # applied during %%install
61 Patch50:        %{name}-Muttrc.patch
62 # bcond-related patches
63 Patch101:       %{name}-home_etc.patch
64 # http://mutt.org.ua/download/
65 Patch102:       %{name}-vvv.nntp.patch
66 Patch103:       %{name}-folder_columns.patch
67 Patch104:       %{name}-imap_recent.patch
68 URL:            http://www.mutt.org/
69 BuildRequires:  autoconf >= 2.54
70 BuildRequires:  automake >= 1.6
71 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.1.0}
72 %{?with_bdb:BuildRequires:      db-devel >= 4.0}
73 BuildRequires:  docbook-dtd42-xml
74 BuildRequires:  docbook-style-xsl
75 %{?with_gdbm:BuildRequires:     gdbm-devel}
76 BuildRequires:  gettext-tools
77 BuildRequires:  gpgme-devel >= 1:1.4.0
78 %{?with_home_etc:BuildRequires: home-etc-devel >= 1.0.8}
79 BuildRequires:  libgpg-error-devel >= 1.33
80 BuildRequires:  libidn-devel
81 BuildRequires:  libxslt-progs
82 BuildRequires:  lynx
83 %{!?with_slang:BuildRequires:   ncurses-devel >= 5.0}
84 BuildRequires:  openssl-devel >= 0.9.7d
85 %{?with_qdbm:BuildRequires:     qdbm-devel}
86 %{?with_slang:BuildRequires:    slang-devel}
87 %{?with_tokyocabinet:BuildRequires:     tokyocabinet-devel}
88 Requires:       gpgme >= 1:1.4.0
89 %{?with_home_etc:Requires:      home-etc-lib >= 1.0.8}
90 Requires:       iconv
91 Requires:       libgpg-error >= 1.33
92 Suggests:       mailcap
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         specflags_ia32  -fomit-frame-pointer
96
97 %description
98 Mutt is a small but very poweful full-screen Unix mail client.
99 Features include MIME support, color, POP3 support, message threading,
100 bindable keys, and threaded sorting mode.
101
102 %description -l de.UTF-8
103 Mutt ist ein kleiner aber leistungsfähiger Vollbild-Mail-Client für
104 Unix mit MIME-Unterstützung, Farbe, POP3-Unterstützung,
105 Nachrichten-Threading, zuweisbaren Tasten und Sortieren nach Threads.
106
107 %description -l es.UTF-8
108 Mutt es un pequeño, pero muy potente cliente de correo en pantalla
109 llena. Incluye soporte a tipos MINE, color, POP3; encadenamiento de
110 mensajes, teclas configurables y clasificaciones por encadenamiento.
111
112 %description -l fr.UTF-8
113 mutt est un client courrier Unix plein écran, petit mais très
114 puissant. Il dispose de la gestion MIME, des couleurs, de la gestion
115 POP, des fils de discussion, des touches liées et d'un mode de tri sur
116 les fils.
117
118 %description -l ko.UTF-8
119 Mutt는 작지만 매우 강력한 텍스트 기반의 메일 클라이언트이다. Mutt는 많은 설정이 가능하다. 그리고, 키바인딩, 키보드
120 메크로, 메일 스레딩과 같은 진보된 형태와 정규표현식 검색, 메일에서 선택된 그룹의 내용에서 강력하게 일정한 패턴을 찾아내는
121 것을 지원함으로써 메일의 파워 유저에게 가장 적합하다.
122
123 %description -l pl.UTF-8
124 Mutt jest niewielkim programem pocztowym dla terminali tekstowych,
125 posiadającym duże możliwości. Obsługuje MIME, POP3, cztery formaty
126 skrzynek pocztowych, kolory, wątki, ocenę ważności listów (scoring)
127 oraz skompresowane foldery.
128
129 %description -l pt_BR.UTF-8
130 O Mutt é um pequeno mas muito poderoso cliente de correio em tela
131 cheia. Inclui suporte a tipos MIME, cor, POP3, encadeamento de
132 mensagens, teclas configuráveis e classificação por encadeamento.
133
134 %description -l ru.UTF-8
135 Mutt - это небольшой, но мощный полноэкранный почтовый клиент.
136 Включает поддержку MIME, цвет, поддержку POP3 и IMAP, группировку
137 сообщений по цепочкам, переопределяемые клавиши, поддержку pgp/gpg и
138 сортировку сообщений в цепочках. Включает также (пока что
139 экспериментальную) поддержку NNTP.
140
141 %description -l tr.UTF-8
142 Mutt, küçük ama çok güçlü bir tam-ekran Unix mektup istemcisidir. MIME
143 desteği, renk ve POP3 desteği içerir.
144
145 %description -l uk.UTF-8
146 Mutt - це невеликий, але потужний повноекранний поштовий клієнт.
147 Містить підтримку MIME, колір, підтримку POP3 та IMAP, групування
148 повідомлень по ланцюжкам, перевизначення клавіш, підтримку pgp/gpg та
149 сортування повідомлень у ланцюжках. Містить також (поки що
150 експериментальну) підтримку NNTP.
151
152 %prep
153 %setup -q
154 # pl.poupdate
155 #%patch0 -p1
156 %patch1 -p1
157 %patch2 -p1
158 %patch3 -p1
159 %patch4 -p1
160 %patch5 -p1
161 %patch6 -p1
162 %patch7 -p1
163 %patch8 -p1
164 %patch9 -p1
165 %patch10 -p1
166 %patch11 -p1
167 %patch12 -p1
168 %patch13 -p1
169 %patch14 -p1
170
171 %{?with_home_etc:%patch101 -p1}
172 %{?with_nntp:%patch102 -p1}
173 # breaks display if arrow_cursor is set
174 %{?with_folder_column:%patch103 -p1}
175 %{?with_imap_recent:%patch104 -p1}
176
177 # force regeneration (manual.sgml is modified by some patches)
178 %{__rm} doc/manual*.html
179
180 %build
181 %{__aclocal} -I m4
182 %{__autoconf}
183 %{__autoheader}
184 %{__automake}
185 %configure \
186         mutt_cv_groupwrite=yes \
187         mutt_cv_worldwrite=no \
188         %{!?debug:--disable-debug} %{?debug:--enable-debug} \
189         --disable-warnings \
190         --enable-compressed \
191         --enable-external-dotlock \
192         --enable-gpgme \
193         --enable-hcache \
194         --enable-imap \
195         --enable-mailtool \
196         %{?with_nntp:--enable-nntp} \
197         --enable-pop \
198         --enable-sidebar \
199         --enable-smtp \
200         %{?with_bdb:--with-bdb=/usr} \
201         %{!?with_slang:--with-curses} \
202         --with-docdir=%{_docdir}/%{name} \
203         %{?with_gdbm:--with-gdbm} \
204         %{?with_home_etc:--with-home-etc} \
205         --with-mailpath=/var/mail \
206         --with-mixmaster \
207         %{?with_qdbm:--with-qdbm} \
208         --with-regex \
209         %{?with_sasl:--with-sasl} \
210         %{?with_slang:--with-slang} \
211         --with-ssl \
212         %{?with_tokyocabinet:--with-tokyocabinet}
213
214 %{__make} -j1 -C doc
215 %{__make}
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1} \
220         $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
221
222 %{__make} install \
223         DESTDIR=$RPM_BUILD_ROOT \
224         DOTLOCK_GROUP=
225
226 %{__patch} -p2 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH50}
227
228 install contrib/gpg.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
229 install contrib/smime.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
230 install contrib/colors.linux $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d/colors.rc
231
232 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
233 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
234 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
235
236 cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/mutt_source-muttrc.d
237 #!/bin/sh -e
238 for rc in %{_sysconfdir}/Muttrc.d/*.rc; do
239         [ ! -r "$rc" ] || echo "source \"$rc\""
240 done
241 EOF
242
243 # keep manual.txt.gz, the rest is installed as %doc
244 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
245
246 # conflict with qmail
247 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
248 # belongs to mailcap
249 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
250 # don't litter
251 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.dist
252 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.orig
253 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mime.types.dist
254
255 %find_lang %{name}
256
257 %clean
258 rm -rf $RPM_BUILD_ROOT
259
260 %post   -p /sbin/postshell
261 -/usr/sbin/fix-info-dir -c %{_infodir}
262
263 %postun -p /sbin/postshell
264 -/usr/sbin/fix-info-dir -c %{_infodir}
265
266 %files -f %{name}.lang
267 %defattr(644,root,root,755)
268 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL
269 %dir %{_sysconfdir}/Muttrc.d
270 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc
271 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc.d/*.rc
272 %attr(755,root,root) %{_bindir}/mutt
273 %attr(755,root,root) %{_bindir}/mutt_pgpring
274 %attr(755,root,root) %{_bindir}/mutt_source-muttrc.d
275 %attr(755,root,root) %{_bindir}/flea
276 %attr(755,root,root) %{_bindir}/muttbug
277 %attr(755,root,root) %{_bindir}/pgpewrap
278 %attr(755,root,root) %{_bindir}/smime_keys
279 %attr(2755,root,mail) %{_bindir}/mutt_dotlock
280
281 %{_docdir}/%{name}
282 %{_desktopdir}/mutt.desktop
283 %{_pixmapsdir}/mutt.png
284 #%{_mandir}/man1/flea.1*
285 %{_mandir}/man1/mutt*.1*
286 %{_mandir}/man1/pgpewrap.1*
287 %{_mandir}/man1/smime_keys.1*
288 %{_mandir}/man5/mmdf.5*
289 %{_mandir}/man5/muttrc.5*
290 %lang(pl) %{_mandir}/pl/man1/*
291 %{_infodir}/mutt.info*
This page took 0.066476 seconds and 2 git commands to generate.