]> git.pld-linux.org Git - packages/mutt.git/blob - mutt.spec
- release 2, vvv patches updated from upstream
[packages/mutt.git] / mutt.spec
1 #
2 # TODO:
3 # - gss/heimdal
4 # - finish -folder_columns.patch
5 # - update/drop -home_etc.patch
6 # - update/drop -imap_recent.patch
7 #
8 # Conditional build:
9 %bcond_with     slang           # use slang library instead of ncurses
10 %bcond_with     nntp            # use VVV's NNTP patch
11 %bcond_with     folder_column   # build with folder_column patch
12 %bcond_with     imap_recent     # show IMAP RECENT messages as new (instead of UNSEEN)
13 %bcond_without  sasl            # don't use sasl
14 %bcond_with     home_etc        # use home_etc
15 %bcond_with     gdbm            # use GDBM instead of BerkeleyDB
16 %bcond_with     qdbm            # use QDBM instead of BerkeleyDB
17 %bcond_with     tokyocabinet    # use TokyoCabinet instead of BerkeleyDB
18 #
19 %if %{without gdbm} && %{without qdbm} && %{without tokyocabinet}
20 %define with_bdb        1
21 %endif
22 Summary:        The Mutt Mail User Agent
23 Summary(de.UTF-8):      Der Mutt Mail-User-Agent
24 Summary(es.UTF-8):      Mutt, cliente de correo electrónico
25 Summary(fr.UTF-8):      Agent courrier Mutt
26 Summary(ko.UTF-8):      텍스트 기반의 MUA
27 Summary(pl.UTF-8):      Program pocztowy Mutt
28 Summary(pt_BR.UTF-8):   Mutt, cliente de correio eletrônico
29 Summary(ru.UTF-8):      Почтовая клиентская программа Mutt
30 Summary(tr.UTF-8):      Mutt elektronik posta programı
31 Summary(uk.UTF-8):      Поштова клієнтська програма Mutt
32 Name:           mutt
33 Version:        1.12.1
34 Release:        2
35 Epoch:          6
36 License:        GPL v2+
37 Group:          Applications/Mail
38 Source0:        ftp://ftp.mutt.org/pub/mutt/%{name}-%{version}.tar.gz
39 # Source0-md5:  f77586a895f12d19de9c5250a4dfd034
40 Source1:        %{name}.desktop
41 Source2:        %{name}.png
42 Source3:        %{name}.1.pl
43 Patch0:         %{name}-pl.po-update.patch
44 Patch1:         %{name}-bj.status-time.patch
45 # http://mutt.org.ua/download/
46 Patch2:         %{name}-vvv.quote.patch
47 Patch3:         %{name}-null_name.patch
48 Patch4:         %{name}-cd.signatures_menu.patch
49 # http://www.mutt.ca/patches/ (dw.crypt-autoselectkey)
50 Patch5:         %{name}-crypt-autoselectkey.patch
51 Patch6:         %{name}-manual.patch
52 Patch7:         %{name}-xface.patch
53 Patch8:         %{name}-Muttrc_mbox_path.patch
54 Patch9:         %{name}-po.patch
55 Patch10:        %{name}-Muttrc.head.patch
56 Patch11:        %{name}-smime.rc.patch
57 Patch12:        %{name}-db.patch
58 Patch13:        format-security.patch
59 Patch14:        %{name}-keep_to.patch
60 Patch15:        %{name}-vvv.initials.patch
61 # applied during %%install
62 Patch50:        %{name}-Muttrc.patch
63 # bcond-related patches
64 Patch101:       %{name}-home_etc.patch
65 # http://mutt.org.ua/download/
66 Patch102:       %{name}-vvv.nntp.patch
67 Patch103:       %{name}-folder_columns.patch
68 Patch104:       %{name}-imap_recent.patch
69 URL:            http://www.mutt.org/
70 BuildRequires:  autoconf >= 2.54
71 BuildRequires:  automake >= 1.6
72 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.1.0}
73 %{?with_bdb:BuildRequires:      db-devel >= 4.0}
74 BuildRequires:  docbook-dtd42-xml
75 BuildRequires:  docbook-style-xsl
76 %{?with_gdbm:BuildRequires:     gdbm-devel}
77 BuildRequires:  gettext-tools
78 BuildRequires:  gpgme-devel >= 1:1.4.0
79 %{?with_home_etc:BuildRequires: home-etc-devel >= 1.0.8}
80 BuildRequires:  libgpg-error-devel >= 1.33
81 BuildRequires:  libidn-devel
82 BuildRequires:  libxslt-progs
83 BuildRequires:  lynx
84 %{!?with_slang:BuildRequires:   ncurses-devel >= 5.0}
85 BuildRequires:  openssl-devel >= 0.9.7d
86 %{?with_qdbm:BuildRequires:     qdbm-devel}
87 %{?with_slang:BuildRequires:    slang-devel}
88 %{?with_tokyocabinet:BuildRequires:     tokyocabinet-devel}
89 Requires:       gpgme >= 1:1.4.0
90 %{?with_home_etc:Requires:      home-etc-lib >= 1.0.8}
91 Requires:       iconv
92 Requires:       libgpg-error >= 1.33
93 Suggests:       mailcap
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define         specflags_ia32  -fomit-frame-pointer
97
98 %description
99 Mutt is a small but very poweful full-screen Unix mail client.
100 Features include MIME support, color, POP3 support, message threading,
101 bindable keys, and threaded sorting mode.
102
103 %description -l de.UTF-8
104 Mutt ist ein kleiner aber leistungsfähiger Vollbild-Mail-Client für
105 Unix mit MIME-Unterstützung, Farbe, POP3-Unterstützung,
106 Nachrichten-Threading, zuweisbaren Tasten und Sortieren nach Threads.
107
108 %description -l es.UTF-8
109 Mutt es un pequeño, pero muy potente cliente de correo en pantalla
110 llena. Incluye soporte a tipos MINE, color, POP3; encadenamiento de
111 mensajes, teclas configurables y clasificaciones por encadenamiento.
112
113 %description -l fr.UTF-8
114 mutt est un client courrier Unix plein écran, petit mais très
115 puissant. Il dispose de la gestion MIME, des couleurs, de la gestion
116 POP, des fils de discussion, des touches liées et d'un mode de tri sur
117 les fils.
118
119 %description -l ko.UTF-8
120 Mutt는 작지만 매우 강력한 텍스트 기반의 메일 클라이언트이다. Mutt는 많은 설정이 가능하다. 그리고, 키바인딩, 키보드
121 메크로, 메일 스레딩과 같은 진보된 형태와 정규표현식 검색, 메일에서 선택된 그룹의 내용에서 강력하게 일정한 패턴을 찾아내는
122 것을 지원함으로써 메일의 파워 유저에게 가장 적합하다.
123
124 %description -l pl.UTF-8
125 Mutt jest niewielkim programem pocztowym dla terminali tekstowych,
126 posiadającym duże możliwości. Obsługuje MIME, POP3, cztery formaty
127 skrzynek pocztowych, kolory, wątki, ocenę ważności listów (scoring)
128 oraz skompresowane foldery.
129
130 %description -l pt_BR.UTF-8
131 O Mutt é um pequeno mas muito poderoso cliente de correio em tela
132 cheia. Inclui suporte a tipos MIME, cor, POP3, encadeamento de
133 mensagens, teclas configuráveis e classificação por encadeamento.
134
135 %description -l ru.UTF-8
136 Mutt - это небольшой, но мощный полноэкранный почтовый клиент.
137 Включает поддержку MIME, цвет, поддержку POP3 и IMAP, группировку
138 сообщений по цепочкам, переопределяемые клавиши, поддержку pgp/gpg и
139 сортировку сообщений в цепочках. Включает также (пока что
140 экспериментальную) поддержку NNTP.
141
142 %description -l tr.UTF-8
143 Mutt, küçük ama çok güçlü bir tam-ekran Unix mektup istemcisidir. MIME
144 desteği, renk ve POP3 desteği içerir.
145
146 %description -l uk.UTF-8
147 Mutt - це невеликий, але потужний повноекранний поштовий клієнт.
148 Містить підтримку MIME, колір, підтримку POP3 та IMAP, групування
149 повідомлень по ланцюжкам, перевизначення клавіш, підтримку pgp/gpg та
150 сортування повідомлень у ланцюжках. Містить також (поки що
151 експериментальну) підтримку NNTP.
152
153 %prep
154 %setup -q
155 # pl.poupdate
156 #%patch0 -p1
157 %patch1 -p1
158 %patch2 -p1
159 %patch3 -p1
160 %patch4 -p1
161 %patch5 -p1
162 %patch6 -p1
163 %patch7 -p1
164 %patch8 -p1
165 %patch9 -p1
166 %patch10 -p1
167 %patch11 -p1
168 %patch12 -p1
169 %patch13 -p1
170 %patch14 -p1
171 %patch15 -p1
172
173 %{?with_home_etc:%patch101 -p1}
174 %{?with_nntp:%patch102 -p1}
175 # breaks display if arrow_cursor is set
176 %{?with_folder_column:%patch103 -p1}
177 %{?with_imap_recent:%patch104 -p1}
178
179 # force regeneration (manual.sgml is modified by some patches)
180 %{__rm} doc/{manual*.html,manual.txt}
181
182 %build
183 %{__aclocal} -I m4
184 %{__autoconf}
185 %{__autoheader}
186 %{__automake}
187 %configure \
188         mutt_cv_groupwrite=yes \
189         mutt_cv_worldwrite=no \
190         %{!?debug:--disable-debug} %{?debug:--enable-debug} \
191         --disable-warnings \
192         --enable-compressed \
193         --enable-external-dotlock \
194         --enable-gpgme \
195         --enable-hcache \
196         --enable-imap \
197         --enable-mailtool \
198         %{?with_nntp:--enable-nntp} \
199         --enable-pop \
200         --enable-sidebar \
201         --enable-smtp \
202         %{?with_bdb:--with-bdb=/usr} \
203         %{!?with_slang:--with-curses} \
204         --with-docdir=%{_docdir}/%{name} \
205         %{?with_gdbm:--with-gdbm} \
206         %{?with_home_etc:--with-home-etc} \
207         --with-mailpath=/var/mail \
208         --with-mixmaster \
209         %{?with_qdbm:--with-qdbm} \
210         --with-regex \
211         %{?with_sasl:--with-sasl} \
212         %{?with_slang:--with-slang} \
213         --with-ssl \
214         %{?with_tokyocabinet:--with-tokyocabinet}
215
216 %{__make} -j1 -C doc
217 %{__make}
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/pl/man1} \
222         $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT \
226         DOTLOCK_GROUP=
227
228 %{__patch} -p2 -d $RPM_BUILD_ROOT%{_sysconfdir} < %{PATCH50}
229
230 install contrib/gpg.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
231 install contrib/smime.rc $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d
232 install contrib/colors.linux $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.d/colors.rc
233
234 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
235 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
236 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
237
238 cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/mutt_source-muttrc.d
239 #!/bin/sh -e
240 for rc in %{_sysconfdir}/Muttrc.d/*.rc; do
241         [ ! -r "$rc" ] || echo "source \"$rc\""
242 done
243 EOF
244
245 # keep manual.txt.gz, the rest is installed as %doc
246 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/[!m]*
247
248 # conflict with qmail
249 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
250 # belongs to mailcap
251 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
252
253 %find_lang %{name}
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 %post   -p /sbin/postshell
259 -/usr/sbin/fix-info-dir -c %{_infodir}
260
261 %postun -p /sbin/postshell
262 -/usr/sbin/fix-info-dir -c %{_infodir}
263
264 %files -f %{name}.lang
265 %defattr(644,root,root,755)
266 %doc contrib/{*rc*,*cap*} ChangeLog README TODO NEWS README.SECURITY README.SSL
267 %dir %{_sysconfdir}/Muttrc.d
268 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc
269 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/Muttrc.d/*.rc
270 %attr(755,root,root) %{_bindir}/mutt
271 %attr(755,root,root) %{_bindir}/mutt_pgpring
272 %attr(755,root,root) %{_bindir}/mutt_source-muttrc.d
273 %attr(755,root,root) %{_bindir}/flea
274 %attr(755,root,root) %{_bindir}/muttbug
275 %attr(755,root,root) %{_bindir}/pgpewrap
276 %attr(755,root,root) %{_bindir}/smime_keys
277 %attr(2755,root,mail) %{_bindir}/mutt_dotlock
278
279 %{_docdir}/%{name}
280 %{_desktopdir}/mutt.desktop
281 %{_pixmapsdir}/mutt.png
282 #%{_mandir}/man1/flea.1*
283 %{_mandir}/man1/mutt*.1*
284 %{_mandir}/man1/pgpewrap.1*
285 %{_mandir}/man1/smime_keys.1*
286 %{_mandir}/man5/mmdf.5*
287 %{_mandir}/man5/muttrc.5*
288 %lang(pl) %{_mandir}/pl/man1/*
289 %{_infodir}/mutt.info*
This page took 0.074973 seconds and 3 git commands to generate.