]> git.pld-linux.org Git - packages/memkind.git/blob - memkind.spec
ef9d2186b9d462deb51d88c7ab69a1fbf9edbb96
[packages/memkind.git] / memkind.spec
1 #
2 # Conditional build:
3 %bcond_without  ndctl   # daxctl support
4
5 Summary:        User Extensible Heap Manager
6 Summary(pl.UTF-8):      Rozszerzalny zarządca sterty
7 Name:           memkind
8 Version:        1.10.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/memkind/memkind/releases
13 Source0:        https://github.com/memkind/memkind/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  30a59aec4c79a2504b6c0ec0ec5a070e
15 URL:            http://memkind.github.io/memkind
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 %{?with_ndctl:BuildRequires:    daxctl-devel >= 66}
19 BuildRequires:  libgomp-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:2.2
22 BuildRequires:  numactl-devel
23 BuildRequires:  unzip
24 %{?with_ndctl:Requires: daxctl-libs >= 66}
25 ExclusiveArch:  %{x8664} ppc64 ppc64le s390x aarch64
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The memkind library is an user extensible heap manager built on top of
30 jemalloc which enables control of memory characteristics and a
31 partitioning of the heap between kinds of memory. The kinds of memory
32 are defined by operating system memory policies that have been applied
33 to virtual address ranges. Memory characteristics supported by memkind
34 without user extension include control of NUMA and page size features.
35 The jemalloc non-standard interface has been extended to enable
36 specialized arenas to make requests for virtual memory from the
37 operating system through the memkind partition interface. Through the
38 other memkind interfaces the user can control and extend memory
39 partition features and allocate memory while selecting enabled
40 features.
41
42 %description -l pl.UTF-8
43 Biblioteka memkind to rozserzalny zarządca sterty, zbudowany w oparciu
44 o bibliotekę jemalloc, pozwalający kontrolować charakterystykę pamięci
45 i partycjonowanie sterty pomiędzy różne rodzaje pamięci. Rodzaje
46 pamięci są definiowane przez polityki pamięci systemu operacyjnego
47 nałożone na przedziały adresów wirtualnych. Charakterystyki pamięci
48 obsługiwane przez memkind bez rozszerzania przez użytkownika obejmują
49 sterowanie NUMA oraz rozmiary stron. Niestandardowy interfejs jemalloc
50 został rozszerzony, aby pozwolić specjalizowanym arenom wykonywać
51 żądania pamięci wirtualnej z systemu operacyjnego poprzez interfejs
52 partycjonowania memkind. Przez inne interfejsy memkind użytkownik może
53 sterować i rozszerzać możliwości partycjonowania, a także przydzielać
54 pamięć wybierając określone cechy.
55
56 %package devel
57 Summary:        Header files for Memkind User Extensible Heap Manager libraries
58 Summary(pl.UTF-8):      Pliki nagłówkowe Memkind - bibliotek rozszerzalnego zarządcy sterty
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 %{?with_ndctl:Requires: daxctl-devel >= 66}
62 BuildRequires:  numactl-devel
63
64 %description devel
65 Header files for Memkind User Extensible Heap Manager library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe Memkind - biblioteki rozszerzalnego zarządcy sterty.
69
70 %package static
71 Summary:        Static Memkind libraries
72 Summary(pl.UTF-8):      Statyczne biblioteki Memkind
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static Memkind libraries.
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki Memkind.
81
82 %prep
83 %setup -q
84
85 %build
86 %{__libtoolize}
87 %{__aclocal} -I m4
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         %{!?with_ndctl:--disable-daxctl} \
93         --enable-decorators \
94         --disable-silent-rules \
95         --enable-tls
96
97 %{__make}
98
99 %{__make} checkprogs
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS COPYING ChangeLog NEWS README
118 %attr(755,root,root) %{_bindir}/memkind-auto-dax-kmem-nodes
119 %attr(755,root,root) %{_bindir}/memkind-hbw-nodes
120 %attr(755,root,root) %{_libdir}/libmemkind.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libmemkind.so.0
122 %attr(755,root,root) %{_libdir}/libautohbw.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libautohbw.so.0
124 %{_mandir}/man1/memkind-auto-dax-kmem-nodes.1*
125 %{_mandir}/man1/memkind-hbw-nodes.1*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libmemkind.so
130 %attr(755,root,root) %{_libdir}/libautohbw.so
131 %{_includedir}/hbw_allocator.h
132 %{_includedir}/hbwmalloc.h
133 %{_includedir}/memkind.h
134 %{_includedir}/memkind_allocator.h
135 %{_includedir}/pmem_allocator.h
136 %{_pkgconfigdir}/memkind.pc
137 %{_mandir}/man3/hbwmalloc.3*
138 %{_mandir}/man3/hbwallocator.3*
139 %{_mandir}/man3/pmemallocator.3*
140 %{_mandir}/man3/memkind*.3*
141 %{_mandir}/man7/autohbw.7*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libmemkind.a
146 %{_libdir}/libautohbw.a
This page took 0.125479 seconds and 3 git commands to generate.