]> git.pld-linux.org Git - packages/memkind.git/blame - memkind.spec
- finished files
[packages/memkind.git] / memkind.spec
CommitLineData
b7fbe57b
JB
1#
2# Conditional build:
3%bcond_without ndctl # daxctl support
4
5Summary: User Extensible Heap Manager
6Summary(pl.UTF-8): Rozszerzalny zarządca sterty
7Name: memkind
8Version: 1.10.0
9Release: 1
10License: BSD
11Group: Libraries
12#Source0Download: https://github.com/memkind/memkind/releases
13Source0: https://github.com/memkind/memkind/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 30a59aec4c79a2504b6c0ec0ec5a070e
15URL: http://memkind.github.io/memkind
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake >= 1:1.11
18%{?with_ndctl:BuildRequires: daxctl-devel >= 66}
19BuildRequires: libgomp-devel
20BuildRequires: libstdc++-devel
21BuildRequires: libtool >= 2:2.2
22BuildRequires: numactl-devel
23BuildRequires: unzip
24%{?with_ndctl:Requires: daxctl-libs >= 66}
25ExclusiveArch: %{x8664} ppc64 ppc64le s390x aarch64
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29The memkind library is an user extensible heap manager built on top of
30jemalloc which enables control of memory characteristics and a
31partitioning of the heap between kinds of memory. The kinds of memory
32are defined by operating system memory policies that have been applied
33to virtual address ranges. Memory characteristics supported by memkind
34without user extension include control of NUMA and page size features.
35The jemalloc non-standard interface has been extended to enable
36specialized arenas to make requests for virtual memory from the
37operating system through the memkind partition interface. Through the
38other memkind interfaces the user can control and extend memory
39partition features and allocate memory while selecting enabled
40features.
41
42%description -l pl.UTF-8
43Biblioteka memkind to rozserzalny zarządca sterty, zbudowany w oparciu
44o bibliotekę jemalloc, pozwalający kontrolować charakterystykę pamięci
45i partycjonowanie sterty pomiędzy różne rodzaje pamięci. Rodzaje
46pamięci są definiowane przez polityki pamięci systemu operacyjnego
47nałożone na przedziały adresów wirtualnych. Charakterystyki pamięci
48obsługiwane przez memkind bez rozszerzania przez użytkownika obejmują
49sterowanie NUMA oraz rozmiary stron. Niestandardowy interfejs jemalloc
50został rozszerzony, aby pozwolić specjalizowanym arenom wykonywać
51żądania pamięci wirtualnej z systemu operacyjnego poprzez interfejs
52partycjonowania memkind. Przez inne interfejsy memkind użytkownik może
53sterować i rozszerzać możliwości partycjonowania, a także przydzielać
54pamięć wybierając określone cechy.
55
56%package devel
57Summary: Header files for Memkind User Extensible Heap Manager libraries
58Summary(pl.UTF-8): Pliki nagłówkowe Memkind - bibliotek rozszerzalnego zarządcy sterty
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61%{?with_ndctl:Requires: daxctl-devel >= 66}
62BuildRequires: numactl-devel
63
64%description devel
65Header files for Memkind User Extensible Heap Manager library.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe Memkind - biblioteki rozszerzalnego zarządcy sterty.
69
70%package static
71Summary: Static Memkind libraries
72Summary(pl.UTF-8): Statyczne biblioteki Memkind
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75
76%description static
77Static Memkind libraries.
78
79%description static -l pl.UTF-8
80Statyczne biblioteki Memkind.
81
82%prep
83%setup -q
84
85%build
86%{__libtoolize}
87%{__aclocal} -I m4
88%{__autoconf}
89%{__autoheader}
90%{__automake}
91%configure \
92 %{!?with_ndctl:--disable-daxctl} \
93 --enable-decorators \
94 --disable-silent-rules \
95 --enable-tls
96
97%{__make}
98
99%{__make} checkprogs
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
106
107%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
98fc88d1
JB
108# packaged as %doc
109%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/memkind
b7fbe57b
JB
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS COPYING ChangeLog NEWS README
120%attr(755,root,root) %{_bindir}/memkind-auto-dax-kmem-nodes
121%attr(755,root,root) %{_bindir}/memkind-hbw-nodes
122%attr(755,root,root) %{_libdir}/libmemkind.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libmemkind.so.0
124%attr(755,root,root) %{_libdir}/libautohbw.so.*.*.*
125%attr(755,root,root) %ghost %{_libdir}/libautohbw.so.0
126%{_mandir}/man1/memkind-auto-dax-kmem-nodes.1*
127%{_mandir}/man1/memkind-hbw-nodes.1*
128
129%files devel
130%defattr(644,root,root,755)
131%attr(755,root,root) %{_libdir}/libmemkind.so
132%attr(755,root,root) %{_libdir}/libautohbw.so
133%{_includedir}/hbw_allocator.h
134%{_includedir}/hbwmalloc.h
135%{_includedir}/memkind.h
136%{_includedir}/memkind_allocator.h
98fc88d1 137%{_includedir}/memkind_deprecated.h
b7fbe57b
JB
138%{_includedir}/pmem_allocator.h
139%{_pkgconfigdir}/memkind.pc
140%{_mandir}/man3/hbwmalloc.3*
141%{_mandir}/man3/hbwallocator.3*
142%{_mandir}/man3/pmemallocator.3*
143%{_mandir}/man3/memkind*.3*
144%{_mandir}/man7/autohbw.7*
145
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/libmemkind.a
149%{_libdir}/libautohbw.a
This page took 0.088189 seconds and 4 git commands to generate.