]> git.pld-linux.org Git - packages/lxc.git/commitdiff
Fixed name of variable.
authorspoksss <lukaszgabrych@gmail.com>
Sat, 18 Oct 2014 20:58:11 +0000 (22:58 +0200)
committerspoksss <lukaszgabrych@gmail.com>
Sat, 18 Oct 2014 20:58:11 +0000 (22:58 +0200)
Added dependencies to build package.

lxc-pld.in.sh
lxc.spec

index 57132a58584a82063cdb4cbe5fc085d7067d2c2f..d8d30aba6101e19b0cb669ec84335d5ec8c97c5a 100755 (executable)
@@ -407,12 +407,15 @@ if [ "$(id -u)" != "0" ]; then
        exit 1
 fi
 
-if [ -z "$rootfs_path" ]; then
-       rootfs_path=$path/rootfs
-       # check for 'lxc.rootfs' passed in through default config by lxc-create
-       if grep -q '^lxc.rootfs' $path/config 2>/dev/null ; then
-               rootfs_path=$(awk -F= '/^lxc.rootfs =/{ print $2 }' $path/config)
-       fi
+if [ -z "$rootfs" ]; then
+    rootfs_path=$path/rootfs
+    # check for 'lxc.rootfs' passed in through default config by lxc-create
+    # TODO: should be lxc.rootfs.mount used instead?
+    if grep -q '^lxc.rootfs' $path/config 2>/dev/null ; then
+            rootfs_path=$(awk -F= '/^lxc.rootfs =/{ print $2 }' $path/config)
+    fi
+else
+    rootfs_path=$rootfs
 fi
 config_path=$default_path/$name
 cache=$cache_base/$release
index cd3ef99402533088203bc882e511489cc4f362e6..4cdaee1b92e45aed5525093ea174df4591e03388 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -13,13 +13,13 @@ Summary:    Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
 Version:       1.0.5
-Release:       0.1
+Release:       0.2
 License:       LGPL v2.1+
 Group:         Applications/System
 Source0:       https://www.linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
 # Source0-md5: 9d9af9e9e69a831cd50b58d91c786013
 Source1:       %{name}-pld.in.sh
-Source2:        %{name}.init
+Source2:       %{name}.init
 Patch1:                %{name}-pld.patch
 URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
@@ -31,9 +31,11 @@ BuildRequires:       gnutls-devel
 %{?with_apparmor:BuildRequires:        libapparmor-devel}
 BuildRequires: libcap-devel
 %{?with_seccomp:BuildRequires: libseccomp-devel}
+BuildRequires: libxslt-progs
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 BuildRequires: pkgconfig
 %{?with_python:BuildRequires:  python3-devel >= 3.2}
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: sed >= 4.0
 Requires:      rc-scripts >= 0.4.6
This page took 0.098354 seconds and 4 git commands to generate.