]> git.pld-linux.org Git - packages/lxc.git/commitdiff
- fixed lxd containters launch issue (https://github.com/lxc/lxc/issues/3108); rel 2 auto/th/lxc-3.2.1-2
authormis <mis@pld-linux.org>
Tue, 24 Mar 2020 14:47:25 +0000 (15:47 +0100)
committermis <mis@pld-linux.org>
Tue, 24 Mar 2020 14:47:25 +0000 (15:47 +0100)
lxc-cgroups.patch [new file with mode: 0644]
lxc.spec

diff --git a/lxc-cgroups.patch b/lxc-cgroups.patch
new file mode 100644 (file)
index 0000000..f530619
--- /dev/null
@@ -0,0 +1,29 @@
+--- lxc-3.2.1/src/lxc/cgroups/cgfsng.c.orig    2019-07-23 00:34:33.000000000 +0200
++++ lxc-3.2.1/src/lxc/cgroups/cgfsng.c 2020-03-24 15:17:05.536616935 +0100
+@@ -496,12 +496,12 @@
+       }
+       if (!flipped_bit) {
+-              DEBUG("No isolated or offline cpus present in cpuset");
+-              return true;
++              cpulist = lxc_cpumask_to_cpulist(possmask, maxposs);
++              TRACE("No isolated or offline cpus present in cpuset");
++      } else {
++              cpulist = move_ptr(posscpus);
++              TRACE("Removed isolated or offline cpus from cpuset");
+       }
+-      DEBUG("Removed isolated or offline cpus from cpuset");
+-
+-      cpulist = lxc_cpumask_to_cpulist(possmask, maxposs);
+       if (!cpulist) {
+               ERROR("Failed to create cpu list");
+               return false;
+@@ -1260,7 +1260,7 @@
+       orig_len = strlen(dir);
+       do {
+-              __do_free char *makeme;
++              __do_free char *makeme = NULL;
+               int ret;
+               size_t cur_len;
index d19222539e40b1fe06a865d5cafa8e35f1ff23f4..3054df53096a9390c297a211f6ba22d52183d8a1 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -14,7 +14,7 @@ Summary:      Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
 Version:       3.2.1
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
 Version:       3.2.1
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Applications/System
 Source0:       https://linuxcontainers.org/downloads/lxc/%{name}-%{version}.tar.gz
 License:       LGPL v2.1+
 Group:         Applications/System
 Source0:       https://linuxcontainers.org/downloads/lxc/%{name}-%{version}.tar.gz
@@ -25,6 +25,7 @@ Source2:      %{name}_macvlan.sysconfig
 Source3:       %{name}_macvlan
 Patch1:                %{name}-net.patch
 Patch2:                x32.patch
 Source3:       %{name}_macvlan
 Patch1:                %{name}-net.patch
 Patch2:                x32.patch
+Patch3:                %{name}-cgroups.patch
 URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -159,6 +160,7 @@ bashowe uzupełnianie nazw dla LXC.
 %setup -q
 %patch1 -p1
 %patch2 -p1
 %setup -q
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cp -p %{SOURCE1} templates/lxc-pld.in
 
 
 cp -p %{SOURCE1} templates/lxc-pld.in
 
This page took 0.110149 seconds and 4 git commands to generate.