]> git.pld-linux.org Git - packages/lxc.git/blobdiff - lxc.spec
- release 3 (by relup.sh)
[packages/lxc.git] / lxc.spec
index 8532e4176eadff7927bca8079f1c09f09216f5f0..556d205b9ec88125cb16f7c93b270b49b468d940 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -1,10 +1,6 @@
 # TODO
 # - package apparmor stuff
 # - update (cut down, include /usr/share/lxc/config/common.conf) default pld container config
-# NOTE:
-# - does not work properly (dead symlink /proc/self) with PLD kernel 4.1.13
-#   but seems to work on 4.3.3, vserver issue ?
-#
 
 # Conditional build:
 %bcond_without seccomp         # SecComp syscall filter
 Summary:       Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
-Version:       2.0.4
-Release:       2
+Version:       2.1.1
+Release:       3
 License:       LGPL v2.1+
 Group:         Applications/System
 Source0:       https://linuxcontainers.org/downloads/lxc/%{name}-%{version}.tar.gz
-# Source0-md5: 28db4dbacf860ae742138c0ed8dbf14c
+# Source0-md5: 596f7c96ec78e361b057499dbe994703
 Source1:       %{name}-pld.in.sh
 # lxc-net based on bridge, macvlan is an alternative/supported lxc network
 Source2:       %{name}_macvlan.sysconfig
 Source3:       %{name}_macvlan
-Patch0:                %{name}-pld.patch
 Patch1:                %{name}-net.patch
+Patch2:                x32.patch
 URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -36,6 +32,7 @@ BuildRequires:        automake
 %{?with_cgmanager:BuildRequires:       dbus-devel >= 1.2.16}
 BuildRequires: docbook-dtd45-xml
 BuildRequires: docbook2X >= 0.8
+BuildRequires: doxygen
 BuildRequires: gnutls-devel
 %{?with_apparmor:BuildRequires:        libapparmor-devel}
 BuildRequires: libcap-devel
@@ -45,7 +42,7 @@ BuildRequires:        libxslt-progs
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 BuildRequires: pkgconfig
 %{?with_python:BuildRequires:  python3-devel >= 1:3.2}
-%{?with_python:BuildRequires:  python3-modules}
+%{?with_python:BuildRequires:  python3-modules >= 1:3.2}
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: sed >= 4.0
@@ -94,12 +91,16 @@ oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
 
 %package libs
 Summary:       liblxc library
+Summary(pl.UTF-8):     Biblioteka liblxc
 Group:         Libraries
-Conflicts:     %{name} < 2.0.4-2
+Conflicts:     lxc < 2.0.4-2
 
 %description libs
 liblxc library.
 
+%description libs -l pl.UTF-8
+Biblioteka liblxc.
+
 %package devel
 Summary:       Header files for lxc library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki lxc
@@ -130,8 +131,8 @@ Summary:    Python (3.x) binding for LXC
 Summary(pl.UTF-8):     Wiązanie Pythona (3.x) do LXC
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      python3-libs >= 3.2
-Requires:      python3-modules
+Requires:      python3-libs >= 1:3.2
+Requires:      python3-modules >= 1:3.2
 
 %description -n python3-lxc
 Python (3.x) binding for LXC.
@@ -143,8 +144,11 @@ Wiązanie Pythona (3.x) do LXC.
 Summary:       bash-completion for LXC
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla LXC
 Group:         Applications/Shells
-Requires:      %{name}
+Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-%{name}
 bash-completion for LXC.
@@ -154,17 +158,19 @@ bashowe uzupełnianie nazw dla LXC.
 
 %prep
 %setup -q
-%patch0 -p0
 %patch1 -p1
+%patch2 -p1
 
 cp -p %{SOURCE1} templates/lxc-pld.in
 
 %build
+%{__libtoolize}
 %{__aclocal} -I config
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       bashcompdir=%{bash_compdir} \
        db2xman=docbook2X2man \
        --disable-rpath \
        --enable-bash \
@@ -186,7 +192,7 @@ cp -p %{SOURCE1} templates/lxc-pld.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}  \
+install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc} \
         -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
 
 %{__make} install \
@@ -197,6 +203,8 @@ install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}
 %{__make} -C doc install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/liblxc.la
+
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
 
 # apparmor profiles are not packaged, remove to avoid packagers confusion
@@ -206,8 +214,7 @@ install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/lxc-patch.py
 
 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lxc_macvlan
-install -p %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/%{name}/lxc_macvlan
-
+install -p %{SOURCE3} $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lxc_macvlan
 
 %if %{with python}
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
@@ -262,6 +269,7 @@ fi
 %attr(755,root,root) %{_bindir}/lxc-stop
 %attr(755,root,root) %{_bindir}/lxc-unfreeze
 %attr(755,root,root) %{_bindir}/lxc-unshare
+%attr(755,root,root) %{_bindir}/lxc-update-config
 %attr(755,root,root) %{_bindir}/lxc-usernsexec
 %attr(755,root,root) %{_bindir}/lxc-wait
 %attr(755,root,root) %{_sbindir}/init.lxc
@@ -269,24 +277,26 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/lxc-net
 
 %{systemdunitdir}/lxc.service
+%{systemdunitdir}/lxc@.service
 %{systemdunitdir}/lxc-net.service
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/rootfs
 %{_libdir}/%{name}/rootfs/README
-%attr(755,root,root) %{_libdir}/%{name}/lxc-apparmor-load
-%attr(755,root,root) %{_libdir}/%{name}/lxc-containers
-%attr(755,root,root) %{_libdir}/%{name}/lxc-monitord
-%attr(755,root,root) %{_libdir}/%{name}/lxc-net
-%attr(755,root,root) %{_libdir}/%{name}/lxc-user-nic
-%attr(755,root,root) %{_libdir}/%{name}/lxc_macvlan
+%dir %{_libexecdir}/%{name}
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc-apparmor-load
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc-containers
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc-monitord
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc-net
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc-user-nic
+%attr(755,root,root) %{_libexecdir}/%{name}/lxc_macvlan
+%dir %{_libexecdir}/%{name}/hooks
+%attr(755,root,root) %{_libexecdir}/%{name}/hooks/unmount-namespace
 %dir %{_sysconfdir}/lxc
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lxc_macvlan
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lxc
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/lxc.functions
-# below has been removed in lxc-1.1.3
-#%attr(755,root,root) %{_datadir}/%{name}/lxc-restore-net
 %dir %{_datadir}/%{name}/config
 %{_datadir}/%{name}/config/archlinux.*.conf
 %{_datadir}/%{name}/config/centos.*.conf
@@ -294,6 +304,7 @@ fi
 %dir %{_datadir}/%{name}/config/common.conf.d
 %{_datadir}/%{name}/config/common.conf.d/README
 %{_datadir}/%{name}/config/common.seccomp
+%{_datadir}/%{name}/config/alpine.*.conf
 %{_datadir}/%{name}/config/debian.*.conf
 %{_datadir}/%{name}/config/fedora.*.conf
 %{_datadir}/%{name}/config/gentoo.*.conf
@@ -302,10 +313,15 @@ fi
 %{_datadir}/%{name}/config/openwrt.*.conf
 %{_datadir}/%{name}/config/oracle.*.conf
 %{_datadir}/%{name}/config/plamo.*.conf
+%{_datadir}/%{name}/config/sabayon.common.conf
+%{_datadir}/%{name}/config/sabayon.userns.conf
+%{_datadir}/%{name}/config/slackware.*.conf
+%{_datadir}/%{name}/config/sparclinux.*.conf
 %{_datadir}/%{name}/config/ubuntu-cloud.*.conf
 %{_datadir}/%{name}/config/ubuntu.*.conf
 %{_datadir}/%{name}/config/userns.conf
-%dir %{_libdir}/%{name}/hooks
+%{_datadir}/%{name}/config/voidlinux.common.conf
+%{_datadir}/%{name}/config/voidlinux.userns.conf
 %dir %{_datadir}/%{name}/hooks
 %dir %{_datadir}/%{name}/selinux
 %{_datadir}/%{name}/selinux/*
@@ -315,7 +331,6 @@ fi
 %attr(755,root,root) %{_datadir}/%{name}/hooks/squid-deb-proxy-client
 %attr(755,root,root) %{_datadir}/%{name}/hooks/ubuntu-cloud-prep
 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
-%attr(755,root,root) %{_libdir}/%{name}/hooks/unmount-namespace
 %{_mandir}/man1/lxc-attach.1*
 %{_mandir}/man1/lxc-autostart.1*
 %{_mandir}/man1/lxc-cgroup.1*
@@ -335,6 +350,7 @@ fi
 %{_mandir}/man1/lxc-stop.1*
 %{_mandir}/man1/lxc-unfreeze.1*
 %{_mandir}/man1/lxc-unshare.1*
+%{_mandir}/man1/lxc-update-config.1*
 %{_mandir}/man1/lxc-user-nic.1*
 %{_mandir}/man1/lxc-usernsexec.1*
 %{_mandir}/man1/lxc-wait.1*
@@ -352,11 +368,22 @@ fi
 %exclude %{_mandir}/ja/man1/lxc-device.1*
 %exclude %{_mandir}/ja/man1/lxc-ls.1*
 %exclude %{_mandir}/ja/man1/lxc-top.1*
+%lang(ko) %{_mandir}/ko/man1/lxc*.1*
+%lang(ko) %{_mandir}/ko/man5/lxc-usernet.5*
+%lang(ko) %{_mandir}/ko/man5/lxc.conf.5*
+%lang(ko) %{_mandir}/ko/man5/lxc.container.conf.5*
+%lang(ko) %{_mandir}/ko/man5/lxc.system.conf.5*
+%lang(ko) %{_mandir}/ko/man7/lxc.7*
+%exclude %{_mandir}/ko/man1/lxc-device.1*
+%exclude %{_mandir}/ko/man1/lxc-ls.1*
+%exclude %{_mandir}/ko/man1/lxc-top.1*
 
 %if %{without python}
 # legacy version
 %attr(755,root,root) %{_bindir}/lxc-ls
 %{_mandir}/man1/lxc-ls.1*
+%lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
+%lang(ko) %{_mandir}/ko/man1/lxc-ls.1*
 %endif
 
 %dir %{configpath}
@@ -384,6 +411,7 @@ fi
 %{_datadir}/lua/lxc.lua
 %{_mandir}/man1/lxc-top.1*
 %lang(ja) %{_mandir}/ja/man1/lxc-top.1*
+%lang(ko) %{_mandir}/ko/man1/lxc-top.1*
 %endif
 
 %if %{with python}
@@ -393,13 +421,15 @@ fi
 %attr(755,root,root) %{_bindir}/lxc-ls
 %{py3_sitedir}/lxc
 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
-%{py3_sitedir}/_lxc-0.1-py*.egg-info
+%{py3_sitedir}/lxc-0.1-py*.egg-info
 %{_mandir}/man1/lxc-device.1*
 %{_mandir}/man1/lxc-ls.1*
 %lang(ja) %{_mandir}/ja/man1/lxc-device.1*
 %lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
+%lang(ko) %{_mandir}/ko/man1/lxc-device.1*
+%lang(ko) %{_mandir}/ko/man1/lxc-ls.1*
 %endif
 
 %files -n bash-completion-%{name}
 %defattr(644,root,root,755)
-/etc/bash_completion.d/lxc
+%{bash_compdir}/lxc
This page took 0.111313 seconds and 4 git commands to generate.