]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
- up to 0.6.5, now FHS compliant
[packages/lxc.git] / lxc.spec
1 Summary:        Linux Container Tools
2 Name:           lxc
3 Version:        0.6.5
4 Release:        1
5 License:        GPL
6 Group:          Base
7 Source0:        http://dl.sourceforge.net/lxc/%{name}-%{version}.tar.gz
8 # Source0-md5:  d648bcf82541c0da6725da502ee1d111
9 URL:            http://sourceforge.net/projects/lxc
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  docbook-dtd30-sgml
13 BuildRequires:  docbook-utils
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         configpath      /var/lib/lxc
18
19 %description
20 Tools to create and manage containers. It contains a full featured
21 container with the isolation / virtualization of the pids, the ipc,
22 the utsname, the mount points, /proc, /sys, the network and it takes
23 into account the control groups. It is very light, flexible, and
24 provides a set of tools around the container like the monitoring with
25 asynchronous events notification, or the freeze of the container. This
26 package is useful to create Virtual Private Server, or to run isolated
27 applications like bash or sshd.
28
29 %package devel
30 Summary:        Header files and develpment documentation for lxc
31 Group:          Development/Libraries
32 Requires:       %{name} = %{epoch}:%{version}-%{release}
33
34 %description devel
35 lxc development files.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__libtoolize}
42 %{__aclocal} -I config
43 %{__autoconf}
44 %{__automake}
45 %configure \
46         --with-config-path=%{configpath}
47
48 %{__make}
49 %{__make} -C doc
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT \
56         pcdatadir=%{_pkgconfigdir}
57 %{__make} -C doc install \
58         DESTDIR=$RPM_BUILD_ROOT
59 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
60
61 install -d $RPM_BUILD_ROOT%{configpath}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog README doc/examples/*.conf
72 %attr(755,root,root) %{_bindir}/*
73 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
74 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
75 %{_mandir}/man?/lxc*
76 %dir %{configpath}
77 %attr(755,root,root) %{_libdir}/lxc-init
78
79 %files devel
80 %defattr(644,root,root,755)
81 %{_includedir}/lxc
82 %attr(755,root,root) %{_libdir}/liblxc.so
83 %{_pkgconfigdir}/lxc.pc
This page took 0.039306 seconds and 4 git commands to generate.