]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
- up to 0.7.4.2
[packages/lxc.git] / lxc.spec
1 Summary:        Linux Container Tools
2 Name:           lxc
3 Version:        0.7.4.2
4 Release:        1
5 License:        GPL
6 Group:          Base
7 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
8 # Source0-md5:  36fcb0f6a39d2f55130421f342f24ef3
9 URL:            http://lxc.sourceforge.net
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  docbook-dtd30-sgml
13 BuildRequires:  docbook-utils
14 BuildRequires:  libcap-devel
15 BuildRequires:  libtool
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         configpath      /var/lib/lxc
19
20 %description
21 Tools to create and manage containers. It contains a full featured
22 container with the isolation / virtualization of the pids, the ipc,
23 the utsname, the mount points, /proc, /sys, the network and it takes
24 into account the control groups. It is very light, flexible, and
25 provides a set of tools around the container like the monitoring with
26 asynchronous events notification, or the freeze of the container. This
27 package is useful to create Virtual Private Server, or to run isolated
28 applications like bash or sshd.
29
30 %package devel
31 Summary:        Header files and develpment documentation for lxc
32 Group:          Development/Libraries
33 Requires:       %{name} = %{epoch}:%{version}-%{release}
34
35 %description devel
36 lxc development files.
37
38 %prep
39 %setup -q
40
41 %build
42 %{__libtoolize}
43 %{__aclocal} -I config
44 %{__autoconf}
45 %{__automake}
46 %configure \
47         --with-config-path=%{configpath}
48
49 %{__make}
50 %{__make} -C doc
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT \
57         pcdatadir=%{_pkgconfigdir}
58 %{__make} -C doc install \
59         DESTDIR=$RPM_BUILD_ROOT
60 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
61
62 install -d $RPM_BUILD_ROOT%{configpath}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf 
73 %attr(755,root,root) %{_bindir}/*
74 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
75 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
76 %{_libdir}/lxc/rootfs/README
77 %{_mandir}/man?/lxc*
78 %dir %{configpath}
79 %dir %{_libdir}/lxc
80 %dir %{_libdir}/lxc/templates
81 %dir %{_libdir}/lxc/rootfs
82 %attr(755,root,root) %{_libdir}/lxc/lxc-init
83 %attr(755,root,root) %{_libdir}/lxc/templates/lxc-*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %{_includedir}/lxc
88 %attr(755,root,root) %{_libdir}/liblxc.so
89 %{_pkgconfigdir}/lxc.pc
This page took 0.074739 seconds and 4 git commands to generate.