]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
- rel 2
[packages/lxc.git] / lxc.spec
1 Summary:        Linux Container Tools
2 Name:           lxc
3 Version:        0.7.5
4 Release:        2
5 License:        GPL
6 Group:          Base
7 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
8 # Source0-md5:  04949900ff56898f4353b130929c09d1
9 Patch0:         %{name}-devpts.patch
10 URL:            http://lxc.sourceforge.net
11 BuildRequires:  docbook-dtd30-sgml
12 BuildRequires:  docbook-utils
13 BuildRequires:  libcap-devel
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         configpath      /var/lib/lxc
18
19 %description
20 Tools to create and manage containers. It contains a full featured
21 container with the isolation / virtualization of the pids, the ipc,
22 the utsname, the mount points, /proc, /sys, the network and it takes
23 into account the control groups. It is very light, flexible, and
24 provides a set of tools around the container like the monitoring with
25 asynchronous events notification, or the freeze of the container. This
26 package is useful to create Virtual Private Server, or to run isolated
27 applications like bash or sshd.
28
29 %package devel
30 Summary:        Header files and develpment documentation for lxc
31 Group:          Development/Libraries
32 Requires:       %{name} = %{epoch}:%{version}-%{release}
33
34 %description devel
35 lxc development files.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 %configure \
43         --with-config-path=%{configpath}
44
45 %{__make}
46 %{__make} -C doc
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT \
53         pcdatadir=%{_pkgconfigdir}
54
55 %{__make} -C doc install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
59
60 install -d $RPM_BUILD_ROOT%{configpath}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf 
71 %attr(755,root,root) %{_bindir}/*
72 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
73 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
74 %{_libdir}/lxc/rootfs/README
75 %{_mandir}/man?/lxc*
76 %dir %{configpath}
77 %dir %{_libdir}/lxc
78 %dir %{_libdir}/lxc/templates
79 %dir %{_libdir}/lxc/rootfs
80 %attr(755,root,root) %{_libdir}/lxc/lxc-init
81 %attr(755,root,root) %{_libdir}/lxc/templates/lxc-*
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/lxc
86 %attr(755,root,root) %{_libdir}/liblxc.so
87 %{_pkgconfigdir}/lxc.pc
This page took 0.066123 seconds and 4 git commands to generate.