]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
suggest net-tools, lxc-ps uses netstat(1)
[packages/lxc.git] / lxc.spec
1 #
2 # Conditional build:
3 %bcond_without  seccomp # SecComp syscall filter
4 %bcond_without  lua     # Lua binding
5 %bcond_without  python  # Python binding
6
7 Summary:        Linux Container Tools
8 Summary(pl.UTF-8):      Narzędzia do kontenerów linuksowych (LXC)
9 Name:           lxc
10 Version:        0.9.0
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          Applications/System
14 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
15 # Source0-md5:  8552a4479090616f4bc04d8473765fc9
16 Patch0:         %{name}-devpts.patch
17 Patch1:         %{name}-pld.patch
18 URL:            http://lxc.sourceforge.net/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  docbook-dtd30-sgml
22 BuildRequires:  docbook-utils
23 BuildRequires:  docbook2X
24 BuildRequires:  libapparmor-devel
25 BuildRequires:  libcap-devel
26 %{?with_seccomp:BuildRequires:  libseccomp-devel}
27 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
28 BuildRequires:  pkgconfig
29 %{?with_python:BuildRequires:   python3-devel >= 3.2}
30 BuildRequires:  rpmbuild(macros) >= 1.612
31 BuildRequires:  sed >= 4.0
32 Suggests:       net-tools
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         configpath      /var/lib/lxc
36
37 %description
38 Tools to create and manage containers. It contains a full featured
39 container with the isolation / virtualization of the pids, the ipc,
40 the utsname, the mount points, /proc, /sys, the network and it takes
41 into account the control groups. It is very light, flexible, and
42 provides a set of tools around the container like the monitoring with
43 asynchronous events notification, or the freeze of the container. This
44 package is useful to create Virtual Private Server, or to run isolated
45 applications like bash or sshd.
46
47 %description -l pl.UTF-8
48 Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
49 w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
50 utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
51 grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
52 do czynności związanych z kontenerami, takich jak monitorowanie z
53 asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
54 pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
55 oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
56
57 %package devel
58 Summary:        Header files for lxc library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxc
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header files for lxc library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki lxc.
68
69 %package -n lua-lxc
70 Summary:        Lua binding for LXC
71 Summary(pl.UTF-8):      Wiązanie Lua do LXC
72 Group:          Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       lua51-libs >= 5.1
75
76 %description -n lua-lxc
77 Lua binding for LXC.
78
79 %description -n lua-lxc -l pl.UTF-8
80 Wiązanie Lua do LXC.
81
82 %package -n python3-lxc
83 Summary:        Python (3.x) binding for LXC
84 Summary(pl.UTF-8):      Wiązanie Pythona (3.x) do LXC
85 Group:          Libraries
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       python3-libs >= 3.2
88
89 %description -n python3-lxc
90 Python (3.x) binding for LXC.
91
92 %description -n python3-lxc -l pl.UTF-8
93 Wiązanie Pythona (3.x) do LXC.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 %{__aclocal} -I config
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         db2xman=docbook2X2man \
107         --disable-rpath \
108         --enable-doc \
109         %{?with_lua:--enable-lua} \
110         %{?with_python:--enable-python} \
111         %{?with_seccomp:--enable-seccomp} \
112         --with-config-path=%{configpath} \
113         --with-distro=pld
114
115 %{__make}
116 %{__make} -C doc
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         pcdatadir=%{_pkgconfigdir}
124
125 %{__make} -C doc install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
129
130 install -d $RPM_BUILD_ROOT%{configpath}
131
132 %if %{with python}
133 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
134 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
135 %endif
136 %if %{with lua}
137 %{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
138 %endif
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
149 %attr(755,root,root) %{_bindir}/lxc-attach
150 %attr(755,root,root) %{_bindir}/lxc-cgroup
151 %attr(755,root,root) %{_bindir}/lxc-checkconfig
152 %attr(755,root,root) %{_bindir}/lxc-checkpoint
153 %attr(755,root,root) %{_bindir}/lxc-clone
154 %attr(755,root,root) %{_bindir}/lxc-console
155 %attr(755,root,root) %{_bindir}/lxc-create
156 %attr(755,root,root) %{_bindir}/lxc-destroy
157 %attr(755,root,root) %{_bindir}/lxc-execute
158 %attr(755,root,root) %{_bindir}/lxc-freeze
159 %attr(755,root,root) %{_bindir}/lxc-info
160 %attr(755,root,root) %{_bindir}/lxc-kill
161 %attr(755,root,root) %{_bindir}/lxc-monitor
162 %attr(755,root,root) %{_bindir}/lxc-netstat
163 %attr(755,root,root) %{_bindir}/lxc-ps
164 %attr(755,root,root) %{_bindir}/lxc-restart
165 %attr(755,root,root) %{_bindir}/lxc-shutdown
166 %attr(755,root,root) %{_bindir}/lxc-start
167 %attr(755,root,root) %{_bindir}/lxc-stop
168 %attr(755,root,root) %{_bindir}/lxc-unfreeze
169 %attr(755,root,root) %{_bindir}/lxc-unshare
170 %attr(755,root,root) %{_bindir}/lxc-version
171 %attr(755,root,root) %{_bindir}/lxc-wait
172 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
174 %dir %{configpath}
175 %dir %{_libdir}/lxc
176 %dir %{_libdir}/lxc/rootfs
177 %{_libdir}/lxc/rootfs/README
178 %attr(755,root,root) %{_libdir}/lxc/lxc-init
179 %dir %{_sysconfdir}/lxc
180 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
181 %{_datadir}/lxc
182 %{_mandir}/man1/lxc-attach.1*
183 %{_mandir}/man1/lxc-cgroup.1*
184 %{_mandir}/man1/lxc-checkconfig.1*
185 %{_mandir}/man1/lxc-checkpoint.1*
186 %{_mandir}/man1/lxc-clone.1*
187 %{_mandir}/man1/lxc-console.1*
188 %{_mandir}/man1/lxc-create.1*
189 %{_mandir}/man1/lxc-destroy.1*
190 %{_mandir}/man1/lxc-execute.1*
191 %{_mandir}/man1/lxc-freeze.1*
192 %{_mandir}/man1/lxc-info.1*
193 %{_mandir}/man1/lxc-kill.1*
194 %{_mandir}/man1/lxc-monitor.1*
195 %{_mandir}/man1/lxc-netstat.1*
196 %{_mandir}/man1/lxc-ps.1*
197 %{_mandir}/man1/lxc-restart.1*
198 %{_mandir}/man1/lxc-shutdown.1*
199 %{_mandir}/man1/lxc-start.1*
200 %{_mandir}/man1/lxc-stop.1*
201 %{_mandir}/man1/lxc-unfreeze.1*
202 %{_mandir}/man1/lxc-unshare.1*
203 %{_mandir}/man1/lxc-version.1*
204 %{_mandir}/man1/lxc-wait.1*
205 %{_mandir}/man5/lxc.conf.5*
206 %{_mandir}/man7/lxc.7*
207 %if %{without python}
208 # legacy version
209 %attr(755,root,root) %{_bindir}/lxc-ls
210 %{_mandir}/man1/lxc-ls.1*
211 %endif
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/liblxc.so
216 %{_includedir}/lxc
217 %{_pkgconfigdir}/lxc.pc
218
219 %if %{with lua}
220 %files -n lua-lxc
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/lxc-top
223 %dir %{_libdir}/lua/5.1/lxc
224 %attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
225 %{_datadir}/lua/5.1/lxc.lua
226 %{_mandir}/man1/lxc-top.1*
227 %endif
228
229 %if %{with python}
230 %files -n python3-lxc
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/lxc-device
233 %attr(755,root,root) %{_bindir}/lxc-ls
234 %attr(755,root,root) %{_bindir}/lxc-start-ephemeral
235 %{py3_sitedir}/lxc
236 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
237 %{py3_sitedir}/_lxc-0.1-py*.egg-info
238 %{_mandir}/man1/lxc-device.1*
239 %{_mandir}/man1/lxc-ls.1*
240 %{_mandir}/man1/lxc-start-ephemeral.1*
241 %endif
This page took 0.106173 seconds and 4 git commands to generate.