]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
- 0.6.2
[packages/lxc.git] / lxc.spec
1 # TODO: FHS (/var/lxc -> /var/lib/lxc)
2 Summary:        Linux Container Tools
3 Name:           lxc
4 Version:        0.6.2
5 Release:        1
6 License:        GPL
7 Group:          Base
8 Source0:        http://dl.sourceforge.net/lxc/%{name}-%{version}.tar.gz
9 # Source0-md5:  eb4e14c2d58663f5ebcd6cd3d6a61fe6
10 Patch0:         %{name}-ldflags.patch
11 URL:            http://sourceforge.net/projects/lxc
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Tools to create and manage containers. It contains a full featured
19 container with the isolation / virtualization of the pids, the ipc,
20 the utsname, the mount points, /proc, /sys, the network and it takes
21 into account the control groups. It is very light, flexible, and
22 provides a set of tools around the container like the monitoring with
23 asynchronous events notification, or the freeze of the container. This
24 package is useful to create Virtual Private Server, or to run isolated
25 applications like bash or sshd.
26
27 %package devel
28 Summary:        Header files and develpment documentation for lxc
29 Group:          Development/Libraries
30 Requires:       %{name} = %{epoch}:%{version}-%{release}
31
32 %description devel
33 lxc development files.
34
35 %package static
36 Summary:        Static lxc library
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
39
40 %description static
41 Static lxc library.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46 sed -i -e 's#^lxcpath=.*#lxcpath=/var/lxc#g' src/lxc/Makefile.am
47
48 %build
49 %{__libtoolize}
50 %{__aclocal} -I config
51 %{__autoconf}
52 %{__automake}
53 %configure
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT/var/lxc
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files
72 %defattr(644,root,root,755)
73 %doc AUTHORS ChangeLog README etc/*.conf etc/*-config
74 %dir %{_sysconfdir}/lxc
75 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/*
76 %attr(755,root,root) %{_bindir}/*
77 %attr(755,root,root) %{_libdir}/liblxc-*.so
78 %{_mandir}/*/**
79 %dir %{_sysconfdir}/lxc
80 %dir /var/lxc
81 %attr(755,root,root) %{_libdir}/lxc-init
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/lxc
86 %attr(755,root,root) %{_libdir}/liblxc.so
87 %{_libdir}/lib*.la
88
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/lib*.a
This page took 0.041575 seconds and 4 git commands to generate.