]> git.pld-linux.org Git - packages/lxc.git/blame - lxc.spec
suggest gnupg for gpg tool (for lxc-create -t download template)
[packages/lxc.git] / lxc.spec
CommitLineData
8ba1db82 1# TODO
8ba1db82
ER
2# - package apparmor stuff
3
67c70229
JB
4# Conditional build:
5%bcond_without seccomp # SecComp syscall filter
ccd4948a 6%bcond_without apparmor # apparmor
67c70229
JB
7%bcond_without lua # Lua binding
8%bcond_without python # Python binding
120ac263 9%bcond_with selinux # SELinux
8ba1db82 10%bcond_with cgmanager # Enable cgmanager (BR: libcgmanager, libnih >= 1.0.2, libnih-dbus >= 1.0.0, dbus-1 >= 1.2.16)
21c5c666 11
247c2ba9 12Summary: Linux Containers userspace tools
67c70229 13Summary(pl.UTF-8): Narzędzia do kontenerów linuksowych (LXC)
0886a606 14Name: lxc
247c2ba9 15Version: 1.0.0
39773dac 16Release: 0.3
c34ce688 17License: LGPL v2.1+
67c70229 18Group: Applications/System
9db966c1
ER
19Source0: http://linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
20# Source0-md5: 87a9d168a6e55326303cce3b2cb7f82e
adc39309 21Source1: %{name}-pld.in.sh
67c70229 22Patch1: %{name}-pld.patch
247c2ba9 23URL: http://linuxcontainers.org/
67c70229
JB
24BuildRequires: autoconf >= 2.50
25BuildRequires: automake
e5afa52e 26BuildRequires: docbook-dtd30-sgml
27BuildRequires: docbook-utils
21c5c666 28BuildRequires: docbook2X
7e4c14a6 29BuildRequires: gnutls-devel
ccd4948a 30%{?with_apparmor:BuildRequires: libapparmor-devel}
4e32c712 31BuildRequires: libcap-devel
67c70229
JB
32%{?with_seccomp:BuildRequires: libseccomp-devel}
33%{?with_lua:BuildRequires: lua51-devel >= 5.1}
34BuildRequires: pkgconfig
35%{?with_python:BuildRequires: python3-devel >= 3.2}
36BuildRequires: rpmbuild(macros) >= 1.612
c34ce688 37BuildRequires: sed >= 4.0
7e514b06 38Requires: rc-scripts >= 0.4.6
adc39309 39Requires: which
7f0b7e89 40Suggests: gnupg
21c5c666 41Suggests: net-tools
b335abc0 42Suggests: rsync
0886a606
AM
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
e5afa52e 45%define configpath /var/lib/lxc
46
0886a606
AM
47%description
48Tools to create and manage containers. It contains a full featured
49container with the isolation / virtualization of the pids, the ipc,
50the utsname, the mount points, /proc, /sys, the network and it takes
51into account the control groups. It is very light, flexible, and
52provides a set of tools around the container like the monitoring with
53asynchronous events notification, or the freeze of the container. This
54package is useful to create Virtual Private Server, or to run isolated
55applications like bash or sshd.
56
67c70229
JB
57%description -l pl.UTF-8
58Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
59w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
60utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
61grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
62do czynności związanych z kontenerami, takich jak monitorowanie z
63asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
64pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
65oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
66
0886a606 67%package devel
67c70229
JB
68Summary: Header files for lxc library
69Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lxc
0886a606 70Group: Development/Libraries
67c70229 71Requires: %{name} = %{version}-%{release}
0886a606
AM
72
73%description devel
67c70229
JB
74Header files for lxc library.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe biblioteki lxc.
78
79%package -n lua-lxc
80Summary: Lua binding for LXC
81Summary(pl.UTF-8): Wiązanie Lua do LXC
82Group: Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: lua51-libs >= 5.1
85
86%description -n lua-lxc
87Lua binding for LXC.
88
89%description -n lua-lxc -l pl.UTF-8
90Wiązanie Lua do LXC.
91
92%package -n python3-lxc
93Summary: Python (3.x) binding for LXC
94Summary(pl.UTF-8): Wiązanie Pythona (3.x) do LXC
95Group: Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: python3-libs >= 3.2
91c8fae7 98Requires: python3-modules
67c70229
JB
99
100%description -n python3-lxc
101Python (3.x) binding for LXC.
102
103%description -n python3-lxc -l pl.UTF-8
104Wiązanie Pythona (3.x) do LXC.
0886a606 105
4e82464d
ER
106%package -n bash-completion-%{name}
107Summary: bash-completion for LXC
108Summary(pl.UTF-8): bashowe uzupełnianie nazw dla LXC
109Group: Applications/Shells
110Requires: %{name}
111Requires: bash-completion
112
113%description -n bash-completion-%{name}
114bash-completion for LXC.
115
116%description -n bash-completion-%{name} -l pl.UTF-8
117bashowe uzupełnianie nazw dla LXC.
118
0886a606 119%prep
9db966c1 120%setup -q
67c70229 121%patch1 -p1
0886a606 122
8a96554a
ER
123cp -p %{SOURCE1} templates/lxc-pld.in
124
0886a606 125%build
67c70229
JB
126%{__aclocal} -I config
127%{__autoconf}
128%{__autoheader}
129%{__automake}
e5afa52e 130%configure \
67c70229
JB
131 db2xman=docbook2X2man \
132 --disable-rpath \
8ba1db82 133 --enable-bash \
67c70229 134 --enable-doc \
120ac263 135 --enable-examples \
ccd4948a 136 %{__enable_disable apparmor} \
247c2ba9 137 %{__enable_disable lua} %{?with_lua:--with-lua-pc=lua51} \
ccd4948a
ER
138 %{__enable_disable python} \
139 %{__enable_disable seccomp} \
120ac263 140 %{__enable_disable selinux} \
67c70229 141 --with-config-path=%{configpath} \
8ba1db82 142 --with-init-script=sysvinit,systemd \
9db966c1 143 --with-runtime-path=/var/run \
67c70229 144 --with-distro=pld
0886a606
AM
145
146%{__make}
e5afa52e 147%{__make} -C doc
0886a606
AM
148
149%install
150rm -rf $RPM_BUILD_ROOT
39773dac 151install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}
0886a606 152%{__make} install \
7e4c14a6
ER
153 SYSTEMD_UNIT_DIR=%{systemdunitdir} \
154 pcdatadir=%{_pkgconfigdir} \
155 DESTDIR=$RPM_BUILD_ROOT
33aee790 156
e5afa52e 157%{__make} -C doc install \
0886a606 158 DESTDIR=$RPM_BUILD_ROOT
33aee790 159
21c5c666 160%{__rm} -r $RPM_BUILD_ROOT%{_docdir}
0886a606 161
67c70229
JB
162%if %{with python}
163%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
164%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
165%endif
c34ce688
JB
166%if %{with lua}
167%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
168%endif
67c70229 169
0886a606
AM
170%clean
171rm -rf $RPM_BUILD_ROOT
172
67c70229
JB
173%post -p /sbin/ldconfig
174%postun -p /sbin/ldconfig
0886a606
AM
175
176%files
177%defattr(644,root,root,755)
247c2ba9 178%doc AUTHORS CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
c34ce688 179%attr(755,root,root) %{_bindir}/lxc-attach
7e4c14a6 180%attr(755,root,root) %{_bindir}/lxc-autostart
c34ce688
JB
181%attr(755,root,root) %{_bindir}/lxc-cgroup
182%attr(755,root,root) %{_bindir}/lxc-checkconfig
c34ce688 183%attr(755,root,root) %{_bindir}/lxc-clone
247c2ba9 184%attr(755,root,root) %{_bindir}/lxc-config
c34ce688
JB
185%attr(755,root,root) %{_bindir}/lxc-console
186%attr(755,root,root) %{_bindir}/lxc-create
187%attr(755,root,root) %{_bindir}/lxc-destroy
188%attr(755,root,root) %{_bindir}/lxc-execute
189%attr(755,root,root) %{_bindir}/lxc-freeze
190%attr(755,root,root) %{_bindir}/lxc-info
c34ce688 191%attr(755,root,root) %{_bindir}/lxc-monitor
247c2ba9 192%attr(755,root,root) %{_bindir}/lxc-snapshot
c34ce688
JB
193%attr(755,root,root) %{_bindir}/lxc-start
194%attr(755,root,root) %{_bindir}/lxc-stop
195%attr(755,root,root) %{_bindir}/lxc-unfreeze
196%attr(755,root,root) %{_bindir}/lxc-unshare
120ac263 197%attr(755,root,root) %{_bindir}/lxc-usernsexec
c34ce688 198%attr(755,root,root) %{_bindir}/lxc-wait
e5afa52e 199%attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
247c2ba9 200%attr(755,root,root) %ghost %{_libdir}/liblxc.so.1
7e4c14a6
ER
201%attr(754,root,root) /etc/rc.d/init.d/lxc
202%{systemdunitdir}/lxc.service
8ba1db82
ER
203%dir %{_libdir}/%{name}
204%dir %{_libdir}/%{name}/rootfs
205%{_libdir}/%{name}/rootfs/README
206%attr(755,root,root) %{_libdir}/%{name}/lxc-devsetup
207%attr(755,root,root) %{_libdir}/%{name}/lxc-init
208%attr(755,root,root) %{_libdir}/%{name}/lxc-monitord
209%attr(755,root,root) %{_libdir}/%{name}/lxc-user-nic
dc9a5b3b 210%dir %{_sysconfdir}/lxc
67c70229 211%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
120ac263 212%dir %{_datadir}/%{name}
f5933d47 213%{_datadir}/%{name}/lxc.functions
120ac263 214%dir %{_datadir}/%{name}/config
8ba1db82
ER
215%{_datadir}/%{name}/config/centos.*.conf
216%{_datadir}/%{name}/config/debian.*.conf
217%{_datadir}/%{name}/config/fedora.*.conf
3f7b319e 218%{_datadir}/%{name}/config/gentoo.*.conf
8ba1db82
ER
219%{_datadir}/%{name}/config/oracle.*.conf
220%{_datadir}/%{name}/config/plamo.*.conf
221%{_datadir}/%{name}/config/ubuntu-cloud.*.conf
222%{_datadir}/%{name}/config/ubuntu.*.conf
f5933d47
ER
223%dir %{_datadir}/%{name}/hooks
224%dir %{_datadir}/%{name}/templates
247c2ba9 225%attr(755,root,root) %{_datadir}/%{name}/hooks/clonehostname
7e4c14a6
ER
226%attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
227%attr(755,root,root) %{_datadir}/%{name}/hooks/squid-deb-proxy-client
247c2ba9 228%attr(755,root,root) %{_datadir}/%{name}/hooks/ubuntu-cloud-prep
f5933d47 229%attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
c34ce688 230%{_mandir}/man1/lxc-attach.1*
7e4c14a6 231%{_mandir}/man1/lxc-autostart.1*
c34ce688
JB
232%{_mandir}/man1/lxc-cgroup.1*
233%{_mandir}/man1/lxc-checkconfig.1*
c34ce688 234%{_mandir}/man1/lxc-clone.1*
8ba1db82 235%{_mandir}/man1/lxc-config.1*
c34ce688
JB
236%{_mandir}/man1/lxc-console.1*
237%{_mandir}/man1/lxc-create.1*
238%{_mandir}/man1/lxc-destroy.1*
239%{_mandir}/man1/lxc-execute.1*
240%{_mandir}/man1/lxc-freeze.1*
241%{_mandir}/man1/lxc-info.1*
c34ce688 242%{_mandir}/man1/lxc-monitor.1*
247c2ba9 243%{_mandir}/man1/lxc-snapshot.1*
c34ce688
JB
244%{_mandir}/man1/lxc-start.1*
245%{_mandir}/man1/lxc-stop.1*
246%{_mandir}/man1/lxc-unfreeze.1*
247%{_mandir}/man1/lxc-unshare.1*
120ac263 248%{_mandir}/man1/lxc-user-nic.1*
8ba1db82 249%{_mandir}/man1/lxc-usernsexec.1*
c34ce688 250%{_mandir}/man1/lxc-wait.1*
120ac263 251%{_mandir}/man5/lxc-usernet.5*
67c70229 252%{_mandir}/man5/lxc.conf.5*
8ba1db82
ER
253%{_mandir}/man5/lxc.container.conf.5*
254%{_mandir}/man5/lxc.system.conf.5*
67c70229 255%{_mandir}/man7/lxc.7*
247c2ba9 256%lang(ja) %{_mandir}/ja/man1/lxc*.1*
7e4c14a6 257%lang(ja) %{_mandir}/ja/man5/lxc-usernet.5*
247c2ba9 258%lang(ja) %{_mandir}/ja/man5/lxc.conf.5*
8ba1db82
ER
259%lang(ja) %{_mandir}/ja/man5/lxc.container.conf.5*
260%lang(ja) %{_mandir}/ja/man5/lxc.system.conf.5*
247c2ba9
ER
261%lang(ja) %{_mandir}/ja/man7/lxc.7*
262%exclude %{_mandir}/ja/man1/lxc-device.1*
263%exclude %{_mandir}/ja/man1/lxc-ls.1*
264%exclude %{_mandir}/ja/man1/lxc-start-ephemeral.1*
265%exclude %{_mandir}/ja/man1/lxc-top.1*
266
c34ce688
JB
267%if %{without python}
268# legacy version
269%attr(755,root,root) %{_bindir}/lxc-ls
270%{_mandir}/man1/lxc-ls.1*
271%endif
0886a606 272
ff8ce371 273%dir %{configpath}
39773dac 274%dir %{configpath}snap
f10dfb13
ER
275%dir %attr(750,root,root) /var/log/lxc
276%dir %attr(750,root,root) /var/cache/lxc
ff8ce371 277
0886a606
AM
278%files devel
279%defattr(644,root,root,755)
0886a606 280%attr(755,root,root) %{_libdir}/liblxc.so
67c70229 281%{_includedir}/lxc
e5afa52e 282%{_pkgconfigdir}/lxc.pc
67c70229
JB
283
284%if %{with lua}
285%files -n lua-lxc
286%defattr(644,root,root,755)
c34ce688 287%attr(755,root,root) %{_bindir}/lxc-top
247c2ba9
ER
288%dir %{_libdir}/lua/lxc
289%attr(755,root,root) %{_libdir}/lua/lxc/core.so
290%{_datadir}/lua/lxc.lua
c34ce688 291%{_mandir}/man1/lxc-top.1*
247c2ba9 292%lang(ja) %{_mandir}/ja/man1/lxc-top.1*
67c70229
JB
293%endif
294
295%if %{with python}
296%files -n python3-lxc
297%defattr(644,root,root,755)
c34ce688
JB
298%attr(755,root,root) %{_bindir}/lxc-device
299%attr(755,root,root) %{_bindir}/lxc-ls
300%attr(755,root,root) %{_bindir}/lxc-start-ephemeral
67c70229
JB
301%{py3_sitedir}/lxc
302%attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
303%{py3_sitedir}/_lxc-0.1-py*.egg-info
c34ce688
JB
304%{_mandir}/man1/lxc-device.1*
305%{_mandir}/man1/lxc-ls.1*
306%{_mandir}/man1/lxc-start-ephemeral.1*
247c2ba9
ER
307%lang(ja) %{_mandir}/ja/man1/lxc-device.1*
308%lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
309%lang(ja) %{_mandir}/ja/man1/lxc-start-ephemeral.1*
67c70229 310%endif
4e82464d
ER
311
312%files -n bash-completion-%{name}
313%defattr(644,root,root,755)
314/etc/bash_completion.d/lxc
This page took 0.08742 seconds and 4 git commands to generate.