- fix building with kernel 5.8 auto/th/lin_tape-3.0.52-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 16 Aug 2020 16:56:47 +0000 (18:56 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 16 Aug 2020 16:56:47 +0000 (18:56 +0200)
- rel 2

kernel-5.8.patch [new file with mode: 0644]
lin_tape.spec

diff --git a/kernel-5.8.patch b/kernel-5.8.patch
new file mode 100644 (file)
index 0000000..e7027c2
--- /dev/null
@@ -0,0 +1,26 @@
+--- lin_tape-3.0.52/lin_tape_scsi_tape.c~      2020-03-05 19:43:09.000000000 +0100
++++ lin_tape-3.0.52/lin_tape_scsi_tape.c       2020-08-16 18:55:05.857678020 +0200
+@@ -11533,7 +11533,11 @@
+       memset(pages, '\0', drv->supported_sg_tablesize * sizeof(struct page*));
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,8,0)
+       down_read(&current->mm->mmap_sem);
++#else
++      mmap_read_lock(current->mm);
++#endif
+ #if LINUX_VERSION_CODE == KERNEL_VERSION(4,4,73) \
+       || (LINUX_VERSION_CODE >= KERNEL_VERSION(4,4,92) && LINUX_VERSION_CODE < KERNEL_VERSION(4,4,103)) \
+       || defined(SLESKERNEL_4_4_103_6) \
+@@ -11548,7 +11552,11 @@
+       mapped_pages = get_user_pages(current, current->mm,
+               (ulong)user_location, number_pages, rw, 0, pages, NULL);
+ #endif
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,8,0)
+       up_read(&current->mm->mmap_sem);
++#else
++      mmap_read_unlock(current->mm);
++#endif
+       if(mapped_pages < number_pages) {
+               rc = -EFAULT;
index cb8a5b8042b0aa8eb7ac47ba71f6062a520d00e8..ddf6e5982dca5258e5af865c525c7a810a27acc3 100644 (file)
@@ -5,7 +5,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     1
+%define                rel     2
 %define                pname   lin_tape
 Summary:       IBM Tape SCSI Device Driver for Linux
 Name:          %{pname}%{_alt_kernel}
@@ -20,6 +20,7 @@ Patch0:               use-module-dir.patch
 Patch1:                clean-ifdefs.patch
 Patch2:                kernel-5.0.patch
 Patch3:                kernel-5.6.patch
+Patch4:                kernel-5.8.patch
 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
 URL:           http://www.ibm.com/support/fixcentral/
 BuildRequires: rpmbuild(macros) >= 1.701
@@ -71,6 +72,7 @@ compatible platforms.\
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 install -p %{SOURCE1} .
 
This page took 0.498159 seconds and 4 git commands to generate.