]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
dd98a864dc029d7b0671ff10a9406c7149907def
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     1
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.20
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  e9780677ade7969498032f10611a3bb6
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         linux-4.9.patch
22 Patch3:         linux-4.10.patch
23 Patch4:         linux-4.11.patch
24 Patch5:         linux-4.12.patch
25 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
26 URL:            http://www.ibm.com/support/fixcentral/
27 BuildRequires:  rpmbuild(macros) >= 1.701
28 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The IBM Tape Device Driver, lin_tape, product is a device driver that
33 provides attachment for the IBM TotalStorage and System Storage tape
34 devices to Linux compatible platforms.
35
36 %define kernel_pkg()\
37 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
38 Summary:        IBM Tape SCSI Device Driver for Linux\
39 Release:        %{rel}@%{_kernel_ver_str}\
40 Group:          Base/Kernel\
41 Requires(post,postun):  /sbin/depmod\
42 %requires_releq_kernel\
43 Requires(postun):       %releq_kernel\
44 \
45 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
46 The IBM Tape Device Driver is a device driver that provides attachment\
47 for the IBM TotalStorage and System Storage tape devices to Linux\
48 compatible platforms.\
49 \
50 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
51 %depmod %{_kernel_ver}\
52 \
53 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
54 %depmod %{_kernel_ver}\
55 \
56 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
57 %defattr(644,root,root,755)\
58 %doc lin_tape.fixlist lin_tape.ReadMe\
59 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
60 %{nil}
61
62 %define build_kernel_pkg()\
63 %build_kernel_modules -m lin_tape\
64 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
65 %{nil}
66
67 %{expand:%create_kernel_packages}
68
69 %prep
70 %setup -q -n %{pname}-%{version}
71 %undos Makefile
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77 %patch5 -p1
78
79 install -p %{SOURCE1} .
80
81 %build
82 %{expand:%build_kernel_packages}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT
87
88 cp -a installed/* $RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
This page took 0.053786 seconds and 2 git commands to generate.