]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
a11b6ab92e81b0aa1d29e2a453170927371e6f8b
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     2
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.20
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  e9780677ade7969498032f10611a3bb6
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         linux-4.9.patch
22 Patch3:         linux-4.10.patch
23 Patch4:         linux-4.11.patch
24 Patch5:         linux-4.12.patch
25 Patch6:         linux-4.13.patch
26 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
27 URL:            http://www.ibm.com/support/fixcentral/
28 BuildRequires:  rpmbuild(macros) >= 1.701
29 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The IBM Tape Device Driver, lin_tape, product is a device driver that
34 provides attachment for the IBM TotalStorage and System Storage tape
35 devices to Linux compatible platforms.
36
37 %define kernel_pkg()\
38 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
39 Summary:        IBM Tape SCSI Device Driver for Linux\
40 Release:        %{rel}@%{_kernel_ver_str}\
41 Group:          Base/Kernel\
42 Requires(post,postun):  /sbin/depmod\
43 %requires_releq_kernel\
44 Requires(postun):       %releq_kernel\
45 \
46 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
47 The IBM Tape Device Driver is a device driver that provides attachment\
48 for the IBM TotalStorage and System Storage tape devices to Linux\
49 compatible platforms.\
50 \
51 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
52 %depmod %{_kernel_ver}\
53 \
54 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
55 %depmod %{_kernel_ver}\
56 \
57 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
58 %defattr(644,root,root,755)\
59 %doc lin_tape.fixlist lin_tape.ReadMe\
60 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
61 %{nil}
62
63 %define build_kernel_pkg()\
64 %build_kernel_modules -m lin_tape\
65 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
66 %{nil}
67
68 %{expand:%create_kernel_packages}
69
70 %prep
71 %setup -q -n %{pname}-%{version}
72 %undos Makefile
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77 %patch4 -p1
78 %patch5 -p1
79 %patch6 -p1
80
81 install -p %{SOURCE1} .
82
83 %build
84 %{expand:%build_kernel_packages}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT
89
90 cp -a installed/* $RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
This page took 0.0535 seconds and 2 git commands to generate.