]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
- rel 3
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     3
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.33
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  c22358f485f12baa7254aa25abe20a43
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         linux-4.9.patch
22 Patch4:         linux-4.11.patch
23 Patch5:         linux-4.12.patch
24 Patch6:         linux-4.13.patch
25 Patch7:         kernel-4.14.patch
26 Patch8:         kernel-4.15.patch
27 Patch9:         kernel-4.17.patch
28 Patch10:        kernel-4.19.patch
29 Patch11:        linux-4.4.169.patch
30 Patch12:        kernel-5.0.patch
31 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
32 URL:            http://www.ibm.com/support/fixcentral/
33 BuildRequires:  rpmbuild(macros) >= 1.701
34 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The IBM Tape Device Driver, lin_tape, product is a device driver that
39 provides attachment for the IBM TotalStorage and System Storage tape
40 devices to Linux compatible platforms.
41
42 %define kernel_pkg()\
43 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
44 Summary:        IBM Tape SCSI Device Driver for Linux\
45 Release:        %{rel}@%{_kernel_ver_str}\
46 Group:          Base/Kernel\
47 Requires(post,postun):  /sbin/depmod\
48 %requires_releq_kernel\
49 Requires(postun):       %releq_kernel\
50 \
51 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
52 The IBM Tape Device Driver is a device driver that provides attachment\
53 for the IBM TotalStorage and System Storage tape devices to Linux\
54 compatible platforms.\
55 \
56 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
57 %depmod %{_kernel_ver}\
58 \
59 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
60 %depmod %{_kernel_ver}\
61 \
62 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
63 %defattr(644,root,root,755)\
64 %doc lin_tape.fixlist lin_tape.ReadMe\
65 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
66 %{nil}
67
68 %define build_kernel_pkg()\
69 %build_kernel_modules -m lin_tape\
70 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
71 %{nil}
72
73 %{expand:%create_kernel_packages}
74
75 %prep
76 %setup -q -n %{pname}-%{version}
77 %undos Makefile
78 %patch0 -p1
79 %patch1 -p1
80 %patch2 -p1
81 %patch4 -p1
82 %patch5 -p1
83 %patch6 -p1
84 %patch7 -p1
85 %patch8 -p1
86 %patch9 -p1
87 %patch10 -p1
88 %patch11 -p1
89 %patch12 -p1
90
91 install -p %{SOURCE1} .
92
93 %build
94 %{expand:%build_kernel_packages}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT
99
100 cp -a installed/* $RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
This page took 0.067522 seconds and 3 git commands to generate.