]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
- up to 3.0.23
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     1
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.23
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  38edd3855f4205250cb725df6a8ef2a3
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         linux-4.9.patch
22 Patch3:         linux-4.10.patch
23 Patch4:         linux-4.11.patch
24 Patch5:         linux-4.12.patch
25 Patch6:         linux-4.13.patch
26 Patch7:         kernel-4.14.patch
27 Patch8:         kernel-4.15.patch
28 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
29 URL:            http://www.ibm.com/support/fixcentral/
30 BuildRequires:  rpmbuild(macros) >= 1.701
31 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The IBM Tape Device Driver, lin_tape, product is a device driver that
36 provides attachment for the IBM TotalStorage and System Storage tape
37 devices to Linux compatible platforms.
38
39 %define kernel_pkg()\
40 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
41 Summary:        IBM Tape SCSI Device Driver for Linux\
42 Release:        %{rel}@%{_kernel_ver_str}\
43 Group:          Base/Kernel\
44 Requires(post,postun):  /sbin/depmod\
45 %requires_releq_kernel\
46 Requires(postun):       %releq_kernel\
47 \
48 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
49 The IBM Tape Device Driver is a device driver that provides attachment\
50 for the IBM TotalStorage and System Storage tape devices to Linux\
51 compatible platforms.\
52 \
53 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
54 %depmod %{_kernel_ver}\
55 \
56 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
57 %depmod %{_kernel_ver}\
58 \
59 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
60 %defattr(644,root,root,755)\
61 %doc lin_tape.fixlist lin_tape.ReadMe\
62 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
63 %{nil}
64
65 %define build_kernel_pkg()\
66 %build_kernel_modules -m lin_tape\
67 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
68 %{nil}
69
70 %{expand:%create_kernel_packages}
71
72 %prep
73 %setup -q -n %{pname}-%{version}
74 %undos Makefile
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80 %patch5 -p1
81 %patch6 -p1
82 %patch7 -p1
83 %patch8 -p1
84
85 install -p %{SOURCE1} .
86
87 %build
88 %{expand:%build_kernel_packages}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT
93
94 cp -a installed/* $RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
This page took 0.08448 seconds and 3 git commands to generate.