]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- updated to 2.22.2
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # build docs
4 #
5 Summary:        Music typesetter
6 Summary(pl.UTF-8):      Program do składania nut
7 Name:           lilypond
8 # note: 2.22.x is stable, 2.23.x devel
9 Version:        2.22.2
10 Release:        1
11 License:        GPL v3+ with font exception
12 Group:          Applications/Sound
13 Source0:        https://lilypond.org/download/sources/v2.22/%{name}-%{version}.tar.gz
14 # Source0-md5:  677e68e728b24f66be5d20072294f41c
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-sh.patch
17 Patch2:         %{name}-aclocal.patch
18 Patch3:         %{name}-mf.patch
19 Patch4:         guile3.0.patch
20 URL:            https://lilypond.org/
21 BuildRequires:  autoconf >= 2.60
22 BuildRequires:  automake
23 BuildRequires:  bison >= 2.4.1
24 BuildRequires:  flex >= 2.5.4a
25 BuildRequires:  fontconfig >= 1:2.4.0
26 BuildRequires:  fontconfig-devel >= 1:2.4.0
27 BuildRequires:  fontforge >= 20110222
28 BuildRequires:  fonts-TTF-DejaVu
29 BuildRequires:  fonts-Type1-urw
30 BuildRequires:  freetype >= 1:2.1.10
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  ghostscript-fonts-std
33 BuildRequires:  glib2-devel >= 1:2.38
34 BuildRequires:  guile-devel >= 5:1.8.2
35 BuildRequires:  kpathsea-devel
36 BuildRequires:  libstdc++-devel >= 5:3.4
37 BuildRequires:  pango-devel >= 1:1.38.0
38 BuildRequires:  perl-base
39 BuildRequires:  pkgconfig >= 1:0.9.0
40 BuildRequires:  python3-devel >= 1:3.5
41 BuildRequires:  python3-modules >= 1:3.5
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  t1utils
44 BuildRequires:  texinfo >= 6.1
45 BuildRequires:  texlive-fonts-other
46 BuildRequires:  texlive-metapost
47 %if %{with doc}
48 BuildRequires:  ImageMagick
49 BuildRequires:  ImageMagick-coder-png
50 BuildRequires:  dblatex >= 0.1.4
51 BuildRequires:  ghostscript >= 9.20
52 BuildRequires:  netpbm-progs
53 BuildRequires:  rsync
54 BuildRequires:  texi2html >= 1.82
55 BuildRequires:  texinfo-texi2dvi >= 6.1
56 # `kpsewhich tex epsf`
57 BuildRequires:  texlive
58 # `kpsewhich -format=mf fikparm`
59 BuildRequires:  texlive-fonts-lh
60 BuildRequires:  texlive-latex-bibtex
61 BuildRequires:  texlive-xetex
62 BuildRequires:  zip
63 %endif
64 BuildConflicts: lilypond < 1.6.0
65 Requires:       fonts-TTF-DejaVu
66 Requires:       ghostscript >= 9.20
67 Requires:       glib2 >= 1:2.38
68 Requires:       pango >= 1:1.38.0
69 Requires:       python3-modules >= 1:3.5
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         texmfdir        %{_datadir}/texmf
73 %define         texmfdistdir    %{texmfdir}-dist
74 %if "%{pld_release}" != "th"
75 %define         texfontsdir     %{texmfdir}/fonts
76 %else
77 %define         texfontsdir     %{texmfdistdir}/fonts
78 %endif
79
80 %description
81 LilyPond is a music typesetter. It produces beautiful sheet music
82 using a high level description file as input. It excels at typesetting
83 classical music, but you can also print pop-songs. With LilyPond we
84 hope to make music publication software available to anyone on the
85 internet.
86
87 %description -l pl.UTF-8
88 LilyPond jest programem do składu muzycznego. Produkuje piękne
89 partytury używając języka wysokiego poziomu jako wejście. Służy przede
90 wszystkim do składania nut muzyki klasycznej, ale można drukować także
91 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
92 wszystkim oprogramowania do publikacji muzycznych.
93
94 %package -n emacs-lilypond-mode-pkg
95 Summary:        LilyPond mode for Emacs
96 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
97 Group:          Applications/Editors/Emacs
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       emacs
100
101 %description -n emacs-lilypond-mode-pkg
102 LilyPond mode for Emacs.
103
104 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
105 Tryb edycji plików LilyPond dla Emacsa.
106
107 %package -n vim-syntax-lilypond
108 Summary:        LilyPond files support for Vim
109 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
110 Group:          Applications/Editors/Vim
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       vim-rt >= 4:6.4.001-2
113
114 %description -n vim-syntax-lilypond
115 LilyPond files support for Vim.
116
117 %description -n vim-syntax-lilypond -l pl.UTF-8
118 Obsługa plików LilyPonda dla Vima.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125 %patch3 -p1
126 %patch4 -p1
127
128 %build
129 %{__autoconf}
130 %configure \
131         PYTHON=%{__python3} \
132         %{?debug:--disable-optimising} \
133         --with-texgyre-dir=%{texfontsdir}/opentype/public/tex-gyre/ \
134         %{__enable_disable doc documentation}
135 %{__make} -j1
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm/lilypond,type1/lilypond}}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 cp -p mf/out/*.tfm $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
145 cp -p mf/out/*.pfb $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
146
147 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
148
149 # ?
150 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
151         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
152 # for latex and dvips
153 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
154         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
155 # both for lilypond and dvips
156 ln -sf %{_datadir}/lilypond/%{version}/ps \
157         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
158
159 # vim syntax/etc. files
160 install -d $RPM_BUILD_ROOT%{_datadir}/vim
161 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
162         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
163
164 %find_lang %{name}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %pre
170 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
171
172 %post
173 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
174 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
175 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
176
177 %postun
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
179 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
180 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
181
182 %files -f %{name}.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS.txt DEDICATION LICENSE* NEWS.txt README.md ROADMAP
185 %attr(755,root,root) %{_bindir}/abc2ly
186 %attr(755,root,root) %{_bindir}/convert-ly
187 %attr(755,root,root) %{_bindir}/etf2ly
188 %attr(755,root,root) %{_bindir}/lilymidi
189 %attr(755,root,root) %{_bindir}/lilypond
190 %attr(755,root,root) %{_bindir}/lilypond-book
191 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
192 %attr(755,root,root) %{_bindir}/lilysong
193 %attr(755,root,root) %{_bindir}/midi2ly
194 %attr(755,root,root) %{_bindir}/musicxml2ly
195 %dir %{_datadir}/lilypond
196 %dir %{_datadir}/lilypond/%{version}
197 %{_datadir}/lilypond/%{version}/fonts
198 %{_datadir}/lilypond/%{version}/ly
199 %{_datadir}/lilypond/%{version}/ps
200 %{_datadir}/lilypond/%{version}/python
201 %{_datadir}/lilypond/%{version}/scm
202
203 %{texfontsdir}/source/lilypond
204 %{texfontsdir}/tfm/lilypond
205 %{texfontsdir}/type1/lilypond
206 %{texmfdir}/dvips/lilypond
207 %{texmfdir}/tex/lilypond
208
209 %if %{with doc}
210 %{_infodir}/lilypond-*.info*
211 %{_infodir}/music-glossary.info*
212 %{_mandir}/man1/abc2ly.1*
213 %{_mandir}/man1/convert-ly.1*
214 %{_mandir}/man1/etf2ly.1*
215 %{_mandir}/man1/lilymidi.1*
216 %{_mandir}/man1/lilypond.1*
217 %{_mandir}/man1/lilypond-book.1*
218 %{_mandir}/man1/lilypond-invoke-editor.1*
219 %{_mandir}/man1/lilysong.1*
220 %{_mandir}/man1/midi2ly.1*
221 %{_mandir}/man1/musicxml2ly.1*
222 %endif
223
224 %files -n emacs-lilypond-mode-pkg
225 %defattr(644,root,root,755)
226 %{_datadir}/emacs/site-lisp/lilypond-*.el
227
228 %files -n vim-syntax-lilypond
229 %defattr(644,root,root,755)
230 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
231 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
232 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
233 %{_datadir}/vim/vimfiles/indent/lilypond.vim
234 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.191274 seconds and 3 git commands to generate.