]> git.pld-linux.org Git - packages/libzen.git/blob - libzen.spec
up to 0.4.40
[packages/libzen.git] / libzen.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation (doxygen generated)
4 %bcond_without  static_libs     # static library
5
6 Summary:        ZenLib C++ utility library
7 Summary(pl.UTF-8):      ZenLib - biblioteka narzędziowa C++
8 Name:           libzen
9 Version:        0.4.40
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://mediaarea.net/download/source/libzen/%{version}/%{name}_%{version}.tar.xz
14 # Source0-md5:  44e52daaba43416f15b92dd01ba7aa39
15 Patch0:         %{name}-include.patch
16 URL:            https://github.com/MediaArea/ZenLib
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.11
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:1.5
22 BuildRequires:  rpmbuild(macros) >= 1.566
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ZenLib is a C++ utility library. It includes classes for handling
29 strings, configuration, bit streams, threading, translation, and
30 cross-platform operating system functions.
31
32 %description -l pl.UTF-8
33 ZenLib to biblioteka narzędziowa C++. Zawiera klasy do obsługi
34 łańcuchów znaków, konfiguracji, strumieni bitowych, wątków, tłumaczeń
35 oraz wieloplatformowe funkcji dotyczące systemu operacyjnego.
36
37 %package devel
38 Summary:        Header files for ZenLib library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ZenLib
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for ZenLib library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki ZenLib.
49
50 %package static
51 Summary:        Static ZenLib library
52 Summary(pl.UTF-8):      Statyczna biblioteka ZenLib
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static ZenLib library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka ZenLib.
61
62 %package apidocs
63 Summary:        API documentation for ZenLib library
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki ZenLib
65 Group:          Documentation
66
67 %description apidocs
68 API documentation for ZenLib library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki ZenLib.
72
73 %prep
74 %setup -q -n ZenLib
75 %undos Source/ZenLib/*.h
76 %undos *.txt Source/Doc/*.html
77 chmod 644 *.txt Source/Doc/*.html
78 %patch0 -p1
79
80 %build
81 cd Project/GNU/Library
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         %{?with_static_libs:--enable-static}
88 %{__make} clean
89 %{__make}
90
91 %if %{with apidocs}
92 cd ../../../Source/Doc
93 doxygen Doxyfile
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C Project/GNU/Library install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # obsoleted by pkg-config
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzen.la
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc History.txt License.txt README.md
114 %attr(755,root,root) %{_libdir}/libzen.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libzen.so.0
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libzen.so
120 %{_includedir}/ZenLib
121 %{_pkgconfigdir}/libzen.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libzen.a
127 %endif
128
129 %if %{with apidocs}
130 %files apidocs
131 %defattr(644,root,root,755)
132 # Documentation.html expects Doc/index.html
133 %doc Source/Doc/Documentation.html Doc
134 %endif
This page took 0.142382 seconds and 4 git commands to generate.