]> git.pld-linux.org Git - packages/libvpx.git/commitdiff
- build on x86
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 May 2010 14:05:54 +0000 (14:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libvpx-0.9.0-no-explicit-dep-on-static-lib.patch -> 1.1
    libvpx.spec -> 1.3

libvpx-0.9.0-no-explicit-dep-on-static-lib.patch [new file with mode: 0644]
libvpx.spec

diff --git a/libvpx-0.9.0-no-explicit-dep-on-static-lib.patch b/libvpx-0.9.0-no-explicit-dep-on-static-lib.patch
new file mode 100644 (file)
index 0000000..d909d7e
--- /dev/null
@@ -0,0 +1,11 @@
+diff -up libvpx-0.9.0/examples.mk.BAD libvpx-0.9.0/examples.mk
+--- libvpx-0.9.0/examples.mk.BAD       2010-05-19 17:58:42.611058552 -0400
++++ libvpx-0.9.0/examples.mk   2010-05-19 17:59:11.934181029 -0400
+@@ -129,7 +129,6 @@ BINS-$(NOT_MSVS)           += $(addprefi
+ # Instantiate linker template for all examples.
+ CODEC_LIB=$(if $(CONFIG_DEBUG_LIBS),vpx_g,vpx)
+ $(foreach bin,$(BINS-yes),\
+-    $(if $(BUILD_OBJS),$(eval $(bin): $(LIB_PATH)/lib$(CODEC_LIB).a))\
+     $(if $(BUILD_OBJS),$(eval $(call linker_template,$(bin),\
+         $(call objs,$($(notdir $(bin)).SRCS)) \
+         -l$(CODEC_LIB) $(addprefix -l,$(CODEC_EXTRA_LIBS))\
index 05a4bb163005c5cc02f456cd8a49b488af245a61..840cec6783b2462300e642829f7517977f1819c8 100644 (file)
@@ -6,12 +6,11 @@ License:      BSD
 Group:         Libraries
 Source0:       http://webm.googlecode.com/files/%{name}-%{version}.tar.bz2
 # Source0-md5: 9eb8e818d2f3263623c258fe66924082
+Patch0:                %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
 URL:           http://www.webmproject.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: doxygen
-BuildRequires: php-pcre
-BuildRequires: php-program
 BuildRequires: yasm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -36,6 +35,7 @@ Static libvpx library.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d build
@@ -48,16 +48,61 @@ cd build
 %ifarch %{ix86}
        --target=x86-linux-gcc \
 %endif
-       --enable-install-docs \
+       --enable-pic \
+       --disable-optimizations \
        --enable-vp8 \
        --enable-postproc \
        --enable-runtime-cpu-detect
-%{__make}
+
+# Hack our optflags in.
+sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" libs-*.mk
+sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" examples-*.mk
+sed -i "s|\"vpx_config.h\"|\"vpx_config.h\" %{rpmcflags} %{rpmcppflags} -fPIC|g" docs-*.mk
+
+%{__make} verbose=true target=libs \
+       CC="%{__cc}"
+
+%{__cc} %{rpmldflags} -fPIC -o libvpx.so.0.0.0 -shared -Wl,-soname,libvpx.so.0 vpx_codec/src/*.o vpx_mem/*.o \
+       vpx_scale/generic/*.o vp8/common/*.o vp8/common/generic/*.o vp8/*.o vp8/encoder/*.o \
+       vp8/encoder/generic/*.o vp8/decoder/*.o vp8/decoder/generic/*.o vpx_config.c.o \
+       vp8/common/x*/*.o vp8/encoder/x*/*.o vp8/decoder/x*/*.o vpx_ports/*.o -lm -lpthread
+
+# Temporarily dance the static libs out of the way
+mv libvpx.a libNOTvpx.a
+mv libvpx_g.a libNOTvpx_g.a
+
+# We need to do this so the examples can link against it.
+ln -sf libvpx.so.0.0.0 libvpx.so
+
+%{__make} verbose=true target=examples \
+       CC="%{__cc}"
+%{__make} verbose=true target=docs
+
+# Put them back so the install doesn't fail
+mv libNOTvpx.a libvpx.a
+mv libNOTvpx_g.a libvpx_g.a
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} -C build install
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
+
+install -d outdir
+%{__make} -C build install \
+       DIST_DIR=$(pwd)/outdir
+
+mv outdir/bin/{simple_decoder,vp8_simple_decoder}
+mv outdir/bin/{twopass_encoder,vp8_twopass_encoder}
+install -m755 outdir/bin/* $RPM_BUILD_ROOT%{_bindir}
+
+ln -s libvpx.so.0.0.0 build/libvpx.so.0.0
+ln -s libvpx.so.0.0.0 build/libvpx.so.0
+install -m755 -p build/libvpx.so* $RPM_BUILD_ROOT%{_libdir}
+ldconfig -X -n $RPM_BUILD_ROOT%{_libdir}
+
+install outdir/include/*.h $RPM_BUILD_ROOT%{_includedir}
+
+install outdir/lib/*.a $RPM_BUILD_ROOT%{_libdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -67,20 +112,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/vainfo
-%attr(755,root,root) %{_libdir}/libvpx*.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvpx*.so.1
-%dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/dri
-%attr(755,root,root) %{_libdir}/%{name}/dri/*.so
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/libvpx.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvpx*.so
-%{_includedir}/va
-%{_libdir}/libvpx*.la
-%{_pkgconfigdir}/*.pc
+%{_includedir}/*.h
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libvpx*.a
+%{_libdir}/libvpx.a
This page took 0.097129 seconds and 4 git commands to generate.