]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- simplified Source0 URL
[packages/libvpx.git] / libvpx.spec
index 3b90984d4df29d319df790ca3c0c381ee4481b76..cb89debca4bf669c8f295482f1398b50de07c26e 100644 (file)
@@ -4,9 +4,8 @@
 %bcond_without doc     # don't build doc
 %bcond_with    tests   # build tests (not useful, creates libgtest.a)
 %bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
-%bcond_without vp9_encoder     # vp9 encoder
 
-%ifnarch %{ix86} %{x8664}
+%ifnarch %{ix86} %{x8664} x32
 %undefine      with_asm
 %endif
 
 %undefine      with_ssse3
 %endif
 
-# old gcc gets stuck on ac
-%ifarch sparc
-%undefine      with_vp9_encoder
-%endif
-
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakości
 Name:          libvpx
-Version:       1.3.0
-Release:       2
+Version:       1.8.0
+Release:       1
 License:       BSD
 Group:         Libraries
-#Source0Download: http://code.google.com/p/webm/downloads/list
-#Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-# source, but regenerated on each fetch
-#Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
+# original download URL: http://downloads.webmproject.org/releases/webm/index.html
+# ...but use github mirror to get consistent tarballs
+#Source0Download: https://github.com/webmproject/libvpx/releases
+Source0:       https://github.com/webmproject/libvpx/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 49cb591325f44a3459b040112e3b82e7
 URL:           http://www.webmproject.org/
 BuildRequires: doxygen
 %{?with_tests:BuildRequires:   libstdc++-devel}
@@ -91,15 +84,28 @@ Static libvpx library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libvpx.
 
+%package tools
+Summary:       VPX decoding/encoding tools
+Summary(pl.UTF-8):     Narzędzia do kodowania/dekodowania formatu VPX
+Group:         Applications/Graphics
+Requires:      %{name} = %{version}-%{release}
+
+%description tools
+VPX decoding/encoding tools.
+
+%description tools -l pl.UTF-8
+Narzędzia do kodowania/dekodowania formatu VPX.
+
 %prep
-#%setup -q -n %{name}-v%{version}
-%setup -qc
+%setup -q
 
 %build
 install -d obj
 cd obj
 # not autoconf configure
-CFLAGS="%{rpmcflags} %{rpmcppflags}" \
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
 ../configure \
 %if %{with asm}
        --as=yasm \
@@ -112,19 +118,15 @@ CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        --%{!?with_doc:dis}%{?with_doc:en}able-docs \
        --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
        --enable-vp8 \
-       %{!?with_vp9_encoder:--disable-vp9-encoder} \
+       --enable-vp8 \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
 %{__make} verbose=true target=libs \
        HAVE_GNU_STRIP=no \
-       CC="%{__cc}" \
-       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags}"
 
 %{__make} verbose=true target=examples \
-       CC="%{__cc}" \
-       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags} -L."
 
 %if %{with doc}
@@ -139,7 +141,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
        LIBSUBDIR=%{_lib} \
        DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.6.0
 
 # adjust prefix and libdir
 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
@@ -153,12 +155,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
-%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
-%{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
-%attr(755,root,root) %{_bindir}/vpxdec
-%attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
+%attr(755,root,root) %ghost %{_libdir}/libvpx.so.6
 
 %files devel
 %defattr(644,root,root,755)
@@ -169,3 +167,8 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libvpx.a
+
+%files tools
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/vpxdec
+%attr(755,root,root) %{_bindir}/vpxenc
This page took 0.073837 seconds and 4 git commands to generate.