]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
- x32 rebuild
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4 %bcond_without  doc     # don't build doc
5 %bcond_with     tests   # build tests (not useful, creates libgtest.a)
6 %bcond_without  ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
7 %bcond_without  vp9_encoder     # vp9 encoder
8
9 %ifnarch %{ix86} %{x8664}
10 %undefine       with_asm
11 %endif
12
13 %if "%{pld_release}" == "ac"
14 # not supported by compiler
15 %undefine       with_ssse3
16 %endif
17
18 # old gcc gets stuck on ac
19 %ifarch sparc
20 %undefine       with_vp9_encoder
21 %endif
22
23 Summary:        VP8, a high-quality video codec
24 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
25 Name:           libvpx
26 Version:        1.3.0
27 Release:        3
28 License:        BSD
29 Group:          Libraries
30 #Source0Download: http://code.google.com/p/webm/downloads/list
31 #Source0:       https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
32 # source, but regenerated on each fetch
33 #Source0:       https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
34 Source0:        %{name}-%{version}.tar.gz
35 # Source0-md5:  dcf436a5dc8b56bdfb4aec63b2fe6729
36 URL:            http://www.webmproject.org/
37 BuildRequires:  doxygen
38 %{?with_tests:BuildRequires:    libstdc++-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.673
41 BuildRequires:  sed >= 4.0
42 %{?with_asm:BuildRequires:      yasm >= 0.8}
43 %if %{with doc}
44 BuildRequires:  %{php_name}-pcre
45 BuildRequires:  %{php_name}-program
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define generic_target  generic-gnu
50 %define vpxtarget       %{generic_target}
51 %ifarch %{x8664}
52 %define vpxtarget       x86_64-linux-gcc
53 %endif
54 %ifarch %{ix86}
55 %define vpxtarget       x86-linux-gcc
56 %endif
57 %ifarch ppc
58 %define vpxtarget       ppc32-linux-gcc
59 %endif
60 %ifarch ppc64
61 %define vpxtarget       ppc64-linux-gcc
62 %endif
63
64 %description
65 VP8, a high-quality video codec.
66
67 %description -l pl.UTF-8
68 VP8 - kodek obrazu wysokiej jakości.
69
70 %package devel
71 Summary:        Header files for libvpx
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description devel
77 Header files for libvpx library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki libvpx.
81
82 %package static
83 Summary:        Static libvpx library
84 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static libvpx library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka libvpx.
93
94 %prep
95 #%setup -q -n %{name}-v%{version}
96 %setup -qc
97
98 %build
99 install -d obj
100 cd obj
101 # not autoconf configure
102 CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
103 ../configure \
104 %if %{with asm}
105         --as=yasm \
106 %endif
107         --target=%{vpxtarget} \
108         --enable-shared \
109         %{!?with_ssse3:--disable-ssse3} \
110         --disable-optimizations \
111         --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
112         --%{!?with_doc:dis}%{?with_doc:en}able-docs \
113         --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
114         --enable-vp8 \
115         %{!?with_vp9_encoder:--disable-vp9-encoder} \
116         --enable-postproc \
117         --enable-runtime-cpu-detect
118
119 %{__make} verbose=true target=libs \
120         HAVE_GNU_STRIP=no \
121         CC="%{__cc}" \
122         LD="%{__cc}" \
123         LDFLAGS="%{rpmldflags}"
124
125 %{__make} verbose=true target=examples \
126         CC="%{__cc}" \
127         LD="%{__cc}" \
128         LDFLAGS="%{rpmldflags} -L."
129
130 %if %{with doc}
131 %{__make} verbose=true target=docs
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
137
138 %{__make} -C obj verbose=true install \
139         LIBSUBDIR=%{_lib} \
140         DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
143
144 # adjust prefix and libdir
145 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS CHANGELOG LICENSE PATENTS README
156 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
157 %{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
158 %attr(755,root,root) %{_bindir}/vpxdec
159 %attr(755,root,root) %{_bindir}/vpxenc
160 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libvpx.so
166 %{_includedir}/vpx
167 %{_pkgconfigdir}/vpx.pc
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libvpx.a
This page took 0.055512 seconds and 4 git commands to generate.