]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
- updated to 1.7.0 (note: new soname)
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4 %bcond_without  doc     # don't build doc
5 %bcond_with     tests   # build tests (not useful, creates libgtest.a)
6 %bcond_without  ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
7
8 %ifnarch %{ix86} %{x8664} x32
9 %undefine       with_asm
10 %endif
11
12 %if "%{pld_release}" == "ac"
13 # not supported by compiler
14 %undefine       with_ssse3
15 %endif
16
17 Summary:        VP8, a high-quality video codec
18 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
19 Name:           libvpx
20 Version:        1.7.0
21 Release:        1
22 License:        BSD
23 Group:          Libraries
24 #Source0Download: http://downloads.webmproject.org/releases/webm/index.html
25 Source0:        https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?fakename=/%{name}-%{version}.tar.gz
26 # Source0-md5:  df97945958d8514ba9fc6ca5ca39ae6a
27 URL:            http://www.webmproject.org/
28 BuildRequires:  doxygen
29 %{?with_tests:BuildRequires:    libstdc++-devel}
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.673
32 BuildRequires:  sed >= 4.0
33 %{?with_asm:BuildRequires:      yasm >= 0.8}
34 %if %{with doc}
35 BuildRequires:  %{php_name}-pcre
36 BuildRequires:  %{php_name}-program
37 %endif
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define generic_target  generic-gnu
41 %define vpxtarget       %{generic_target}
42 %ifarch %{x8664}
43 %define vpxtarget       x86_64-linux-gcc
44 %endif
45 %ifarch %{ix86}
46 %define vpxtarget       x86-linux-gcc
47 %endif
48 %ifarch ppc
49 %define vpxtarget       ppc32-linux-gcc
50 %endif
51 %ifarch ppc64
52 %define vpxtarget       ppc64-linux-gcc
53 %endif
54
55 %description
56 VP8, a high-quality video codec.
57
58 %description -l pl.UTF-8
59 VP8 - kodek obrazu wysokiej jakości.
60
61 %package devel
62 Summary:        Header files for libvpx
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description devel
68 Header files for libvpx library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki libvpx.
72
73 %package static
74 Summary:        Static libvpx library
75 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libvpx library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libvpx.
84
85 %package tools
86 Summary:        VPX decoding/encoding tools
87 Summary(pl.UTF-8):      Narzędzia do kodowania/dekodowania formatu VPX
88 Group:          Applications/Graphics
89 Requires:       %{name} = %{version}-%{release}
90
91 %description tools
92 VPX decoding/encoding tools.
93
94 %description tools -l pl.UTF-8
95 Narzędzia do kodowania/dekodowania formatu VPX.
96
97 %prep
98 %setup -q -c
99
100 %build
101 install -d obj
102 cd obj
103 # not autoconf configure
104 CC="%{__cc}" \
105 CXX="%{__cxx}" \
106 CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
107 ../configure \
108 %if %{with asm}
109         --as=yasm \
110 %endif
111         --target=%{vpxtarget} \
112         --enable-shared \
113         %{!?with_ssse3:--disable-ssse3} \
114         --disable-optimizations \
115         --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
116         --%{!?with_doc:dis}%{?with_doc:en}able-docs \
117         --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
118         --enable-vp8 \
119         --enable-vp8 \
120         --enable-postproc \
121         --enable-runtime-cpu-detect
122
123 %{__make} verbose=true target=libs \
124         HAVE_GNU_STRIP=no \
125         LDFLAGS="%{rpmldflags}"
126
127 %{__make} verbose=true target=examples \
128         LDFLAGS="%{rpmldflags} -L."
129
130 %if %{with doc}
131 %{__make} verbose=true target=docs
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
137
138 %{__make} -C obj verbose=true install \
139         LIBSUBDIR=%{_lib} \
140         DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.5.0
143
144 # adjust prefix and libdir
145 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS CHANGELOG LICENSE PATENTS README
156 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.5
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libvpx.so
162 %{_includedir}/vpx
163 %{_pkgconfigdir}/vpx.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libvpx.a
168
169 %files tools
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/vpxdec
172 %attr(755,root,root) %{_bindir}/vpxenc
This page took 0.081357 seconds and 3 git commands to generate.