]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- updated to 1.6.0 (note: new soname)
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
a7d444e9 4%bcond_without doc # don't build doc
ecadc52c 5%bcond_with tests # build tests (not useful, creates libgtest.a)
5f38e725
ER
6%bcond_without ssse3 # use SSSE3 instructions (Intel since Core2, Via Nano)
7
30fcd8a5 8%ifnarch %{ix86} %{x8664} x32
f2369026
ER
9%undefine with_asm
10%endif
11
5f38e725
ER
12%if "%{pld_release}" == "ac"
13# not supported by compiler
14%undefine with_ssse3
15%endif
3c828a1d 16
bccc9f86 17Summary: VP8, a high-quality video codec
d5d82930 18Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 19Name: libvpx
a608fd09 20Version: 1.6.0
05641fc7 21Release: 1
bccc9f86
AM
22License: BSD
23Group: Libraries
627f7539 24#Source0Download: http://downloads.webmproject.org/releases/webm/index.html
05641fc7 25Source0: https://storage.googleapis.com/downloads.webmproject.org/releases/webm/%{name}-%{version}.tar.bz2
a608fd09 26# Source0-md5: f95a176768a0e1bb4fe42742e27a41af
bccc9f86 27URL: http://www.webmproject.org/
a28e5963 28BuildRequires: doxygen
71ced3dc 29%{?with_tests:BuildRequires: libstdc++-devel}
efdc9f5e 30BuildRequires: pkgconfig
a7d444e9 31BuildRequires: rpmbuild(macros) >= 1.673
9026bd8c 32BuildRequires: sed >= 4.0
3c828a1d 33%{?with_asm:BuildRequires: yasm >= 0.8}
a7d444e9
ER
34%if %{with doc}
35BuildRequires: %{php_name}-pcre
36BuildRequires: %{php_name}-program
37%endif
bccc9f86
AM
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
e1331b3a
ER
40%define generic_target generic-gnu
41%define vpxtarget %{generic_target}
42%ifarch %{x8664}
43%define vpxtarget x86_64-linux-gcc
44%endif
45%ifarch %{ix86}
46%define vpxtarget x86-linux-gcc
47%endif
48%ifarch ppc
49%define vpxtarget ppc32-linux-gcc
50%endif
51%ifarch ppc64
52%define vpxtarget ppc64-linux-gcc
53%endif
54
bccc9f86
AM
55%description
56VP8, a high-quality video codec.
57
d5d82930
JB
58%description -l pl.UTF-8
59VP8 - kodek obrazu wysokiej jakości.
60
bccc9f86 61%package devel
d5d82930
JB
62Summary: Header files for libvpx
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 64Group: Development/Libraries
d5d82930 65Requires: %{name} = %{version}-%{release}
bccc9f86
AM
66
67%description devel
d5d82930
JB
68Header files for libvpx library.
69
70%description devel -l pl.UTF-8
71Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
72
73%package static
74Summary: Static libvpx library
d5d82930 75Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 76Group: Development/Libraries
d5d82930 77Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
78
79%description static
80Static libvpx library.
81
d5d82930
JB
82%description static -l pl.UTF-8
83Statyczna biblioteka libvpx.
84
bccc9f86 85%prep
aa7aed28 86%setup -q
bccc9f86
AM
87
88%build
d5d82930
JB
89install -d obj
90cd obj
bccc9f86 91# not autoconf configure
2f02a711
JB
92CC="%{__cc}" \
93CXX="%{__cxx}" \
16ab9c5e 94CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
bccc9f86 95../configure \
7b991969 96%if %{with asm}
dcde509e 97 --as=yasm \
61956466 98%endif
e1331b3a 99 --target=%{vpxtarget} \
6c7c0f8b 100 --enable-shared \
5f38e725 101 %{!?with_ssse3:--disable-ssse3} \
0257ab6e 102 --disable-optimizations \
2f397753 103 --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
f0a288d6
ER
104 --%{!?with_doc:dis}%{?with_doc:en}able-docs \
105 --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
bccc9f86 106 --enable-vp8 \
2f02a711 107 --enable-vp8 \
bccc9f86
AM
108 --enable-postproc \
109 --enable-runtime-cpu-detect
0257ab6e 110
0257ab6e 111%{__make} verbose=true target=libs \
938aec6f 112 HAVE_GNU_STRIP=no \
6c7c0f8b 113 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
114
115%{__make} verbose=true target=examples \
dcde509e 116 LDFLAGS="%{rpmldflags} -L."
a7d444e9
ER
117
118%if %{with doc}
0257ab6e 119%{__make} verbose=true target=docs
a7d444e9 120%endif
0257ab6e 121
bccc9f86
AM
122%install
123rm -rf $RPM_BUILD_ROOT
464fefd2 124install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 125
6c7c0f8b 126%{__make} -C obj verbose=true install \
938aec6f
ER
127 LIBSUBDIR=%{_lib} \
128 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 129
a608fd09 130%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.4.0
9026bd8c
JB
131
132# adjust prefix and libdir
3c828a1d 133%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
2f397753 138%post -p /sbin/ldconfig
bccc9f86
AM
139%postun -p /sbin/ldconfig
140
141%files
142%defattr(644,root,root,755)
d5d82930
JB
143%doc AUTHORS CHANGELOG LICENSE PATENTS README
144%attr(755,root,root) %{_bindir}/vpxdec
145%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 146%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
a608fd09 147%attr(755,root,root) %ghost %{_libdir}/libvpx.so.4
bccc9f86
AM
148
149%files devel
150%defattr(644,root,root,755)
47f853c3 151%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 152%{_includedir}/vpx
9026bd8c 153%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
154
155%files static
156%defattr(644,root,root,755)
0257ab6e 157%{_libdir}/libvpx.a
This page took 0.183868 seconds and 4 git commands to generate.