]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- updated to 1.10.0
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
a7d444e9 4%bcond_without doc # don't build doc
ecadc52c 5%bcond_with tests # build tests (not useful, creates libgtest.a)
5f38e725
ER
6%bcond_without ssse3 # use SSSE3 instructions (Intel since Core2, Via Nano)
7
30fcd8a5 8%ifnarch %{ix86} %{x8664} x32
f2369026
ER
9%undefine with_asm
10%endif
11
5f38e725
ER
12%if "%{pld_release}" == "ac"
13# not supported by compiler
14%undefine with_ssse3
15%endif
3c828a1d 16
bccc9f86 17Summary: VP8, a high-quality video codec
d5d82930 18Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 19Name: libvpx
a0961f7e 20Version: 1.10.0
05641fc7 21Release: 1
bccc9f86
AM
22License: BSD
23Group: Libraries
5d57f493
JB
24# original download URL: http://downloads.webmproject.org/releases/webm/index.html
25# ...but use github mirror to get consistent tarballs
26#Source0Download: https://github.com/webmproject/libvpx/releases
27Source0: https://github.com/webmproject/libvpx/archive/v%{version}/%{name}-%{version}.tar.gz
a0961f7e
JB
28# Source0-md5: cded283be38dc0078c3fbe751722efc5
29URL: https://www.webmproject.org/
a28e5963 30BuildRequires: doxygen
71ced3dc 31%{?with_tests:BuildRequires: libstdc++-devel}
efdc9f5e 32BuildRequires: pkgconfig
a7d444e9 33BuildRequires: rpmbuild(macros) >= 1.673
9026bd8c 34BuildRequires: sed >= 4.0
3c828a1d 35%{?with_asm:BuildRequires: yasm >= 0.8}
a7d444e9
ER
36%if %{with doc}
37BuildRequires: %{php_name}-pcre
38BuildRequires: %{php_name}-program
39%endif
bccc9f86
AM
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
e1331b3a
ER
42%define generic_target generic-gnu
43%define vpxtarget %{generic_target}
44%ifarch %{x8664}
45%define vpxtarget x86_64-linux-gcc
46%endif
47%ifarch %{ix86}
48%define vpxtarget x86-linux-gcc
49%endif
50%ifarch ppc
51%define vpxtarget ppc32-linux-gcc
52%endif
53%ifarch ppc64
54%define vpxtarget ppc64-linux-gcc
55%endif
5ae03088
JP
56%ifarch aarch64
57%define vpxtarget arm64-linux-gcc
58%endif
e1331b3a 59
bccc9f86
AM
60%description
61VP8, a high-quality video codec.
62
d5d82930
JB
63%description -l pl.UTF-8
64VP8 - kodek obrazu wysokiej jakości.
65
bccc9f86 66%package devel
d5d82930
JB
67Summary: Header files for libvpx
68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 69Group: Development/Libraries
d5d82930 70Requires: %{name} = %{version}-%{release}
bccc9f86
AM
71
72%description devel
d5d82930
JB
73Header files for libvpx library.
74
75%description devel -l pl.UTF-8
76Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
77
78%package static
79Summary: Static libvpx library
d5d82930 80Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 81Group: Development/Libraries
d5d82930 82Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
83
84%description static
85Static libvpx library.
86
d5d82930
JB
87%description static -l pl.UTF-8
88Statyczna biblioteka libvpx.
89
59ff1590
JB
90%package tools
91Summary: VPX decoding/encoding tools
92Summary(pl.UTF-8): Narzędzia do kodowania/dekodowania formatu VPX
93Group: Applications/Graphics
94Requires: %{name} = %{version}-%{release}
95
96%description tools
97VPX decoding/encoding tools.
98
99%description tools -l pl.UTF-8
100Narzędzia do kodowania/dekodowania formatu VPX.
101
bccc9f86 102%prep
5df4ed4b 103%setup -q
bccc9f86
AM
104
105%build
d5d82930
JB
106install -d obj
107cd obj
bccc9f86 108# not autoconf configure
2f02a711
JB
109CC="%{__cc}" \
110CXX="%{__cxx}" \
28316222 111CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 112../configure \
7b991969 113%if %{with asm}
dcde509e 114 --as=yasm \
61956466 115%endif
e1331b3a 116 --target=%{vpxtarget} \
6c7c0f8b 117 --enable-shared \
5f38e725 118 %{!?with_ssse3:--disable-ssse3} \
0257ab6e 119 --disable-optimizations \
2f397753 120 --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
f0a288d6
ER
121 --%{!?with_doc:dis}%{?with_doc:en}able-docs \
122 --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
bccc9f86 123 --enable-vp8 \
2f02a711 124 --enable-vp8 \
bccc9f86
AM
125 --enable-postproc \
126 --enable-runtime-cpu-detect
0257ab6e 127
0257ab6e 128%{__make} verbose=true target=libs \
938aec6f 129 HAVE_GNU_STRIP=no \
6c7c0f8b 130 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
131
132%{__make} verbose=true target=examples \
dcde509e 133 LDFLAGS="%{rpmldflags} -L."
a7d444e9
ER
134
135%if %{with doc}
0257ab6e 136%{__make} verbose=true target=docs
a7d444e9 137%endif
0257ab6e 138
bccc9f86
AM
139%install
140rm -rf $RPM_BUILD_ROOT
464fefd2 141install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 142
6c7c0f8b 143%{__make} -C obj verbose=true install \
938aec6f
ER
144 LIBSUBDIR=%{_lib} \
145 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 146
61c9fbe7 147# redundant minor version symlink (not SONAME)
a0961f7e 148%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.6.4
9026bd8c
JB
149
150# adjust prefix and libdir
3c828a1d 151%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
2f397753 156%post -p /sbin/ldconfig
bccc9f86
AM
157%postun -p /sbin/ldconfig
158
159%files
160%defattr(644,root,root,755)
d5d82930 161%doc AUTHORS CHANGELOG LICENSE PATENTS README
47f853c3 162%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
8895f186 163%attr(755,root,root) %ghost %{_libdir}/libvpx.so.6
bccc9f86
AM
164
165%files devel
166%defattr(644,root,root,755)
47f853c3 167%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 168%{_includedir}/vpx
9026bd8c 169%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
170
171%files static
172%defattr(644,root,root,755)
0257ab6e 173%{_libdir}/libvpx.a
59ff1590
JB
174
175%files tools
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_bindir}/vpxdec
178%attr(755,root,root) %{_bindir}/vpxenc
This page took 0.085712 seconds and 4 git commands to generate.