]> git.pld-linux.org Git - packages/libraw.git/blob - libraw.spec
- up to 0.21.2
[packages/libraw.git] / libraw.spec
1 #
2 # Conditional build:
3 %bcond_without  openmp  # OpenMP support
4 %bcond_without  zlib    # ZLIB for deflated DNG format support
5 #
6 Summary:        LibRaw - a library for reading RAW files
7 Summary(pl.UTF-8):      LibRaw - biblioteka do odczytu plików RAW
8 Name:           libraw
9 Version:        0.21.1
10 Release:        1
11 License:        LGPL v2.1 or CDDL v1.0
12 Group:          Libraries
13 #Source0Download: http://www.libraw.org/download#stable
14 Source0:        https://www.libraw.org/data/LibRaw-%{version}.tar.gz
15 # Source0-md5:  2942732de752f46baccd9c6d57823b7b
16 Patch0:         int64.patch
17 URL:            https://www.libraw.org/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 %{?with_openmp:BuildRequires:   gcc >= 6:4.2}
21 BuildRequires:  jasper-devel
22 BuildRequires:  lcms2-devel >= 2
23 %{?with_openmp:BuildRequires:   libgomp-devel}
24 BuildRequires:  libjpeg-devel >= 8
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 # zlib with pkgconfig support
29 %{?with_zlib:BuildRequires:     zlib-devel >= 1.2.3.3}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 LibRaw is a library for reading RAW files obtained from digital photo
34 cameras (CRW/CR2, NEF, RAF, DNG, and others).
35
36 LibRaw is based on the source codes of the dcraw utility, where part
37 of drawbacks have already been eliminated and part will be fixed in
38 future. The users of the library are provided with API to be built
39 into their software programs.
40
41 %description -l pl.UTF-8
42 LibRaw to biblioteka do odczytu plików RAW uzyskanych z cyfrowych
43 aparatów fotograficznych (w formacie CRW/CR2, NEF, RAF, DNG i innych).
44
45 LibRaw jest oparty na kodzie źródłowym dcraw, z którego część wad
46 została już wyeliminowana, a część zostanie poprawiona w przyszłości.
47
48 %package samples
49 Summary:        LibRaw sample programs
50 Summary(pl.UTF-8):      Programy przykładowe do LibRaw
51 Group:          Applications/Graphics
52
53 %description samples
54 LibRaw sample programs.
55
56 %description samples -l pl.UTF-8
57 Programy przykładowe do LibRaw.
58
59 %package devel
60 Summary:        Header files for LibRaw
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibRaw
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       jasper-devel
65 Requires:       lcms2-devel >= 2
66 %{?with_openmp:Requires: libgomp-devel}
67 Requires:       libjpeg-devel >= 8
68 Requires:       libstdc++-devel
69 %{?with_zlib:Requires:  zlib-devel >= 1.2.3.3}
70
71 %description devel
72 Header files for LibRaw.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki LibRaw.
76
77 %package static
78 Summary:        Static LibRaw library
79 Summary(pl.UTF-8):      Statyczna biblioteka LibRaw
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static LibRaw library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka LibRaw.
88
89 %prep
90 %setup -q -n LibRaw-%{version}
91 %patch0 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         %{!?with_openmp:--disable-openmp} \
100         %{?with_zlib:--enable-zlib}
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # obsoleted by pkg-config
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraw*.la
112
113 # packaged as %doc
114 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc COPYRIGHT Changelog.txt README.md LICENSE.CDDL LICENSE.LGPL
125 %attr(755,root,root) %{_libdir}/libraw.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libraw.so.23
127 %attr(755,root,root) %{_libdir}/libraw_r.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libraw_r.so.23
129
130 %files samples
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/4channels
133 %attr(755,root,root) %{_bindir}/dcraw_emu
134 %attr(755,root,root) %{_bindir}/dcraw_half
135 %attr(755,root,root) %{_bindir}/half_mt
136 %attr(755,root,root) %{_bindir}/mem_image
137 %attr(755,root,root) %{_bindir}/multirender_test
138 %attr(755,root,root) %{_bindir}/postprocessing_benchmark
139 %attr(755,root,root) %{_bindir}/raw-identify
140 %attr(755,root,root) %{_bindir}/rawtextdump
141 %attr(755,root,root) %{_bindir}/simple_dcraw
142 %attr(755,root,root) %{_bindir}/unprocessed_raw
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc doc/*.html
147 %attr(755,root,root) %{_libdir}/libraw.so
148 %attr(755,root,root) %{_libdir}/libraw_r.so
149 %{_includedir}/libraw
150 %{_pkgconfigdir}/libraw.pc
151 %{_pkgconfigdir}/libraw_r.pc
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libraw.a
156 %{_libdir}/libraw_r.a
This page took 0.096392 seconds and 3 git commands to generate.