]> git.pld-linux.org Git - packages/libmp3splt.git/blob - libmp3splt.spec
flac rebuild
[packages/libmp3splt.git] / libmp3splt.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Libraries for the mp3splt project
7 Summary(pl.UTF-8):      Biblioteki do projektu mp3splt
8 Name:           libmp3splt
9 Version:        0.9.1
10 Release:        2
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/mp3splt/%{name}-%{version}.tar.gz
14 # Source0-md5:  742f9fb4806df909c0ba25919bf9bb4f
15 Patch0:         ltdl.patch
16 URL:            http://mp3splt.sourceforge.net/
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake
19 BuildRequires:  flac-devel >= 1.2.1
20 BuildRequires:  gettext-tools >= 0.18.3
21 BuildRequires:  libid3tag-devel
22 BuildRequires:  libltdl-devel
23 BuildRequires:  libmad-devel
24 BuildRequires:  libtool
25 BuildRequires:  libvorbis-devel
26 BuildRequires:  pcre-devel >= 1.0
27 BuildRequires:  pkgconfig
28 %if %{with apidocs}
29 BuildRequires:  doxygen
30 BuildRequires:  graphviz
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The mp3Splt project provides utilities to split mp3 and ogg files, by
36 selecting a begin and an end time position, without decoding. It is
37 very useful to split large mp3/ogg into smaller files, or to split
38 entire albums to obtain original tracks. To split an album, the split
39 points and filenames can be selected manually or automatically from
40 CDDB (internet or a local file), or from .cue files.
41
42 It supports automatic silence detection, which can be used to adjust
43 cddb/cue split points. It is also possible to extract tracks from
44 Mp3Wrap or AlbumWrap files in a few seconds.
45
46 %description -l pl.UTF-8
47 Projekt mp3Splt dostarcza narzędzi umożliwiających dzielenie plików w
48 formacie mp3 i ogg poprzez zaznaczenie pozycji początku i końca
49 dzielenia, bez potrzeby dekodowania. Dzielenie dużych plików mp3/ogg
50 na mniejsze części jest bardzo użyteczne, można w ten sposób dzielić
51 całe albumy by otrzymać oryginalne ścieżki. Żeby podzielić album
52 punkty podziału i nazwy plików mogą zostać wybrane ręcznie lub
53 automatycznie z wykorzystaniem CDDB (z Internetu lub lokalnie), albo z
54 plików .cue.
55
56 Projekt wspiera automatyczne wykrywanie ciszy, które może zostać
57 wykorzystane do ustawienia punktów podziału cddb/cue. Jest również
58 możliwe wyciągnięcie ścieżek z plików Mp3Wrap lub AlbumWrap w ciągu
59 kilku sekund.
60
61 %package devel
62 Summary:        Header files for libmp3splt library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmp3splt
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description devel
68 Header files for libmp3splt library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki libmp3splt.
72
73 %package static
74 Summary:        Static libmp3splt library
75 Summary(pl.UTF-8):      Statyczna biblioteka libmp3splt
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libmp3splt library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libmp3splt.
84
85 %package apidocs
86 Summary:        libmp3splt API documentation
87 Summary(pl.UTF-8):      Dokumentacja API biblioteki libmp3splt
88 Group:          Documentation
89 BuildArch:      noarch
90
91 %description apidocs
92 API and internal documentation for libmp3splt library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki libmp3splt.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 sed -i -e 's/fr_FR/fr/;s/de_DE/de/;' po/LINGUAS
101 mv po/de_DE.po po/de.po
102 mv po/fr_FR.po po/fr.po
103
104 %build
105 %{__gettextize}
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --enable-flac \
113         --enable-id3tag \
114         --enable-mp3 \
115         --enable-ogg \
116         --enable-pcre \
117         --with-ltdl-lib=%{_libdir} \
118         --with-ltdl-include=%{_includedir} \
119         %{!?with_static_libs:--disable-static}
120
121 %{__make}
122 %if %{with apidocs}
123 %{__make} -C doc doc
124 %endif
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmp3splt0/*.{a,la}
133 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
134
135 %find_lang libmp3splt0
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f libmp3splt0.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README TODO
146 %attr(755,root,root) %{_libdir}/libmp3splt.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libmp3splt.so.0
148 %dir %{_libdir}/libmp3splt0
149 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_flac.so
150 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_mp3.so
151 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_ogg.so
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_libdir}/libmp3splt.so
156 %{_libdir}/libmp3splt.la
157 %{_includedir}/libmp3splt
158 %{_pkgconfigdir}/libmp3splt.pc
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libmp3splt.a
164 %endif
165
166 %if %{with apidocs}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc doc/doxygen/*
170 %endif
This page took 0.094794 seconds and 3 git commands to generate.