]> git.pld-linux.org Git - packages/libmatroska.git/blobdiff - libmatroska.spec
- updated to 1.4.9; build system has been changed to cmake
[packages/libmatroska.git] / libmatroska.spec
index f119987f42f053bb9c5d4944bdc7766303eef975..dd58742f6ccc510e200909812add38ebafb30e7a 100644 (file)
@@ -1,21 +1,23 @@
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+
 Summary:       Extensible Binary Meta Language access library
 Summary(pl.UTF-8):     Biblioteka dostępu rozszerzalnego metajęzyka binarnego
 Name:          libmatroska
-Version:       1.4.8
+Version:       1.4.9
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://dl.matroska.org/downloads/libmatroska/%{name}-%{version}.tar.xz
-# Source0-md5: 45ffda84badb4e3da5d8f2535e54d511
+# Source0-md5: cb1671e4045e1f36c7e055baba7af9d5
 URL:           https://www.matroska.org/
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake
-BuildRequires: libebml-devel >= 1.3.4
+BuildRequires: cmake >= 3.1.2
+BuildRequires: libebml-devel >= 1.3.5
 BuildRequires: libstdc++-devel
-BuildRequires: libtool >= 2:2
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.566
-Requires:      libebml >= 1.3.4
+BuildRequires: rpmbuild(macros) >= 1.605
+Requires:      libebml >= 1.3.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -39,7 +41,7 @@ Summary:      Header files for matroska library
 Summary(pl.UTF-8):     Nagłówki dla biblioteki matroska
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libebml-devel >= 1.3.4
+Requires:      libebml-devel >= 1.3.5
 Requires:      libstdc++-devel
 
 %description devel
@@ -64,20 +66,36 @@ Statyczna wersja biblioteki matroska.
 %setup -q
 
 %build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       %{?debug:--enable-debug}
+# .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
+%if %{with static_libs}
+install -d build-static
+cd build-static
+%cmake .. \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DCMAKE_INSTALL_INCLUDEDIR=include \
+       -DCMAKE_INSTALL_LIBDIR=%{_lib}
+
+%{__make}
+cd ..
+%endif
+
+install -d build
+cd build
+%cmake .. \
+       -DCMAKE_INSTALL_INCLUDEDIR=include \
+       -DCMAKE_INSTALL_LIBDIR=%{_lib}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%if %{with static_libs}
+%{__make} -C build-static install \
+       DESTDIR=$RPM_BUILD_ROOT
+%endif
+
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
@@ -88,17 +106,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog
+%doc ChangeLog README.md
 %attr(755,root,root) %{_libdir}/libmatroska.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libmatroska.so.6
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libmatroska.so
-%{_libdir}/libmatroska.la
 %{_includedir}/matroska
 %{_pkgconfigdir}/libmatroska.pc
+%{_libdir}/cmake/matroska
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libmatroska.a
+%endif
This page took 0.086826 seconds and 4 git commands to generate.