]> git.pld-linux.org Git - packages/libmatroska.git/blob - libmatroska.spec
up to 1.7.1
[packages/libmatroska.git] / libmatroska.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Extensible Binary Meta Language access library
6 Summary(pl.UTF-8):      Biblioteka dostępu rozszerzalnego metajęzyka binarnego
7 Name:           libmatroska
8 Version:        1.7.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        https://dl.matroska.org/downloads/libmatroska/%{name}-%{version}.tar.xz
13 # Source0-md5:  576ca1b6d2661f328a42192124135e86
14 URL:            https://www.matroska.org/
15 BuildRequires:  cmake >= 3.1.2
16 BuildRequires:  libebml-devel >= 1.4.3
17 BuildRequires:  libstdc++-devel >= 6:5
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       libebml >= 1.4.3
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Matroska is an extensible open standard Audio/Video container format,
27 aiming to become the standard of Multimedia Container Formats one day.
28 It is based on EBML (Extensible Binary Meta Language), a kind of
29 binary version of XML. This way the significant advantages in terms of
30 future format extensibility are gained without breaking file support
31 in old parsers.
32
33 %description -l pl.UTF-8
34 Matroska to rozszerzalny otwarty format kodowania dźwięku i obrazu,
35 dążący do stania się pewnego dnia standardem formatów zawierających
36 multimedia. Jest on oparty na EBML (rozszerzalnym metajęzyku
37 binarnym), binarnym odpowiedniku XML-a. W ten sposób ma on przewagę
38 nad innymi formatami pod względem przyszłej rozszerzalności przy
39 jednoczesnym zachowaniu kompatybilności wstecz.
40
41 %package devel
42 Summary:        Header files for matroska library
43 Summary(pl.UTF-8):      Nagłówki dla biblioteki matroska
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libebml-devel >= 1.4.3
47 Requires:       libstdc++-devel >= 6:4.7
48
49 %description devel
50 Header files for matroska library.
51
52 %description devel -l pl.UTF-8
53 Nagłówki dla biblioteki matroska.
54
55 %package static
56 Summary:        Static version of matroska library
57 Summary(pl.UTF-8):      Statyczna wersja biblioteki matroska
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static version of matroska library.
63
64 %description static -l pl.UTF-8
65 Statyczna wersja biblioteki matroska.
66
67 %prep
68 %setup -q
69
70 %build
71 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
72 %if %{with static_libs}
73 install -d build-static
74 cd build-static
75 %cmake .. \
76         -DBUILD_SHARED_LIBS:BOOL=OFF \
77         -DCMAKE_INSTALL_INCLUDEDIR=include \
78         -DCMAKE_INSTALL_LIBDIR=%{_lib}
79
80 %{__make}
81 cd ..
82 %endif
83
84 install -d build
85 cd build
86 %cmake .. \
87         -DCMAKE_INSTALL_INCLUDEDIR=include \
88         -DCMAKE_INSTALL_LIBDIR=%{_lib}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %if %{with static_libs}
96 %{__make} -C build-static install \
97         DESTDIR=$RPM_BUILD_ROOT
98 %endif
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc NEWS.md README.md
112 %attr(755,root,root) %{_libdir}/libmatroska.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libmatroska.so.7
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libmatroska.so
118 %{_includedir}/matroska
119 %{_pkgconfigdir}/libmatroska.pc
120 %{_libdir}/cmake/Matroska
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libmatroska.a
126 %endif
This page took 0.084947 seconds and 4 git commands to generate.