]> git.pld-linux.org Git - packages/libfuse3.git/blob - libfuse3.spec
up to 3.10.4
[packages/libfuse3.git] / libfuse3.spec
1 Summary:        Filesystem in Userspace
2 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
3 Name:           libfuse3
4 Version:        3.10.4
5 Release:        1
6 License:        LGPL v2 (library), GPL v2 (tools)
7 Group:          Applications/System
8 #Source0Download: https://github.com/libfuse/libfuse/releases
9 Source0:        https://github.com/libfuse/libfuse/releases/download/fuse-%{version}/fuse-%{version}.tar.xz
10 # Source0-md5:  55b87e9ed691c2fa698e491241985b4a
11 Patch0:         %{name}-build.patch
12 URL:            https://github.com/libfuse/libfuse
13 BuildRequires:  meson >= 0.42
14 BuildRequires:  ninja >= 1.5
15 BuildRequires:  rpmbuild(macros) >= 1.736
16 BuildRequires:  sed >= 4.0
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 FUSE (Filesystem in Userspace) is a simple interface for userspace
23 programs to export a virtual filesystem to the Linux kernel. FUSE also
24 aims to provide a secure method for non privileged users to create and
25 mount their own filesystem implementations.
26
27 This package contains a shared library.
28
29 %description -l pl.UTF-8
30 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
31 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
32 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
33 montowania własnych implementacji systemów plików przez zwykłych
34 (nieuprzywilejowanych) użytkowników.
35
36 Ten pakiet zawiera bibliotekę współdzieloną.
37
38 %package devel
39 Summary:        Filesystem in Userspace - Development header files
40 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
41 License:        LGPL v2
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Libfuse3 library header files.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki libfuse3.
50
51 %package static
52 Summary:        Filesystem in Userspace - static library
53 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteka statyczna
54 License:        LGPL v2
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libfuse3 library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libfuse3.
63
64 %package apidocs
65 Summary:        API documentation for FUSE 3 library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki FUSE 3
67 Group:          Documentation
68
69 %description apidocs
70 API documentation for FUSE 3 library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki FUSE 3.
74
75 %package -n libfuse-common
76 Summary:        Common package for FUSE 2 and FUSE 3
77 Summary(pl.UTF-8):      Pliki wspólne dla FUSE 2 i FUSE 3
78 Group:          Libraries
79 Conflicts:      libfuse < 2.9.7-3
80 Conflicts:      libfuse3 < 3.2.4-2
81
82 %description -n libfuse-common
83 Common package for FUSE 2 and FUSE 3.
84
85 %description -n libfuse-common -l pl.UTF-8
86 Pliki wspólne dla FUSE 2 i FUSE 3.
87
88 %package tools
89 Summary:        Tools to mount FUSE 3 based filesystems
90 Summary(pl.UTF-8):      Narzędzia do montowania systemów plików opartych na FUSE 3
91 License:        GPL v2
92 Group:          Applications/System
93 Requires(pre):  /usr/bin/getgid
94 Requires(pre):  /usr/sbin/groupadd
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       libfuse-common = %{version}-%{release}
97 Requires:       mount >= 2.18
98 Provides:       group(fuse)
99
100 %description tools
101 Tools to mount FUSE 3 based filesystems.
102
103 %description tools -l pl.UTF-8
104 Narzędzia do montowania systemów plików opartych na FUSE 3.
105
106 %prep
107 %setup -q -n fuse-%{version}
108 %patch0 -p1
109
110 %{__sed} -i '/FUSERMOUNT_PROG/s,fusermount3,%{_bindir}/fusermount3,' lib/mount.c
111
112 # gold is missing base versioning
113 install -d ld-dir
114 [ ! -x /usr/bin/ld.bfd ] || ln -sf /usr/bin/ld.bfd ld-dir/ld
115
116 %build
117 PATH=$(pwd)/ld-dir:$PATH
118
119 %meson build \
120         -Duseroot=false
121
122 %ninja_build -C build
123
124 %{?with_tests:%ninja_test -C build}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir},/sbin}
129
130 %ninja_install -C build
131
132 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libfuse3.so.* $RPM_BUILD_ROOT/%{_lib}
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfuse3.so
134 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libfuse3.so.*.*) \
135         $RPM_BUILD_ROOT%{_libdir}/libfuse3.so
136
137 %{__mv} $RPM_BUILD_ROOT{%{_sbindir},/sbin}/mount.fuse3
138
139 # part of default udev rules nowdays
140 %{__rm} $RPM_BUILD_ROOT/lib/udev/rules.d/99-fuse3.rules
141
142 # not needed
143 %{__rm} $RPM_BUILD_ROOT/etc/init.d/fuse3
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %pre tools
152 %groupadd -g 84 fuse
153
154 %files
155 %defattr(644,root,root,755)
156 %doc README.md ChangeLog.rst AUTHORS doc/{README.NFS,fast17-vangoor.pdf,kernel.txt}
157 %attr(755,root,root) /%{_lib}/libfuse3.so.*.*.*
158 %attr(755,root,root) %ghost /%{_lib}/libfuse3.so.3
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libfuse3.so
163 %{_includedir}/fuse3
164 %{_pkgconfigdir}/fuse3.pc
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libfuse3.a
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc doc/html/*
173
174 %files -n libfuse-common
175 %defattr(644,root,root,755)
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
177
178 %files tools
179 %defattr(644,root,root,755)
180 %attr(4755,root,root) %{_bindir}/fusermount3
181 %attr(755,root,root) /sbin/mount.fuse3
182 %{_mandir}/man1/fusermount3.1*
183 %{_mandir}/man8/mount.fuse3.8*
This page took 0.052643 seconds and 3 git commands to generate.