]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
- x32 rebuild
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # don't build gui stuff
4 %bcond_with     mmx             # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6
7 %ifarch athlon pentium2 pentium3 pentium4 %{x8664}
8 %define         with_mmx        1
9 %endif
10 Summary:        DV video software codec
11 Summary(pl.UTF-8):      Biblioteka do obsługi formatu wideo DV
12 Name:           libdv
13 Version:        1.0.0
14 Release:        5
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
18 # Source0-md5:  f895162161cfa4bb4a94c070a7caa6c7
19 Patch0:         %{name}-include_fix.patch
20 URL:            http://libdv.sourceforge.net/
21 BuildRequires:  autoconf >= 2.59-9
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig >= 1:0.7
25 BuildRequires:  popt-devel
26 BuildRequires:  rpmbuild(macros) >= 1.213
27 %if %{with gui}
28 BuildRequires:  SDL-devel >= 1.1.6
29 BuildRequires:  gtk+-devel >= 1.2.10-3
30 BuildRequires:  xorg-lib-libXv-devel
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Quasar DV codec (libdv) is a software codec for DV video. DV is
36 the encoding format used by most digital camcorders, typically those
37 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
38 was developed according to the official standards for DV video, IEC
39 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
40
41 %description -l pl.UTF-8
42 Quasar DV (libdv) jest biblioteką do obsługi obrazu DV. DV jest
43 formatem stosowanym przez większość cyfrowych urządzeń, zwykle tych,
44 które używają interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
45 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
46
47 %package devel
48 Summary:        DV library headers
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DV
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 This is the libraries, include files and other resources you can use
55 to incorporate libdv into applications.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe potrzebne do budowania programów korzystających z
59 libdv.
60
61 %package static
62 Summary:        DV static libraries
63 Summary(pl.UTF-8):      Statyczne biblioteki do obsługi formatu DV
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 This is package with static libdv libraries.
69
70 %description static -l pl.UTF-8
71 Statyczna wersja biblioteki libdv.
72
73 %package -n dv
74 Summary:        Programs to encode and play DV files
75 Summary(pl.UTF-8):      Programy do kodowania i odtwarzania plików DV
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n dv
80 Programs to encode and play DV files.
81
82 %description -n dv -l pl.UTF-8
83 Programy do kodowania i odtwarzania plików DV.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{!?with_mmx:--disable-asm} \
97 %if %{with gui}
98         --enable-gtk \
99         --enable-sdl \
100 %else
101         --disable-gtk \
102         --disable-sdl \
103 %endif
104         --enable-shared \
105         %{!?with_static_libs:--disable-static} \
106         --without-debug
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         pkgconfigdir=%{_pkgconfigdir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README.* TODO
126 %attr(755,root,root) %{_libdir}/libdv.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libdv.so.4
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libdv.so
132 %{_libdir}/libdv.la
133 %{_includedir}/libdv
134 %{_pkgconfigdir}/libdv.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libdv.a
140 %endif
141
142 %if %{with gui}
143 %files -n dv
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/dubdv
146 %attr(755,root,root) %{_bindir}/dvconnect
147 %attr(755,root,root) %{_bindir}/encodedv
148 %attr(755,root,root) %{_bindir}/playdv
149 %{_mandir}/man1/dubdv.1*
150 %{_mandir}/man1/dvconnect.1*
151 %{_mandir}/man1/encodedv.1*
152 %{_mandir}/man1/playdv.1*
153 %endif
This page took 0.074438 seconds and 3 git commands to generate.