]> git.pld-linux.org Git - packages/libcmrt.git/blob - libcmrt.spec
- new URLs, updated to 1.0.6, added -jitter subpackage with binary blob
[packages/libcmrt.git] / libcmrt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define libva_ver       1.2.0
6
7 Summary:        C for Media Runtime - media GPU kernel manager for Intel GPUs
8 Summary(pl.UTF-8):      C for Media Runtime - zarządca jąder GPU dla układów Intela
9 Name:           libcmrt
10 Version:        1.0.6
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 #Source0Download: https://github.com/intel/cmrt/releases
15 Source0:        https://github.com/intel/cmrt/archive/%{version}/cmrt-%{version}.tar.gz
16 # Source0-md5:  91f5845c9354cce44a5133337f4e881c
17 Patch0:         x32.patch
18 URL:            https://github.com/intel/cmrt
19 BuildRequires:  autoconf >= 2.57
20 BuildRequires:  automake
21 BuildRequires:  libdrm-devel >= 2.4.23
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  libva-devel >= %{libva_ver}
25 BuildRequires:  pkgconfig
26 BuildRequires:  pkgconfig(libva) >= 0.34
27 Requires:       libdrm >= 2.4.23
28 Requires:       libva >= %{libva_ver}
29 ExclusiveArch:  %{ix86} %{x8664} x32
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 One solution to expose Intel's Gen GPU's high performance through high
34 level language.
35
36 Features:
37 - Interface between host program and driver
38 - Manage Gen device
39 - Manage surfaces
40 - Manage media GPU kernels
41 - Manage events
42 - Manage threads
43 - Manage execution
44 - Prepare media GPU kernel arguments
45 - Transfer data between system and GPU memory
46 - Report errors
47
48 %description -l pl.UTF-8
49 Rozwiązanie mające na celu udostępnienie wysokiej wydajności
50 procesorów graficznych (GPU) Intel Gen poprzez język wysokopoziomowy.
51
52 Możliwości:
53 - interfejs między programem hostującym a sterownikiem
54 - zarządzanie urządzeniem Gen
55 - zarządzanie powierzchniami
56 - zarządzanie jądrami GPU
57 - zarządzanie zdarzeniami
58 - zarządzanie wątkami
59 - zarządzanie wykonywaniem
60 - przygotowywanie argumentów dla jąder GPU
61 - przesyłanie pamięci między pamięcią systemową a GPU
62 - raportowanie błędów
63
64 %package jitter
65 Summary:        Online compiler to convert VirtualISA into Gen HW instructions
66 Summary(pl.UTF-8):      Kompilator w locie reprezentacji VirtualISA na instrukcje Gen HW
67 License:        distributable, non-free, closed source
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       libstdc++ >= 6:4.8
70
71 %description jitter
72 Jitter (igfxcmjit32.so or igfxcmjit64.so) is an online compiler to
73 convert VirtualISA into Gen HW instruction, while VirtualISA is an
74 intermediate representation between CM source code and HW instruction.
75
76 %description jitter -l pl.UTF-8
77 Jitter (igfxcmjit32.so lub igfxcmjit64.so) to działający w locie
78 kompilator przekształcający reprezentację VirtualISA na instrukcje Gen
79 HW. VirtualISA to reprezentacja pośrednia między kodem źródłowym CM a
80 instrukcjami sprzętowymi.
81
82 %package devel
83 Summary:        Header files for CMRT library
84 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMRT
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87
88 %description devel
89 Header files for CMRT library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki CMRT.
93
94 %package static
95 Summary:        Static CMRT library
96 Summary(pl.UTF-8):      Statyczna biblioteka CMRT
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static CMRT library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka CMRT.
105
106 %prep
107 %setup -q -n cmrt-%{version}
108 %patch0 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-silent-rules \
118         %{?with_static_libs:--enable-static}
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %ifarch %{ix86}
129 install jitter/igfxcmjit32.so $RPM_BUILD_ROOT%{_libdir}
130 %endif
131 %ifarch %{x8664}
132 install jitter/igfxcmjit64.so $RPM_BUILD_ROOT%{_libdir}
133 %endif
134
135 # obsoleted by pkg-config
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcmrt.la
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS COPYING NEWS README
147 %attr(755,root,root) %{_libdir}/libcmrt.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libcmrt.so.1
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cmrt.conf
150
151 %ifarch %{ix86} %{x8664}
152 %files jitter
153 %defattr(644,root,root,755)
154 %doc jitter/{LICENSE,readme}.txt
155 %ifarch %{ix86}
156 %attr(755,root,root) %{_libdir}/igfxcmjit32.so
157 %endif
158 %ifarch %{x8664}
159 %attr(755,root,root) %{_libdir}/igfxcmjit64.so
160 %endif
161 %endif
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libcmrt.so
166 %{_includedir}/cm_rt*.h
167 %{_pkgconfigdir}/libcmrt.pc
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libcmrt.a
173 %endif
This page took 0.084947 seconds and 4 git commands to generate.