]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
fb9e9862defcf5beb07f9b2d39c4ccfec352ffd2
[packages/libbsd.git] / libbsd.spec
1 # TODO
2 # - take french bitstring.3 from fcron?
3 Summary:        Utility functions from BSD systems
4 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
5 Name:           libbsd
6 Version:        0.8.7
7 Release:        1
8 License:        BSD, MIT (depending on part)
9 Group:          Libraries
10 Source0:        https://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
11 # Source0-md5:  d9e6980fbfe44f94fd92b89a33cce67d
12 URL:            https://libbsd.freedesktop.org/
13 BuildRequires:  sed >= 4.0
14 BuildRequires:  tar >= 1:1.22
15 BuildRequires:  xz
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This library provides useful functions commonly found on BSD systems,
20 and lacking on others like GNU systems, thus making it easier to port
21 projects with strong BSD origins, without needing to embed the same
22 code over and over again on each project.
23
24 %description -l pl.UTF-8
25 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
26 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
27 portowanie projektów mających silne korzenie BSD bez potrzeby
28 osadzania ciągle tego samego kodu w każdym projekcie.
29
30 %package devel
31 Summary:        Header files for BSD library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Conflicts:      glibc-devel < 6:2.19
36
37 %description devel
38 Header files for BSD library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki BSD.
42
43 %package static
44 Summary:        Static BSD library
45 Summary(pl.UTF-8):      Statyczna biblioteka BSD
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48 Conflicts:      glibc-devel < 6:2.19
49
50 %description static
51 Static BSD library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka BSD.
55
56 %prep
57 %setup -q
58
59 %build
60 %configure \
61         --disable-silent-rules
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 # obsoleted by pkg-config
71 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc COPYING ChangeLog README TODO
82 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/libbsd.so
88 %{_libdir}/libbsd-ctor.a
89 %{_includedir}/bsd
90 %{_pkgconfigdir}/libbsd.pc
91 %{_pkgconfigdir}/libbsd-ctor.pc
92 %{_pkgconfigdir}/libbsd-overlay.pc
93 %{_mandir}/man3/arc4random*.3*
94 %{_mandir}/man3/be16dec.3*
95 %{_mandir}/man3/be16enc.3*
96 %{_mandir}/man3/be32dec.3*
97 %{_mandir}/man3/be32enc.3*
98 %{_mandir}/man3/be64dec.3*
99 %{_mandir}/man3/be64enc.3*
100 %{_mandir}/man3/bit_alloc.3*
101 %{_mandir}/man3/bit_clear.3*
102 %{_mandir}/man3/bit_decl.3*
103 %{_mandir}/man3/bit_ffc.3*
104 %{_mandir}/man3/bit_ffs.3*
105 %{_mandir}/man3/bit_nclear.3*
106 %{_mandir}/man3/bit_nset.3*
107 %{_mandir}/man3/bit_set.3*
108 %{_mandir}/man3/bitstring.3*
109 %{_mandir}/man3/bitstr_size.3*
110 %{_mandir}/man3/bit_test.3*
111 %{_mandir}/man3/byteorder.3*
112 %{_mandir}/man3/closefrom.3*
113 %{_mandir}/man3/dehumanize_number.3*
114 %{_mandir}/man3/errc.3*
115 %{_mandir}/man3/expand_number.3*
116 %{_mandir}/man3/explicit_bzero.3*
117 %{_mandir}/man3/fgetln.3*
118 %{_mandir}/man3/fgetwln.3*
119 %{_mandir}/man3/flopen.3*
120 %{_mandir}/man3/fmtcheck.3*
121 %{_mandir}/man3/fparseln.3*
122 %{_mandir}/man3/fpurge.3*
123 %{_mandir}/man3/funopen.3*
124 %{_mandir}/man3/getbsize.3*
125 %{_mandir}/man3/getmode.3*
126 %{_mandir}/man3/getpeereid.3*
127 %{_mandir}/man3/getprogname.3*
128 %{_mandir}/man3/heapsort.3*
129 %{_mandir}/man3/humanize_number.3*
130 %{_mandir}/man3/le16dec.3*
131 %{_mandir}/man3/le16enc.3*
132 %{_mandir}/man3/le32dec.3*
133 %{_mandir}/man3/le32enc.3*
134 %{_mandir}/man3/le64dec.3*
135 %{_mandir}/man3/le64enc.3*
136 %{_mandir}/man3/LIST_*.3*
137 %{_mandir}/man3/md5.3**
138 %{_mandir}/man3/mergesort.3*
139 %{_mandir}/man3/nlist.3*
140 %{_mandir}/man3/pidfile.3*
141 %{_mandir}/man3/pidfile_close.3*
142 %{_mandir}/man3/pidfile_open.3*
143 %{_mandir}/man3/pidfile_remove.3*
144 %{_mandir}/man3/pidfile_write.3*
145 %{_mandir}/man3/queue.3**
146 %{_mandir}/man3/radixsort.3*
147 %{_mandir}/man3/RB_*.3*
148 %{_mandir}/man3/readpassphrase.3*
149 %{_mandir}/man3/reallocarray.3*
150 %{_mandir}/man3/reallocf.3*
151 %{_mandir}/man3/setmode.3*
152 %{_mandir}/man3/setproctitle.3*
153 %{_mandir}/man3/setproctitle_init.3*
154 %{_mandir}/man3/setprogname.3*
155 %{_mandir}/man3/sl_add.3*
156 %{_mandir}/man3/sl_delete.3*
157 %{_mandir}/man3/sl_find.3*
158 %{_mandir}/man3/sl_free.3*
159 %{_mandir}/man3/sl_init.3*
160 %{_mandir}/man3/SLIST_*.3*
161 %{_mandir}/man3/SPLAY_*.3*
162 %{_mandir}/man3/sradixsort.3*
163 %{_mandir}/man3/STAILQ_*.3*
164 %{_mandir}/man3/stringlist.3*
165 %{_mandir}/man3/strlcat.3*
166 %{_mandir}/man3/strlcpy.3*
167 %{_mandir}/man3/strmode.3*
168 %{_mandir}/man3/strnstr.3*
169 %{_mandir}/man3/strnunvis.3*
170 %{_mandir}/man3/strnvis.3*
171 %{_mandir}/man3/strtonum.3*
172 %{_mandir}/man3/strunvis.3*
173 %{_mandir}/man3/strvis.3*
174 %{_mandir}/man3/strvisx.3*
175 %{_mandir}/man3/TAILQ_*.3*
176 %{_mandir}/man3/timeradd.3*
177 %{_mandir}/man3/timerclear.3*
178 %{_mandir}/man3/timercmp.3*
179 %{_mandir}/man3/timerisset.3*
180 %{_mandir}/man3/timersub.3*
181 %{_mandir}/man3/timespecadd.3*
182 %{_mandir}/man3/timespecclear.3*
183 %{_mandir}/man3/timespeccmp.3*
184 %{_mandir}/man3/timespecisset.3*
185 %{_mandir}/man3/timespecsub.3*
186 %{_mandir}/man3/TIMESPEC_TO_TIMEVAL.3*
187 %{_mandir}/man3/timeval.3*
188 %{_mandir}/man3/TIMEVAL_TO_TIMESPEC.3*
189 %{_mandir}/man3/tree.3*
190 %{_mandir}/man3/unvis.3*
191 %{_mandir}/man3/vis.3*
192 %{_mandir}/man3/wcslcat.3*
193 %{_mandir}/man3/wcslcpy.3*
194 %{_mandir}/man7/libbsd.7*
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libbsd.a
This page took 0.057589 seconds and 2 git commands to generate.