]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
- updated to 0.6.0
[packages/libbsd.git] / libbsd.spec
1 Summary:        Utility functions from BSD systems
2 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
3 Name:           libbsd
4 Version:        0.6.0
5 Release:        1
6 License:        BSD, MIT (depending on part)
7 Group:          Libraries
8 Source0:        http://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
9 # Source0-md5:  f6c75f0a9818e323a589bcbd560a0eb4
10 URL:            http://libbsd.freedesktop.org/
11 BuildRequires:  sed >= 4.0
12 BuildRequires:  tar >= 1:1.22
13 BuildRequires:  xz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This library provides useful functions commonly found on BSD systems,
18 and lacking on others like GNU systems, thus making it easier to port
19 projects with strong BSD origins, without needing to embed the same
20 code over and over again on each project.
21
22 %description -l pl.UTF-8
23 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
24 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
25 portowanie projektów mających silne korzenie BSD bez potrzeby
26 osadzania ciągle tego samego kodu w każdym projekcie.
27
28 %package devel
29 Summary:        Header files for BSD library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for BSD library.
36
37 Note: to avoid clash with libbsd.a from glibc, library provided by
38 this package is available as -lbsdutil.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki BSD.
42
43 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
44 dostarczana przez ten pakiet jest dostępna jako -lbsdutil.
45
46 %package static
47 Summary:        Static BSD library
48 Summary(pl.UTF-8):      Statyczna biblioteka BSD
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static BSD library.
54
55 Note: to avoid clash with libbsd.a from glibc, library provided by
56 this package is available as libbsdutil.a.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka BSD.
60
61 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
62 dostarczana przez ten pakiet jest dostępna jako libbsdutil.a.
63
64 %prep
65 %setup -q
66
67 %build
68 %configure \
69         --disable-silent-rules
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # avoid clash with libbsd.a from glibc
79 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.so
80 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.a
81 sed -i -e 's/-lbsd/-lbsdutil/' $RPM_BUILD_ROOT%{_pkgconfigdir}/{libbsd,libbsd-overlay}.pc
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc COPYING ChangeLog README TODO
93 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libbsdutil.so
99 %{_libdir}/libbsd-ctor.a
100 %{_includedir}/bsd
101 %{_pkgconfigdir}/libbsd.pc
102 %{_pkgconfigdir}/libbsd-ctor.pc
103 %{_pkgconfigdir}/libbsd-overlay.pc
104 %{_mandir}/man3/arc4random*.3*
105 %{_mandir}/man3/bitstring.3*
106 %{_mandir}/man3/closefrom.3*
107 %{_mandir}/man3/dehumanize_number.3*
108 %{_mandir}/man3/expand_number.3*
109 %{_mandir}/man3/fgetln.3*
110 %{_mandir}/man3/fgetwln.3*
111 %{_mandir}/man3/flopen.3*
112 %{_mandir}/man3/fmtcheck.3*
113 %{_mandir}/man3/fparseln.3*
114 %{_mandir}/man3/getmode.3*
115 %{_mandir}/man3/getpeereid.3*
116 %{_mandir}/man3/getprogname.3*
117 %{_mandir}/man3/heapsort.3*
118 %{_mandir}/man3/humanize_number.3*
119 %{_mandir}/man3/md5.3bsd*
120 %{_mandir}/man3/mergesort.3*
121 %{_mandir}/man3/nlist.3*
122 %{_mandir}/man3/pidfile.3*
123 %{_mandir}/man3/queue.3bsd*
124 %{_mandir}/man3/radixsort.3*
125 %{_mandir}/man3/readpassphrase.3*
126 %{_mandir}/man3/reallocf.3*
127 %{_mandir}/man3/setmode.3*
128 %{_mandir}/man3/setproctitle.3*
129 %{_mandir}/man3/setprogname.3*
130 %{_mandir}/man3/sradixsort.3*
131 %{_mandir}/man3/strlcat.3*
132 %{_mandir}/man3/strlcpy.3*
133 %{_mandir}/man3/strmode.3*
134 %{_mandir}/man3/strnstr.3*
135 %{_mandir}/man3/strtonum.3*
136 %{_mandir}/man3/tree.3*
137 %{_mandir}/man3/unvis.3*
138 %{_mandir}/man3/vis.3*
139 %{_mandir}/man3/wcslcat.3*
140 %{_mandir}/man3/wcslcpy.3*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libbsdutil.a
This page took 0.063917 seconds and 3 git commands to generate.