]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
- updated to 0.12.2
[packages/libbsd.git] / libbsd.spec
1 # TODO
2 # - take french bitstring.3 from fcron?
3 Summary:        Utility functions from BSD systems
4 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
5 Name:           libbsd
6 Version:        0.11.3
7 Release:        2
8 License:        BSD, MIT (depending on part)
9 Group:          Libraries
10 Source0:        https://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
11 # Source0-md5:  5ce1707688d8bb75d365fadfce962b2c
12 URL:            https://libbsd.freedesktop.org/
13 BuildRequires:  libmd-devel >= 1.0
14 BuildRequires:  sed >= 4.0
15 BuildRequires:  tar >= 1:1.22
16 BuildRequires:  xz
17 Requires:       libmd >= 1.0
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This library provides useful functions commonly found on BSD systems,
22 and lacking on others like GNU systems, thus making it easier to port
23 projects with strong BSD origins, without needing to embed the same
24 code over and over again on each project.
25
26 %description -l pl.UTF-8
27 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
28 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
29 portowanie projektów mających silne korzenie BSD bez potrzeby
30 osadzania ciągle tego samego kodu w każdym projekcie.
31
32 %package devel
33 Summary:        Header files for BSD library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libmd >= 1.0
38 Conflicts:      glibc-devel < 6:2.19
39
40 %description devel
41 Header files for BSD library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki BSD.
45
46 %package static
47 Summary:        Static BSD library
48 Summary(pl.UTF-8):      Statyczna biblioteka BSD
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51 Conflicts:      glibc-devel < 6:2.19
52
53 %description static
54 Static BSD library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka BSD.
58
59 %prep
60 %setup -q
61
62 %build
63 CPPFLAGS="%{rpmcppflags} -I/usr/include/libmd"
64 %configure \
65         --disable-silent-rules
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 # obsoleted by pkg-config
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc COPYING ChangeLog README TODO
86 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libbsd.so
92 %{_libdir}/libbsd-ctor.a
93 %{_includedir}/bsd
94 %{_pkgconfigdir}/libbsd.pc
95 %{_pkgconfigdir}/libbsd-ctor.pc
96 %{_pkgconfigdir}/libbsd-overlay.pc
97 %{_mandir}/man3/LIST_*.3bsd*
98 %{_mandir}/man3/RB_*.3bsd*
99 %{_mandir}/man3/SLIST_*.3bsd*
100 %{_mandir}/man3/SPLAY_*.3bsd*
101 %{_mandir}/man3/STAILQ_*.3bsd*
102 %{_mandir}/man3/TAILQ_*.3bsd*
103 %{_mandir}/man3/TIMESPEC_TO_TIMEVAL.3bsd*
104 %{_mandir}/man3/TIMEVAL_TO_TIMESPEC.3bsd*
105 %{_mandir}/man3/arc4random*.3bsd*
106 %{_mandir}/man3/be16dec.3bsd*
107 %{_mandir}/man3/be16enc.3bsd*
108 %{_mandir}/man3/be32dec.3bsd*
109 %{_mandir}/man3/be32enc.3bsd*
110 %{_mandir}/man3/be64dec.3bsd*
111 %{_mandir}/man3/be64enc.3bsd*
112 %{_mandir}/man3/bit_alloc.3bsd*
113 %{_mandir}/man3/bit_clear.3bsd*
114 %{_mandir}/man3/bit_decl.3bsd*
115 %{_mandir}/man3/bit_ffc.3bsd*
116 %{_mandir}/man3/bit_ffs.3bsd*
117 %{_mandir}/man3/bit_nclear.3bsd*
118 %{_mandir}/man3/bit_nset.3bsd*
119 %{_mandir}/man3/bit_set.3bsd*
120 %{_mandir}/man3/bit_test.3bsd*
121 %{_mandir}/man3/bitstr_size.3bsd*
122 %{_mandir}/man3/bitstring.3bsd*
123 %{_mandir}/man3/byteorder.3bsd*
124 %{_mandir}/man3/closefrom.3bsd*
125 %{_mandir}/man3/dehumanize_number.3bsd*
126 %{_mandir}/man3/errc.3bsd*
127 %{_mandir}/man3/expand_number.3bsd*
128 %{_mandir}/man3/explicit_bzero.3bsd*
129 %{_mandir}/man3/fgetln.3bsd*
130 %{_mandir}/man3/fgetwln.3bsd*
131 %{_mandir}/man3/flopen.3bsd*
132 %{_mandir}/man3/fmtcheck.3bsd*
133 %{_mandir}/man3/fparseln.3bsd*
134 %{_mandir}/man3/fpurge.3bsd*
135 %{_mandir}/man3/freezero.3bsd*
136 %{_mandir}/man3/funopen.3bsd*
137 %{_mandir}/man3/getbsize.3bsd*
138 %{_mandir}/man3/getmode.3bsd*
139 %{_mandir}/man3/getpeereid.3bsd*
140 %{_mandir}/man3/getprogname.3bsd*
141 %{_mandir}/man3/gid_from_group.3bsd*
142 %{_mandir}/man3/group_from_gid.3bsd*
143 %{_mandir}/man3/heapsort.3bsd*
144 %{_mandir}/man3/humanize_number.3bsd*
145 %{_mandir}/man3/le16dec.3bsd*
146 %{_mandir}/man3/le16enc.3bsd*
147 %{_mandir}/man3/le32dec.3bsd*
148 %{_mandir}/man3/le32enc.3bsd*
149 %{_mandir}/man3/le64dec.3bsd*
150 %{_mandir}/man3/le64enc.3bsd*
151 %{_mandir}/man3/md5.3bsd*
152 %{_mandir}/man3/mergesort.3bsd*
153 %{_mandir}/man3/nlist.3bsd*
154 %{_mandir}/man3/pidfile.3bsd*
155 %{_mandir}/man3/pidfile_close.3bsd*
156 %{_mandir}/man3/pidfile_open.3bsd*
157 %{_mandir}/man3/pidfile_remove.3bsd*
158 %{_mandir}/man3/pidfile_write.3bsd*
159 %{_mandir}/man3/pwcache.3bsd*
160 %{_mandir}/man3/queue.3bsd*
161 %{_mandir}/man3/radixsort.3bsd*
162 %{_mandir}/man3/readpassphrase.3bsd*
163 %{_mandir}/man3/reallocarray.3bsd*
164 %{_mandir}/man3/reallocf.3bsd*
165 %{_mandir}/man3/recallocarray.3bsd*
166 %{_mandir}/man3/setmode.3bsd*
167 %{_mandir}/man3/setproctitle.3bsd*
168 %{_mandir}/man3/setproctitle_init.3bsd*
169 %{_mandir}/man3/setprogname.3bsd*
170 %{_mandir}/man3/sl_add.3bsd*
171 %{_mandir}/man3/sl_delete.3bsd*
172 %{_mandir}/man3/sl_find.3bsd*
173 %{_mandir}/man3/sl_free.3bsd*
174 %{_mandir}/man3/sl_init.3bsd*
175 %{_mandir}/man3/sradixsort.3bsd*
176 %{_mandir}/man3/stringlist.3bsd*
177 %{_mandir}/man3/strlcat.3bsd*
178 %{_mandir}/man3/strlcpy.3bsd*
179 %{_mandir}/man3/strmode.3bsd*
180 %{_mandir}/man3/strnstr.3bsd*
181 %{_mandir}/man3/strnunvis.3bsd*
182 %{_mandir}/man3/strnvis.3bsd*
183 %{_mandir}/man3/strtoi.3bsd*
184 %{_mandir}/man3/strtonum.3bsd*
185 %{_mandir}/man3/strtou.3bsd*
186 %{_mandir}/man3/strunvis.3bsd*
187 %{_mandir}/man3/strvis.3bsd*
188 %{_mandir}/man3/strvisx.3bsd*
189 %{_mandir}/man3/timeradd.3bsd*
190 %{_mandir}/man3/timerclear.3bsd*
191 %{_mandir}/man3/timercmp.3bsd*
192 %{_mandir}/man3/timerisset.3bsd*
193 %{_mandir}/man3/timersub.3bsd*
194 %{_mandir}/man3/timespec.3bsd*
195 %{_mandir}/man3/timespecadd.3bsd*
196 %{_mandir}/man3/timespecclear.3bsd*
197 %{_mandir}/man3/timespeccmp.3bsd*
198 %{_mandir}/man3/timespecisset.3bsd*
199 %{_mandir}/man3/timespecsub.3bsd*
200 %{_mandir}/man3/timeval.3bsd*
201 %{_mandir}/man3/tree.3bsd*
202 %{_mandir}/man3/uid_from_user.3bsd*
203 %{_mandir}/man3/unvis.3bsd*
204 %{_mandir}/man3/user_from_uid.3bsd*
205 %{_mandir}/man3/vis.3bsd*
206 %{_mandir}/man3/wcslcat.3bsd*
207 %{_mandir}/man3/wcslcpy.3bsd*
208 %{_mandir}/man7/libbsd.7*
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libbsd.a
This page took 0.093865 seconds and 3 git commands to generate.