]> git.pld-linux.org Git - packages/lame.git/blob - lame.spec
- rediffed
[packages/lame.git] / lame.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk     # GTK+ frontend
4 #
5 Summary:        Software to create compressed audio files
6 Summary(es.UTF-8):      Lame es un gerador de MP3
7 Summary(pl.UTF-8):      Program do tworzenia skompresowanych plików dźwiękowych
8 Summary(pt_BR.UTF-8):   Lame é um gerador de MP3
9 Name:           lame
10 Version:        3.100
11 Release:        1
12 # libmp3lame encoder is LGPL v2+, but decoder parts (enabled by default)
13 # come from old mpg123 code, which was licensed on GPL
14 License:        GPL v2+ (MP3 decoder), LGPL v2+ (the rest)
15 Group:          Applications/Sound
16 Source0:        http://downloads.sourceforge.net/lame/%{name}-%{version}.tar.gz
17 # Source0-md5:  83e260acbe4389b54fe08e0bdbf7cddb
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-without_gtk.patch
20 Patch2:         %{name}-exports.patch
21 Patch3:         %{name}-sse.patch
22 URL:            http://lame.sourceforge.net/
23 BuildRequires:  autoconf >= 2.69
24 BuildRequires:  automake
25 %{?with_gtk:BuildRequires:      gtk+-devel >= 1.2.0}
26 # with --with-fileio=sndfile (but disables stdin input)
27 #BuildRequires: libsndfile-devel >= 1.0.2
28 BuildRequires:  libtool
29 %ifarch %{ix86}
30 BuildRequires:  nasm
31 %endif
32 BuildRequires:  ncurses-devel >= 4.2
33 BuildRequires:  pkgconfig
34 Requires:       %{name}-libs = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Lame (LAME Ain't an MP3 Encoder) is a program which can be used to
39 create compressed audio files. These audio files can be played back by
40 popular MP3 players such as mpg123.
41
42 %description -l es.UTF-8
43 LAME es un encoder MP3 GPL.
44
45 %description -l pl.UTF-8
46 Lame (LAME Ain't an MP3 Encoder - LAME to nie program do kodowania
47 MP3) jest programem, który służy do tworzenia skompresowanych plików
48 dźwiękowych. Stworzone pliki można odtwarzać dekoderami MP3, np.:
49 mpg123.
50
51 %description -l pt_BR.UTF-8
52 LAME é um encoder MP3 GPL.
53
54 %package libs
55 Summary:        LAME MP3 encoding library
56 Summary(pl.UTF-8):      Biblioteka kodująca MP3 LAME
57 Group:          Libraries
58
59 %description libs
60 LAME MP3 encoding library.
61
62 %description libs -l pl.UTF-8
63 Biblioteka kodująca MP3 LAME.
64
65 %package libs-devel
66 Summary:        Header files and devel documentation
67 Summary(es.UTF-8):      Archivos para desarrollo
68 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja deweloperska
69 Summary(pt_BR.UTF-8):   Arquivos para desenvolvimento
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72
73 %description libs-devel
74 Header files and devel documentation for LAME libraries.
75
76 %description libs-devel -l es.UTF-8
77 Archivos de desarrolo.
78
79 %description libs-devel -l pl.UTF-8
80 Pliki nagłówkowe i dokumentacja deweloperska bibliotek LAME.
81
82 %description libs-devel -l pt_BR.UTF-8
83 Arquivos de desenvolvimento.
84
85 %package libs-static
86 Summary:        Static LAME library
87 Summary(es.UTF-8):      Bibliotecas estaticas de desarrollo
88 Summary(pl.UTF-8):      Biblioteki statyczne LAME
89 Summary(pt_BR.UTF-8):   Bibliotecas estáticas de desenvolvimento
90 Group:          Development/Libraries
91 Requires:       %{name}-libs-devel = %{version}-%{release}
92
93 %description libs-static
94 LAME static libraries.
95
96 %description libs-static -l es.UTF-8
97 Bibliotecas estaticas de desarrollo.
98
99 %description libs-static -l pl.UTF-8
100 Biblioteki statyczne LAME.
101
102 %description libs-static -l pt_BR.UTF-8
103 Bibliotecas estáticas de desenvolvimento.
104
105 %package x11
106 Summary:        GTK+ frame analyzer
107 Summary(pl.UTF-8):      Analizator ramek w GTK+
108 Group:          Applications/Sound
109 Requires:       %{name}-libs = %{version}-%{release}
110
111 %description x11
112 GTK+ frame analyzer.
113
114 %description x11 -l pl.UTF-8
115 Analizator ramek w GTK+.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %{!?with_gtk:%patch1 -p1}
121 %patch2 -p1
122 %patch3 -p1
123
124 %build
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --disable-cpml \
132         --enable-dynamic-frontends \
133         %{?with_gtk:--enable-mp3x} \
134         --enable-mp3rtp \
135 %ifarch %{ix86}
136         --enable-nasm
137 %endif
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/lame/html
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   libs -p /sbin/ldconfig
153 %postun libs -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc ChangeLog README TODO USAGE doc/html/*.html
158 %attr(755,root,root) %{_bindir}/lame
159 %attr(755,root,root) %{_bindir}/mp3rtp
160 %{_mandir}/man1/lame.1*
161
162 %files libs
163 %defattr(644,root,root,755)
164 %doc LICENSE
165 %attr(755,root,root) %{_libdir}/libmp3lame.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libmp3lame.so.0
167
168 %files libs-devel
169 %defattr(644,root,root,755)
170 %doc API DEFINES
171 %attr(755,root,root) %{_libdir}/libmp3lame.so
172 %{_libdir}/libmp3lame.la
173 %{_includedir}/lame
174
175 %files libs-static
176 %defattr(644,root,root,755)
177 %{_libdir}/libmp3lame.a
178
179 %if %{with gtk}
180 %files x11
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/mp3x
183 %endif
This page took 0.149315 seconds and 4 git commands to generate.