]> git.pld-linux.org Git - packages/ktoblzcheck.git/blob - ktoblzcheck.spec
- updated to 1.53 (uses cmake now); added python3- package
[packages/ktoblzcheck.git] / ktoblzcheck.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A library to check account numbers and bank codes of German banks
6 Summary(pl.UTF-8):      Biblioteka do sprawdzania numerów kont i kodów bankowych niemieckich banków
7 Name:           ktoblzcheck
8 Version:        1.48
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/ktoblzcheck/%{name}-%{version}.tar.gz
13 # Source0-md5:  6f56c83a649cbdaf1aad3e04a7b7a8ce
14 URL:            http://ktoblzcheck.sourceforge.net/
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpm-pythonprov
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 KtoBLZCheck is a library to check account numbers and bank codes of
22 German banks.
23
24 Both a library for other programs as well as a short command-line tool
25 is available. It is possible to check pairs of account numbers and
26 bank codes (BLZ) of German banks, and to map bank codes (BLZ) to the
27 clear-text name and location of the bank.
28
29 %description -l pl.UTF-8
30 KtoBLZCheck to biblioteka do sprawdzania numerów kont i kodów
31 bankowych niemieckich banków.
32
33 Dostępna jest zarówno biblioteka jak i proste narzędzie działające z
34 linii poleceń. Pozwalają na sprawdzenie par numerów kont i kodów
35 bankowych (BLZ) niemieckich banków oraz na zamianę kodów bankowych
36 (BLZ) na tekstową nazwę oraz lokalizację banku.
37
38 %package devel
39 Summary:        Header files for KtoBLZCheck library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki KtoBLZCheck
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libstdc++-devel
44
45 %description devel
46 Header files for KtoBLZCheck library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki KtoBLZCheck.
50
51 %package static
52 Summary:        Static KtoBLZCheck library
53 Summary(pl.UTF-8):      Statyczna biblioteka KtoBLZCheck
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static KtoBLZCheck library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka KtoBLZCheck.
62
63 %package -n python-ktoblzcheck
64 Summary:        Python binding for KtoBLZCheck library
65 Summary(pl.UTF-8):      Wiązanie Pythona dla biblioteki KtoBLZCheck
66 Group:          Development/Languages/Python
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       python-modules >= 1:2.5
69
70 %description -n python-ktoblzcheck
71 Python binding for KtoBLZCheck library.
72
73 %description -n python-ktoblzcheck -l pl.UTF-8
74 Wiązanie Pythona dla biblioteki KtoBLZCheck.
75
76 %prep
77 %setup -q
78
79 %build
80 %configure \
81         --enable-python \
82         %{?with_static_libs:--enable-static}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libktoblzcheck.la
93
94 %py_postclean
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README
105 %attr(755,root,root) %{_bindir}/ktoblzcheck
106 %attr(755,root,root) %{_libdir}/libktoblzcheck.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libktoblzcheck.so.1
108 %dir %{_datadir}/%{name}
109 %{_datadir}/%{name}/*.txt
110 %attr(755,root,root) %{_datadir}/%{name}/*.pl
111 %{_mandir}/man1/ktoblzcheck.1*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libktoblzcheck.so
116 %{_includedir}/iban.h
117 %{_includedir}/ktoblzcheck.h
118 %{_pkgconfigdir}/ktoblzcheck.pc
119
120 %if %{with static_libs}
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libktoblzcheck.a
124 %endif
125
126 %files -n python-ktoblzcheck
127 %defattr(644,root,root,755)
128 %{py_sitescriptdir}/ktoblzcheck.py[co]
This page took 0.092392 seconds and 3 git commands to generate.