]> git.pld-linux.org Git - packages/kp5-xdg-desktop-portal-kde.git/blobdiff - kp5-xdg-desktop-portal-kde.spec
- updated to 5.27.11
[packages/kp5-xdg-desktop-portal-kde.git] / kp5-xdg-desktop-portal-kde.spec
index f822fcc7b61a17fc20571d8fe9dbfdc187c0d9e0..213ad9c2816c99b3582b78eee2ceb66f8072b21a 100644 (file)
@@ -1,18 +1,22 @@
-%define                kdeplasmaver    5.11.2
-%define                qtver           5.3.2
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.27.11
+%define                qtver           5.15.2
 %define                kpname          xdg-desktop-portal-kde
 
 Summary:       KDE XDG Desktop Portal
 Name:          kp5-%{kpname}
-Version:       5.11.2
+Version:       5.27.11
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 22828f884c7538652e07aa0200d921fc
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: da938f11c9caab561a4452810bec93d3
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.16.0
+BuildRequires: cups-devel
 BuildRequires: fontconfig-devel
 BuildRequires: kf5-attica-devel
 BuildRequires: kf5-kactivities-stats-devel
@@ -31,6 +35,7 @@ BuildRequires:        kf5-kpeople-devel
 BuildRequires: kf5-krunner-devel
 BuildRequires: kf5-kwallet-devel
 BuildRequires: kf5-plasma-framework-devel
+BuildRequires: ninja
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: xorg-driver-input-evdev-devel
 BuildRequires: xorg-driver-input-synaptics-devel
@@ -41,24 +46,27 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                qt5dir          %{_libdir}/qt5
 
 %description
-KDE XDG Desktop Portal
+A portal frontend service for Flatpak and possibly other desktop
+containment frameworks.
 
 %prep
 %setup -q -n %{kpname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake \
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ../
-%{__make}
+       -DHTML_INSTALL_DIR=%{_kdedocdir}
+%ninja_build -C build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kpname} --all-name --with-kde
 
@@ -67,6 +75,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{kpname}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xdg-desktop-portal-kde
+%attr(755,root,root) %{_libexecdir}/xdg-desktop-portal-kde
 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.desktop.kde.service
 %{_datadir}/xdg-desktop-portal/portals/kde.portal
+%{_datadir}/xdg-desktop-portal/kde-portals.conf
+%{_desktopdir}/org.freedesktop.impl.portal.desktop.kde.desktop
+%{_datadir}/knotifications5/xdg-desktop-portal-kde.notifyrc
+%{systemduserunitdir}/plasma-xdg-desktop-portal-kde.service
+%{_datadir}/qlogging-categories5/xdp-kde.categories
This page took 0.05192 seconds and 4 git commands to generate.