]> git.pld-linux.org Git - packages/kp5-xdg-desktop-portal-kde.git/blobdiff - kp5-xdg-desktop-portal-kde.spec
- updated to 5.27.11
[packages/kp5-xdg-desktop-portal-kde.git] / kp5-xdg-desktop-portal-kde.spec
index d36adb15aa4cb143e820743fe7a1caf3397a2a44..213ad9c2816c99b3582b78eee2ceb66f8072b21a 100644 (file)
@@ -1,18 +1,22 @@
-%define                kdeplasmaver    5.14.5
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.27.11
+%define                qtver           5.15.2
 %define                kpname          xdg-desktop-portal-kde
 
 Summary:       KDE XDG Desktop Portal
 Name:          kp5-%{kpname}
-Version:       5.14.5
+Version:       5.27.11
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: e13a7259f9749c765b2bd8ea5eb4175d
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: da938f11c9caab561a4452810bec93d3
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.16.0
+BuildRequires: cups-devel
 BuildRequires: fontconfig-devel
 BuildRequires: kf5-attica-devel
 BuildRequires: kf5-kactivities-stats-devel
@@ -31,6 +35,7 @@ BuildRequires:        kf5-kpeople-devel
 BuildRequires: kf5-krunner-devel
 BuildRequires: kf5-kwallet-devel
 BuildRequires: kf5-plasma-framework-devel
+BuildRequires: ninja
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: xorg-driver-input-evdev-devel
 BuildRequires: xorg-driver-input-synaptics-devel
@@ -48,18 +53,20 @@ containment frameworks.
 %setup -q -n %{kpname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake \
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ../
-%{__make}
+       -DHTML_INSTALL_DIR=%{_kdedocdir}
+%ninja_build -C build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kpname} --all-name --with-kde
 
@@ -71,3 +78,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libexecdir}/xdg-desktop-portal-kde
 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.desktop.kde.service
 %{_datadir}/xdg-desktop-portal/portals/kde.portal
+%{_datadir}/xdg-desktop-portal/kde-portals.conf
+%{_desktopdir}/org.freedesktop.impl.portal.desktop.kde.desktop
+%{_datadir}/knotifications5/xdg-desktop-portal-kde.notifyrc
+%{systemduserunitdir}/plasma-xdg-desktop-portal-kde.service
+%{_datadir}/qlogging-categories5/xdp-kde.categories
This page took 0.075922 seconds and 4 git commands to generate.