]> git.pld-linux.org Git - packages/kp5-bluedevil.git/blob - kp5-bluedevil.spec
- updated to 5.27.11
[packages/kp5-bluedevil.git] / kp5-bluedevil.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.11
5 %define         qtver           5.15.2
6 %define         kpname          bluedevil
7 Summary:        Integrate the Bluetooth technology within KDE workspace and applications
8 Name:           kp5-%{kpname}
9 Version:        5.27.11
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  fa76e6968433867bf329b759bcfa1419
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Quick-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  kf5-bluez-qt-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-kcmutils-devel
23 BuildRequires:  kf5-kconfigwidgets-devel
24 BuildRequires:  kf5-kdbusaddons-devel
25 BuildRequires:  kf5-kdeclarative-devel
26 BuildRequires:  kf5-kded-devel
27 BuildRequires:  kf5-ki18n-devel
28 BuildRequires:  kf5-kio-devel
29 BuildRequires:  kf5-kirigami2-devel
30 BuildRequires:  kf5-knotifications-devel
31 BuildRequires:  kf5-kwidgetsaddons-devel
32 BuildRequires:  kf5-kwindowsystem-devel
33 BuildRequires:  kf5-plasma-framework-devel
34 BuildRequires:  ninja
35 BuildRequires:  qt5-build >= %{qtver}
36 BuildRequires:  rpmbuild(macros) >= 1.164
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Integrate the Bluetooth technology within KDE workspace and
43 applications.
44
45 %prep
46 %setup -q -n %{kpname}-%{version}
47
48 %build
49 %cmake -B build \
50         -G Ninja \
51         %{!?with_tests:-DBUILD_TESTING=OFF} \
52         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
53         -DHTML_INSTALL_DIR=%{_kdedocdir}
54 %ninja_build -C build
55
56 %if %{with tests}
57 ctest
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %ninja_install -C build
63
64 # not supported by glibc yet
65 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
66
67 %find_lang bluedevil --all-name --with-kde
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f bluedevil.lang
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_bindir}/bluedevil-sendfile
78 %attr(755,root,root) %{_bindir}/bluedevil-wizard
79 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/bluedevil.so
80 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_bluetooth.so
81 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_obexftp.so
82 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth
83 %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/qmldir
84 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/bluetooth/libbluetoothplugin.so
85 %{_desktopdir}/org.kde.bluedevilsendfile.desktop
86 %{_desktopdir}/org.kde.bluedevilwizard.desktop
87 %dir %{_datadir}/bluedevilwizard
88 %{_datadir}/bluedevilwizard/pin-code-database.xml
89 %{_datadir}/knotifications5/bluedevil.notifyrc
90 %{_datadir}/mime/packages/bluedevil-mime.xml
91 %{_datadir}/plasma/plasmoids/org.kde.plasma.bluetooth
92 %{_datadir}/remoteview/bluetooth-network.desktop
93 %{_datadir}/metainfo/org.kde.plasma.bluetooth.appdata.xml
94 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth
95 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents
96 %dir %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui
97 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml
98 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/General.qml
99 %{_datadir}/kservices5/plasma-applet-org.kde.plasma.bluetooth.desktop
100 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_bluetooth.so
101 %{_desktopdir}/kcm_bluetooth.desktop
102 %{_datadir}/kpackage/kcms/kcm_bluetooth/contents/ui/main.qml
103 %{_datadir}/qlogging-categories5/bluedevil.categories
This page took 0.103834 seconds and 4 git commands to generate.