]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
- patch to build kismet on machine with kernel-headers installed
[packages/kismet.git] / kismet.spec
1 #
2 # TODO: Anybody knows, why it will not build, 
3 #       when kernel-headers are installed?
4 #
5 Summary:        Wireless network sniffer
6 Summary(pl):    Sniffer sieci bezprzewodowych
7 Name:           kismet
8 Version:        2005_04_R1
9 %define _ver 2005-04-R1
10 Release:        5
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://www.kismetwireless.net/code/%{name}-%{_ver}.tar.gz
14 # Source0-md5:  19b4f192eb11a418ed3f6bf65c1226af
15 Patch0:         %{name}-conf.patch
16 #Patch1:                %{name}-pcap.patch
17 URL:            http://www.kismetwireless.net/
18 BuildRequires:  ImageMagick-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  expat-devel
23 BuildRequires:  gmp-devel
24 BuildRequires:  libpcap-devel >= 2:0.8.1-2
25 BuildRequires:  libwiretap-devel
26 BuildRequires:  ncurses-ext-devel
27 BuildRequires:  zlib-devel
28 # it uses internal structures - so strict deps
29 %requires_eq    libpcap
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Kismet is a 802.11b wireless network sniffer. It is capable of
34 sniffing using almost any wireless card supported in Linux, including
35 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
36 Rangelan, etc), cards which support standard packet capture via
37 libpcap (Cisco), and limited support for cards without RF Monitor
38 support.
39
40 %description -l pl
41 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
42 sniffowania u¿ywaj±c prawie dowolnych bezprzewodowych kart sieciowych
43 w Linuksie w³±czaj±c w to karty Prism2 wspierane przez projekt Wlan-NG
44 (Linksys, Dlink, Rangelan, etc), kart które umo¿liwiaj±
45 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
46 wsparcie dla kart bez obs³ugi Monitora RF.
47
48 %prep
49 %setup -q -n %{name}-%{_ver}
50 %patch0 -p0
51 #%patch1 -p1
52
53 cp Makefile.in Makefile.new
54 sed -e 's#-o $(INSTUSR)##g' -e 's#-o $(INSTGRP)##g' \
55         Makefile.new > Makefile.in
56
57 %build
58 cp -f /usr/share/automake/config.* .
59 %{__aclocal}
60 %{__autoconf}
61 CPPFLAGS="-I/usr/include/ncurses"
62 %configure \
63         --enable-syspcap \
64         --with-linuxheaders=no \
65         --with-ethereal=%{_includedir} \
66 %ifarch arm
67         --enable-zaurus
68 %endif
69
70 %{__make} 
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
75
76 %{__make} install \
77         INSTGRP=$(id -g) \
78         MANGRP=$(id -g) \
79         prefix=$RPM_BUILD_ROOT%{_prefix} \
80         exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
81         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
82         BIN=$RPM_BUILD_ROOT%{_bindir} \
83         SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
84         MAN=$RPM_BUILD_ROOT%{_mandir}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc docs/* CHANGELOG CHANGELOG-OLD README
92 %attr(755,root,root) %{_bindir}/*
93 %{_sysconfdir}/*_manuf
94 %{_datadir}/%{name}
95 %{_mandir}/man?/*
96 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}*
This page took 0.074415 seconds and 4 git commands to generate.