]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
- rel. 1
[packages/kismet.git] / kismet.spec
1 #
2 # TODO: Anybody knows, why it will not build,
3 #       when kernel-headers are installed?
4 #
5 Summary:        Wireless network sniffer
6 Summary(pl.UTF-8):      Sniffer sieci bezprzewodowych
7 Name:           kismet
8 Version:        2007_10_R1
9 %define _ver    2007-10-R1
10 Release:        1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://www.kismetwireless.net/code/%{name}-%{_ver}.tar.gz
14 # Source0-md5:  2100c667e69db0cde35fa2d06c8516e2
15 Patch0:         %{name}-c++.patch
16 URL:            http://www.kismetwireless.net/
17 BuildRequires:  ImageMagick-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gmp-devel
21 BuildRequires:  libpcap-devel >= 2:0.9.4-1
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libwiretap-devel
24 BuildRequires:  ncurses-ext-devel
25 # it uses internal structures - so strict deps
26 %requires_eq    libpcap
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Kismet is a 802.11b wireless network sniffer. It is capable of
31 sniffing using almost any wireless card supported in Linux, including
32 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
33 Rangelan, etc), cards which support standard packet capture via
34 libpcap (Cisco), and limited support for cards without RF Monitor
35 support.
36
37 %description -l pl.UTF-8
38 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
39 sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
40 w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
41 (Linksys, Dlink, Rangelan, etc), kart które umożliwiają
42 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
43 wsparcie dla kart bez obsługi Monitora RF.
44
45 %prep
46 %setup -q -n %{name}-%{_ver}
47 %patch0 -p1
48
49 sed -i -e 's#-o $(INSTUSR)##g' -e 's#-o $(INSTGRP)##g' Makefile.in
50
51 %build
52 cp -f /usr/share/automake/config.* .
53 %{__aclocal}
54 %{__autoconf}
55 CPPFLAGS="-I/usr/include/ncurses"
56 %configure \
57         --enable-syspcap \
58         --with-linuxheaders=no \
59         --with-ethereal=%{_includedir} \
60 %ifarch arm
61         --enable-zaurus
62 %endif
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
69
70 %{__make} install \
71         INSTGRP=$(id -g) \
72         MANGRP=$(id -g) \
73         prefix=$RPM_BUILD_ROOT%{_prefix} \
74         exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
75         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
76         BIN=$RPM_BUILD_ROOT%{_bindir} \
77         SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
78         MAN=$RPM_BUILD_ROOT%{_mandir}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc docs/* CHANGELOG CHANGELOG-OLD README TODO
86 %attr(755,root,root) %{_bindir}/*
87 %{_sysconfdir}/*_manuf
88 %{_datadir}/%{name}
89 %{_mandir}/man?/*
90 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}*
This page took 0.074821 seconds and 4 git commands to generate.