]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
- added BR: libstdc++-devel; removed BRs required by other BRs
[packages/kismet.git] / kismet.spec
1 #
2 # TODO: Anybody knows, why it will not build, 
3 #       when kernel-headers are installed?
4 #
5 Summary:        Wireless network sniffer
6 Summary(pl):    Sniffer sieci bezprzewodowych
7 Name:           kismet
8 Version:        2005_06_R1
9 %define _ver 2005-06-R1
10 Release:        0.1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://www.kismetwireless.net/code/%{name}-%{_ver}.tar.gz
14 # Source0-md5:  253ed1e6c2c53e35864385965ef596f6
15 #Patch0:                %{name}-conf.patch
16 #Patch1:                %{name}-pcap.patch
17 URL:            http://www.kismetwireless.net/
18 BuildRequires:  ImageMagick-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gmp-devel
22 BuildRequires:  libpcap-devel >= 2:0.8.1-2
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libwiretap-devel
25 BuildRequires:  ncurses-ext-devel
26 # it uses internal structures - so strict deps
27 %requires_eq    libpcap
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Kismet is a 802.11b wireless network sniffer. It is capable of
32 sniffing using almost any wireless card supported in Linux, including
33 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
34 Rangelan, etc), cards which support standard packet capture via
35 libpcap (Cisco), and limited support for cards without RF Monitor
36 support.
37
38 %description -l pl
39 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
40 sniffowania u¿ywaj±c prawie dowolnych bezprzewodowych kart sieciowych
41 w Linuksie w³±czaj±c w to karty Prism2 wspierane przez projekt Wlan-NG
42 (Linksys, Dlink, Rangelan, etc), kart które umo¿liwiaj±
43 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
44 wsparcie dla kart bez obs³ugi Monitora RF.
45
46 %prep
47 %setup -q -n %{name}-%{_ver}
48 #%patch0 -p0
49 #%patch1 -p1
50
51 cp Makefile.in Makefile.new
52 sed -e 's#-o $(INSTUSR)##g' -e 's#-o $(INSTGRP)##g' \
53         Makefile.new > Makefile.in
54
55 %build
56 cp -f /usr/share/automake/config.* .
57 %{__aclocal}
58 %{__autoconf}
59 CPPFLAGS="-I/usr/include/ncurses"
60 %configure \
61         --enable-syspcap \
62         --with-linuxheaders=no \
63         --with-ethereal=%{_includedir} \
64 %ifarch arm
65         --enable-zaurus
66 %endif
67
68 %{__make} 
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
73
74 %{__make} install \
75         INSTGRP=$(id -g) \
76         MANGRP=$(id -g) \
77         prefix=$RPM_BUILD_ROOT%{_prefix} \
78         exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
79         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
80         BIN=$RPM_BUILD_ROOT%{_bindir} \
81         SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
82         MAN=$RPM_BUILD_ROOT%{_mandir}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc docs/* CHANGELOG CHANGELOG-OLD README
90 %attr(755,root,root) %{_bindir}/*
91 %{_sysconfdir}/*_manuf
92 %{_datadir}/%{name}
93 %{_mandir}/man?/*
94 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}*
This page took 0.126689 seconds and 4 git commands to generate.