]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
- up to 2010_07_R1
[packages/kismet.git] / kismet.spec
1 #
2 # TODO: Anybody knows, why it will not build,
3 #       when kernel-headers are installed?
4 #
5 %define         tarver  %(echo %{version} | tr _ -)
6 Summary:        Wireless network sniffer
7 Summary(pl.UTF-8):      Sniffer sieci bezprzewodowych
8 Name:           kismet
9 Version:        2010_07_R1
10 Release:        0.1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.gz
14 # Source0-md5:  85e59186eb529889118b5635f35cf57d
15 URL:            http://www.kismetwireless.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  bluez-libs-devel
19 BuildRequires:  gmp-devel
20 BuildRequires:  libcap-devel
21 BuildRequires:  libnl-devel
22 BuildRequires:  libpcap-devel >= 2:0.9.4-1
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  ncurses-ext-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  pcre-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  sed >= 4.0
29 # it uses internal structures - so strict deps
30 %requires_eq    libpcap
31 # plugin-btscan.so, not detected automatically for whatever reason
32 Requires:       bluez-libs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         plugins plugin-autowep plugin-btscan plugin-ptw plugin-spectools
36
37 %description
38 Kismet is a 802.11b wireless network sniffer. It is capable of
39 sniffing using almost any wireless card supported in Linux, including
40 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
41 Rangelan, etc), cards which support standard packet capture via
42 libpcap (Cisco), and limited support for cards without RF Monitor
43 support.
44
45 %description -l pl.UTF-8
46 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
47 sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
48 w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
49 (Linksys, Dlink, Rangelan, etc), kart które umożliwiają
50 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
51 wsparcie dla kart bez obsługi Monitora RF.
52
53 %prep
54 %setup -q -n %{name}-%{tarver}
55
56 # make lib64 aware, include exec bits on install
57 %{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
58 %{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
59
60 # make %doc friendly
61 for a in plugin-*/README; do
62         mv $a README.${a%/README}
63 done
64
65 %build
66 cp -f /usr/share/automake/config.* .
67 %{__aclocal}
68 %{__autoconf}
69 %configure
70
71 %{__make} \
72         CLIENTLIBS="-ldl -lncurses -lpanel -ltinfo"  # hack to add -ltinfo
73
74 for plugin in %plugins; do
75         %{__make} -C $plugin \
76                 KIS_SRC_DIR=$PWD
77 done
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
82 for dir in . %plugins; do
83         %{__make} -C $dir install \
84                 DESTDIR="$RPM_BUILD_ROOT" \
85                 KIS_SRC_DIR=$PWD \
86                 INSTUSR=%(id -un) \
87                 INSTGRP=%(id -gn) \
88                 MANGRP=%(id -gn)
89 done
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/* CHANGELOG README README.plugin-*
97 %attr(755,root,root) %{_bindir}/kismet
98 %attr(755,root,root) %{_bindir}/kismet_client
99 %attr(755,root,root) %{_bindir}/kismet_drone
100 %attr(755,root,root) %{_bindir}/kismet_server
101 %{_datadir}/%{name}
102 %{_mandir}/man1/kismet.1*
103 %{_mandir}/man1/kismet_drone.1*
104 %{_mandir}/man5/kismet.conf.5*
105 %{_mandir}/man5/kismet_drone.conf.5*
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
107 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_drone.conf
108 %dir %{_libdir}/kismet
109 %dir %{_libdir}/kismet_client
110 %attr(755,root,root) %{_libdir}/kismet/aircrack-kismet.so
111 %attr(755,root,root) %{_libdir}/kismet/autowep-kismet.so
112 %attr(755,root,root) %{_libdir}/kismet/btscan.so
113 %attr(755,root,root) %{_libdir}/kismet/spectool_net.so
114 %attr(755,root,root) %{_libdir}/kismet_client/btscan_ui.so
115 %attr(755,root,root) %{_libdir}/kismet_client/spectools_ui.so
This page took 0.090416 seconds and 4 git commands to generate.