]> git.pld-linux.org Git - packages/kismet.git/blame - kismet.spec
- Up to the latest version 2011-03-R2.
[packages/kismet.git] / kismet.spec
CommitLineData
bd19fd3a
ER
1# TODO
2# - Anybody knows, why it will not build, when kernel-headers are installed?
7d77e3fc 3#
496b93f1 4%define tarver %(echo %{version} | tr _ -)
ce8d2811 5Summary: Wireless network sniffer
3197fdd7 6Summary(pl.UTF-8): Sniffer sieci bezprzewodowych
ce8d2811 7Name: kismet
d360bfd2 8Version: 2011_03_R2
9Release: 0.1
ce8d2811
AM
10License: GPL
11Group: Networking/Utilities
496b93f1 12Source0: http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.gz
d360bfd2 13# Source0-md5: 8bf077e8111e6dc8c12cadefdf40aadd
74f46803 14Patch0: config.patch
ce8d2811 15URL: http://www.kismetwireless.net/
58c65496
JB
16BuildRequires: autoconf
17BuildRequires: automake
412db6e5 18BuildRequires: bluez-libs-devel
7d77e3fc 19BuildRequires: gmp-devel
412db6e5 20BuildRequires: libcap-devel
399fadea 21BuildRequires: libnl-devel
387a2d36 22BuildRequires: libpcap-devel >= 2:0.9.4-1
6870d034 23BuildRequires: libstdc++-devel
92c7dc22 24BuildRequires: ncurses-ext-devel
412db6e5 25BuildRequires: openssl-devel
26BuildRequires: pcre-devel
9cf4f36b 27BuildRequires: pkgconfig
496b93f1 28BuildRequires: sed >= 4.0
9128618d 29Suggests: %{name}-server
58c65496
JB
30# it uses internal structures - so strict deps
31%requires_eq libpcap
472ae821 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ce8d2811 33
496b93f1 34%define plugins plugin-autowep plugin-btscan plugin-ptw plugin-spectools
89d87381 35
ce8d2811
AM
36%description
37Kismet is a 802.11b wireless network sniffer. It is capable of
38sniffing using almost any wireless card supported in Linux, including
39Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
40Rangelan, etc), cards which support standard packet capture via
41libpcap (Cisco), and limited support for cards without RF Monitor
42support.
43
280f6f5a 44%description -l pl.UTF-8
ce8d2811 45Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
280f6f5a
JR
46sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
47w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
48(Linksys, Dlink, Rangelan, etc), kart które umożliwiają
49przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
50wsparcie dla kart bez obsługi Monitora RF.
ce8d2811 51
9128618d
ER
52%package server
53Summary: Server for Kismet
54Group: Networking/Daemons
55Requires(postun): /usr/sbin/groupdel
56Requires(pre): /usr/sbin/groupadd
57Provides: group(kismet)
58
59%description server
60This package contains kismet_server which you can access with kismet
61protocol compatible clients.
62
ce8d2811 63%prep
496b93f1 64%setup -q -n %{name}-%{tarver}
74f46803 65%patch0 -p1
ce8d2811 66
496b93f1
ER
67# make lib64 aware, include exec bits on install
68%{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
69%{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
70
71# make %doc friendly
72for a in plugin-*/README; do
73 mv $a README.${a%/README}
74done
a824f1d9 75
69914467
JB
76%build
77cp -f /usr/share/automake/config.* .
2be18a10
SZ
78%{__aclocal}
79%{__autoconf}
496b93f1 80%configure
2be18a10 81
c0067f80 82%{__make} \
83 CLIENTLIBS="-ldl -lncurses -lpanel -ltinfo" # hack to add -ltinfo
ce8d2811 84
89d87381 85for plugin in %plugins; do
496b93f1
ER
86 %{__make} -C $plugin \
87 KIS_SRC_DIR=$PWD
89d87381 88done
89
ce8d2811
AM
90%install
91rm -rf $RPM_BUILD_ROOT
1c58060a 92install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir},/var/log/%{name}}
496b93f1
ER
93for dir in . %plugins; do
94 %{__make} -C $dir install \
95 DESTDIR="$RPM_BUILD_ROOT" \
96 KIS_SRC_DIR=$PWD \
97 INSTUSR=%(id -un) \
98 INSTGRP=%(id -gn) \
99 MANGRP=%(id -gn)
89d87381 100done
101
54766e54
ER
102# do what binsuidinstall would do
103install -p kismet_capture $RPM_BUILD_ROOT%{_bindir}
104
ce8d2811
AM
105%clean
106rm -rf $RPM_BUILD_ROOT
107
9128618d
ER
108%pre server
109%groupadd -P %{name}-server -g 180 kismet
110
111%preun server
112if [ "$1" = "0" ]; then
113 %groupremove kismet
114fi
115
ce8d2811
AM
116%files
117%defattr(644,root,root,755)
496b93f1
ER
118%doc docs/* CHANGELOG README README.plugin-*
119%attr(755,root,root) %{_bindir}/kismet
120%attr(755,root,root) %{_bindir}/kismet_client
ce8d2811 121%{_datadir}/%{name}
496b93f1
ER
122%{_mandir}/man1/kismet.1*
123%{_mandir}/man1/kismet_drone.1*
9128618d
ER
124%dir %{_libdir}/kismet_client
125%attr(755,root,root) %{_libdir}/kismet_client/btscan_ui.so
126%attr(755,root,root) %{_libdir}/kismet_client/spectools_ui.so
127
128%files server
129%defattr(644,root,root,755)
496b93f1
ER
130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
131%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_drone.conf
9128618d
ER
132%attr(4750,root,kismet) %{_bindir}/kismet_capture
133%attr(755,root,root) %{_bindir}/kismet_drone
134%attr(755,root,root) %{_bindir}/kismet_server
135%{_mandir}/man5/kismet.conf.5*
136%{_mandir}/man5/kismet_drone.conf.5*
496b93f1 137%dir %{_libdir}/kismet
496b93f1
ER
138%attr(755,root,root) %{_libdir}/kismet/aircrack-kismet.so
139%attr(755,root,root) %{_libdir}/kismet/autowep-kismet.so
140%attr(755,root,root) %{_libdir}/kismet/btscan.so
141%attr(755,root,root) %{_libdir}/kismet/spectool_net.so
9128618d 142%dir %attr(770,root,kismet) /var/log/%{name}
This page took 0.075785 seconds and 4 git commands to generate.